Tagged: 

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #1055442

    Hello support,

    I’ve launched a FB campaign referring to my Enfold site, mindventure.dk.

    Friends and family are calling me to tell me there is a problem with my fonts. That they are being displayed in a strange way as if the browser wont recognise the font and putting in random signs instead.

    So far I have had reports that it’s both working and not working on the respective platforms:
    Google chrome desktop
    Safari Iphone

    Please help me solve the problem as soon as possible!
    Thank you

    #1055477

    can you make a screenshot of what you think is not correct. When i look to your site with chrome or firefox or safari – all browsers are with no major differences

    It sounds a bit as if CORS is the reason why – but i can not see such “glyphs” on your page.
    if it is a CORS Problem ( Cross-Origin Resource Sharing ) you can solve it by adding this to your htaccess file on root directory of your installation ( if you are running on an Apache Server)

    <FilesMatch "\.(eot|otf|svg|ttf|woff|woff2)$">
    <IfModule mod_headers.c>
    Header set Access-Control-Allow-Origin "*"
    </IfModule>
    </FilesMatch>

    on IIS Server Installations it comes to web.config file:

    <system.webServer>
      <httpProtocol>
        <customHeaders>
          <add name="access-control-allow-origin" value="*" />
          <add name="access-control-allow-headers" value="content-type" />
        </customHeaders>
      </httpProtocol>
    </system.webServer>
    #1055490

    Hi again,

    here is the a screen dump

    https://drive.google.com/file/d/1Q3puSHGOu7TkZdrOU0la4RmtK1uFRfvA/view?usp=sharing

    It looks like it wont accept Ø Æ Å in which are Danish letters…

    What do you think is the problem?

    #1055491

    Regarding your prior suggestion for a solution, I have no idea how to do that! Please walk me through!

    #1055493

    I just want to add, that there is no problem on my computer and people tell me that eg on their computer its perfect but not on their phone…

    #1055562

    But this seems not to be CORS conflict but a Charset Conflict:
    We Germans got it with our ö, ü, ä etc

    Read here: (Purchase code hidden if logged out) -shown-correctly/”>https://kriesi.at/support/topic/ (Purchase code hidden if logged out) -shown-correctly/

    Login with ftp and look for wp-config.php

    If there is in it:

    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    – replace it with:

    define('DB_CHARSET', '');
    define('DB_COLLATE', '');

    if it is not in the wp-config.php
    just try first with

    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    (Purchase code hidden if logged out) -shown-correctly/#post-864457″>https://kriesi.at/support/topic/ (Purchase code hidden if logged out) -shown-correctly/#post-864457

    try first this above – only if it does not work go on reading
    __________-

    so you have ftp access to your root directory?
    Login. Some ftp clients do not show hidden files on default it must be activated sometimes.
    if the charset can not solve it maybe you try the CORS thing:
    Filezilla f.e. under Menu – Server – list hidden files.
    the htaccess file is a hidden file and has a dot infront of it and no extension.
    you can download it – rename it to a file without dot and with extension txt so that there is htaccess.txt.
    Open it with a good text editor: sublime text on mac or notepad++ for windows.
    Add this code above to it if your provider server is on apache:

    <FilesMatch "\.(eot|otf|svg|ttf|woff|woff2)$">
    <IfModule mod_headers.c>
    Header set Access-Control-Allow-Origin "*"
    </IfModule>
    </FilesMatch>

    upload that file again to your root. rename the existing .htaccess to htaccess.bak ( or something you can remind well) – rename the newly uploaded file to :
    .htaccess (without extension)

    #1056039

    Hi,

    Thanks for helping out @guenni007, did you try that out and did you have any luck with it @auroraarcus?

    Best regards,
    Rikard

    #1056048

    WordPress character encoding mismatch

    The point is that wordpress (newer versions) uses utf-8 charset encoding.
    If – on different reasons this could happen – you are using on your database a different charset (latin-1 etc pp) these troubles could happen.
    this is known as the double utf-8 Encoding problematc.

    If these little changes of the wp-config file do not solve the problem – or change the problem to another one – you have to edit the tables in your database.
    there are some plugins doing this.

    (Purchase code hidden if logged out)(Purchase code hidden if logged out) “>https://www.tipsandtricks-hq.com/ (Purchase code hidden if logged out)(Purchase code hidden if logged out)

    If the code above in your wp-config.php does not do the trick allone : see here a detailed how to.
    (Purchase code hidden if logged out)(Purchase code hidden if logged out) -encoding-latin1-to-utf8/”>https://theblogpress.com/blog/ (Purchase code hidden if logged out)(Purchase code hidden if logged out) -encoding-latin1-to-utf8/

    On some tips in the internet the lines must be outcoded by //

    //define('DB_CHARSET', 'utf8');
    //define('DB_COLLATE', '' );
    #1056110

    Hi RIkard and Guenni,

    First I tried to overwrite the following:

    define(‘DB_CHARSET’, ‘utf8’);
    define(‘DB_COLLATE’, ”);

    with:

    define(‘DB_CHARSET’, ”);
    define(‘DB_COLLATE’, ”);

    This did not solve the problem.

    I have now tried this instead to see if it solves the problem:
    define(‘DB_CHARSET’, ‘utf8’);
    define(‘DB_COLLATE’, ”);
    changing it out for:

    //define(‘DB_CHARSET’, ‘utf8’);
    //define(‘DB_COLLATE’, ”);

    I want to emphasise that the problem only occurs, when people press a “learn more” button through my Facebook commercial. So normally everyones sees the letters perfectly, but when they push the “learn more” button through Facebook, the problem occurs:

    https://drive.google.com/file/d/1Q3puSHGOu7TkZdrOU0la4RmtK1uFRfvA/view?usp=sharing

    Here is the original commercial with the problem:

    Klar til at finde dit fokus under varme himmelstrøg?Drag med tidligere jægersoldat, Rolf, på en Mindventure kursusrejse! 6 pladser tilbage!

    Gepostet von Mindventure am Donnerstag, 17. Januar 2019

    Do you see the problem when you push it?

    #1056148

    I just want to share, that it seems that this change solved the problem:

    define(‘DB_CHARSET’, ‘utf8’);
    define(‘DB_COLLATE’, ”);

    changing it out for:

    //define(‘DB_CHARSET’, ‘utf8’);
    //define(‘DB_COLLATE’, ”);

    Good luck for the rest of you with the problem. I hope this can add some value for you:)

    #1056287

    Hi AuroraArcus,

    Glad you got it working for you and thank you for sharing! :)

    If you need further assistance please let us know.

    Best regards,
    Victoria

    #1056294

    so my tip with outcoding those default lines in wp-config.php solves the problem.
    this is nice to know – because on (Purchase code hidden if logged out) -shown-correctly/#post-864457″>the former thread the participant don’t give us positiv feedback.

    #1056317

    Hi Guenni007,

    Yes, looks like commenting those lines out solved the problem in this case :)

    Great tip as usual! Thank you:)

    Best regards,
    Victoria

    #1057927

    I thought the problem had been solved as one of my friends told me that he no longer had a problem.

    Then another send me this 2 days later which proves that the problem still is there:
    https://drive.google.com/file/d/1ZG1tW4PKz6Fyl_z0r_PVVMgq_wY07wXX/view?usp=sharing

    Any other solutions to the problem?

    Again, please remember, that the problem only arises when people push the facebook “learn more” button and not when people enter the site.

    Mindventure.dk (working great)
    vs
    https://www.facebook.com/mindventure.dk/posts/229616101159655 (not working all the time)

    #1058236

    Hi AuroraArcus,

    Can you disable caching and minification for now?

    Best regards,
    Victoria

    #1058328

    Hi Victoria,

    I have deactivated “WP Fastest Cache” and “Smush”. Was that what you wanted me to do?

    I have added all the info you need to log on to my site if that is your intention…

    Kind regards,
    Aurora

    #1058820

    Hi AuroraArcus,

    https://cl.ly/17cc30d1f4e5 It shows up fine now when I click the link learn more from FB.

    Please check.

    Best regards,
    Victoria

    #1058828

    Hi again Victoria,

    it shows up great on some devices and on others it fails…

    Could you test it on more devices or might you know what is going on?

    Kind regards,
    Aurora

    #1060166

    Hi Aurora,

    Could you please attach some screenshots of the issue?

    https://www.dropbox.com/s/be6g9ycbzjl6x64/File%2029-01-2019%2C%2020%2042%2051.jpeg?dl=0 Here is the what I see on my iPad. Looks ok. Which devices is it not working on?

    Best regards,
    Victoria

    #1061439

    Hi Victoria,

    looks good as far as Im concerned as well and my friends are telling me that there hasnt been a problem. I believe that it might have been solved with the new update of Enfold, but Im unsure. As of now solved…

    Kind regards,
    Aurora

    #1061995

    Hi,

    Great, glad you got it working again and sorry for the problems. Please let us know if you should need any further help on the topic or if we can close it.

    Best regards,
    Rikard

Viewing 21 posts - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.