Tagged: , ,

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #802596

    Hi,
    I’m putting together a site for a client and have run into an issue when scrolling the homepage in IE or Edge.
    We have 2 colour sections among other content which have a fixed background image.
    These background images shake / judder when scrolling the page using the scrollwheel or the scrollbar (in IE it appears correctly (smooth) if we use the scrollbar).
    Seems OK in Chrome, etc.
    Thanks
    Steve
    Wp 4.7.5
    Enfold 4.0.7

    #802963

    Hi, we have exactly the same Problem here.
    // EDIT
    I found a reference of this beeing a IE bug,
    https://connect.microsoft.com/IE/feedback/details/795070/mouse-wheel-issue-with-position-fixed-images

    But it seems in your demo at: http://kriesi.at/themes/enfold-creative-studio/
    You somehow worked around that issue.

    I’m happy for any hint you can give us.

    • This reply was modified 6 years, 10 months ago by nyloc. Reason: Additional Information
    #804156

    Hi,

    Our demo has the same functionality as the themes that are published.
    DO you have any active cache software?

    Best regards,
    Basilis

    #804197

    Hi,

    DO you have any active cache software?

    No I disabled all caching during development server-side and WordPress wise.
    Other enfold demos using the parallax effect have the same bug. I don’t know why enfold-creative-studio one does not show the error.
    Do you have any idea how to work around this or do I have to live with the fact that the page will look ugly for Internet Explorer users?

    // EDIT
    To add some more information, the demo at http://kriesi.at/themes/enfold-2017/ for example shows the “bug” in the fixed background section.
    And I correct my self the enfold-creative-studio shows the bug in the fixed background section too. This can be resolved by disabling smooth scrolling in the IE settings on the user side (that’s what I did and forgot about) but disabling smooth scrolling makes parallax sections look even worse. Any help is appreciated.

    • This reply was modified 6 years, 10 months ago by nyloc. Reason: More information
    #804451

    I can confirm that we have no cache in place on our build site either.
    Thanks
    Steve

    • This reply was modified 6 years, 10 months ago by Steve.
    #805367

    Hi,

    So u fixed it by disabling the smooth scrolling?

    Best regards,
    Basilis

    #805450

    Yes and no the fixed background stuttering is fixed by the setting but this is on the user side, so it is no real fix as I can not change the IE settings of all my visitors. I really can’t belive that we are the first ones to notice that.

    #807116

    Hi,

    Yea seems so, what version of IE you are using?

    Best regards,
    Basilis

    #807125

    It happens wit all versions of the IE up to the latest if you use the scrollwheel and have enabled smooth scrolling.

    #808241

    Hi,

    Ok, will do report it to our developers so they can check it out.
    Thakn you very much

    Best regards,
    Basilis

    #808470

    Sorry, been away for a few days.
    I’d agree with all Nyloc’s said about the issue.
    Thank you Nyloc for picking up in my absence and thank you Basilis for your attention.
    I look forward to a resolve.
    Regards
    Steve

    #809663

    Hi,

    But it seems in your demo at: http://kriesi.at/themes/enfold-creative-studio/ You somehow worked around that issue.

    The demo is using the element out of the box; there is no “workaround”. Could you please provide a screencast or a short clip of the issue?

    Best regards,
    Ismael

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.