Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1216292

    I tried to share the link to my website on several social media channels, but the featured image does not show up.

    I managed to set a featured image for the Home page (http://digitalservicesact.eu/home), so now when sharing the permalink with “home” on social media, the featured image appears, but not with http://digitalservicesact.eu/.

    Any ideas on how to get the featured image to show when sharing http://digitalservicesact.eu ?

    Perhaps there’s a way of changing the homepage permalink from http://digitalservicesact.eu/home to http://digitalservicesact.eu?

    #1216383

    Hey sheilaregan,

    If you install a plugin like Yoast SEO then you can specify which image you want to display when sharing on social networks.

    Best regards,
    Rikard

    #1216695

    Hi Rikard,

    Thank you for the tip!

    I already had Yoast installed, but hadn’t really used it, so I went to my Yoast tab and was able to get the featured image to show when sharing to Facebook. Thanks!

    However, it isn’t showing on Twitter, and I can’t figure out why. I’ve enabled the Open Graph meta data setting on the Facebook tab inside the Yoast plugin, which works as a foundational setting on the Yoast plugin for all the other social media platforms, and on the Twitter tab I’ve enabled the Twitter card meta data, using “summary with large image” as the default card type to be used.

    As far as I can see, there are no other settings for me to enable on Yoast, and yet the featured image still isn’t showing up on Twitter.

    Any suggestions?

    #1217230

    Hi,

    Thanks for the update. Twitter has a separate tab in Yoast, did you set an image specifically for Twitter?

    Best regards,
    Rikard

    #1218770

    Hi Rikard,
    I did set up the Yoast Twitter tab as much as was possible. The Twitter tab in Yoast works from the Facebook tab as a base. What I mean is, it say on the Yoast Twitter tab: “Twitter uses Open Graph metadata just like Facebook, so be sure to keep the “Add Open Graph meta data” setting on the Facebook tab enabled if you want to optimize your site for Twitter.” And on the Facebook tab I have set the featured image.
    Also on the Twitter tab it has the option to set up the Twitter card, which I’ve done. Here it has the option either to use just a summary, or a summary with large image, and I have gone for the summary with large image option. It doesn’t allow you to designate which image is used though, so I assume it must take this data from the Facebook tab.

    I have taken two screenshots and shared them under this link:
    https://drive.google.com/drive/folders/1RAgcaIB8WoiI5zRRNlnmAZ7MObdNtJXu?usp=sharing

    Thanks for your help!

    Screenshot of Facebook and Twitter tabs on Yoast

    #1218948

    Hi,

    I could only see one of your screenshots, the second one is not working. Anyway, here’s what I see when I edit a page: https://imgur.com/a/HD7Rzzz. It’s clearly possible to set an image which should be used when sharing on Twitter. If you still can’t get it to work then I would suggest that you try reaching out to Yoast support instead, since they know their product better than we do.

    Best regards,
    Rikard

    #1218971

    Hi Rikard,

    Ok, I figured out the problem. I was trying to change the general Yoast settings (in the Yoast menu), but when I looked at your image I realised you were changing the local settings for a specific page. I went to my home page and the Twitter tab is just like in your picture. I added the image there, and now it’s working!

    Thanks!

    You may close this thread.

    #1219086

    Hi Rikard,

    Actually, before you close this thread, there’s another problem now …

    I will describe it shortly in the next message.

    Chris

    • This reply was modified 10 months, 2 weeks ago by  Chris.
    #1219093

    So now the issue has been solved for Twitter, but for some reason Facebook, which was working earlier, now is not showing the featured image any longer.
    I’ve attempted various solutions (e.g. disabling the open graph metadata for Facebook in the general tab but keeping the featured image for the homepage; or clearing the Facebook image for Yoast on the homepage but keeping the open graph metadata for Facebook in the general tab) but nothing seems to work.

    I wonder if you could log in and take a look and try solve it?

    The goal of what I’m aiming for is: to have the homepage banner image show up on Facebook and Twitter posts when I share the http://www.digitalservicesact.eu link.

    Thank you!

    #1219300

    Hi,

    You haven’t set anything in the Facebook tab in Yoast on the front page. Please try filling out all the fields then try sharing it on Facebook again.

    Best regards,
    Rikard

    #1222704

    Hi Rikard,

    This is a bit strange – I’d already tried your suggestion but it hadn’t worked, but now when I tried it again it did work. So now finally everything seems to be working.

    Thanks!

    Chris

    #1222861

    Hi,

    Did you need additional help withi this topic or shall we close?

    Best regards,
    Jordan Shannon

    #1246297

    Yes you can close this thread.

    #1246309

    Hi Chris,

    We’re glad to hear that :)
    Thanks for using Enfold and have a great day!

    Best regards,
    Nikko

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Featured image not showing when sharing URL on social media’ is closed to new replies.