Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #412756

    Hello,

    It’s great to see the Advanced Layout in the editor for Posts now. Although when I create or edit posts using the Advanced Layout Editor the featured image does not show up on the post page.

    Here is an example page:

    http://www.advisormarketingsystems.com/project-earn-what-youre-worth/

    As you can see the featured image shows up on in the post feed here:

    http://www.advisormarketingsystems.com/blog/page/4/

    #413462

    Hey Joshua!

    Thank you for using Enfold.

    All default elements including post meta info, featured image, title etc will be remove when you use the advance layout builder for posts. You need to add it manually using an image element or sliders. You still need to set the featured image if you want it to show on archive or category pages.

    Cheers!
    Ismael

    #414363

    I’m having the same issue and some others. So if I understand correctly. Adding the featured image isn’t enough. I also have to add an element to the top of the page when building the post?

    I’m also having an issue where the sidebar is showing below the post content and the comments section is removed when building a post with advanced layout editor. When I go back and build the same post again with the default editor, it’s fine. Am I doing something wrong or is this a known issue since the update?

    #415364

    Hi!

    That’s how it’s supposed to work. If your using the layout builder for posts then you can build the post to however you want. You can display an image at the start for the “featured image” with our image shortcode and you can use the comments shortcode at the bottom of the post if you want to display comments. It’s meant to give you as much flexibility as possible.

    If your just wanting the post to display how it normally does with featured image, post meta, comments, etc etc, then it would be best to use the default editor.

    Cheers!
    Elliott

    • This reply was modified 5 years, 6 months ago by  Elliott.
    #433171

    What would be the PHP code in my child theme if I want to make the featured image ALWAYS show up even if using the theme builder?

    #433739

    Hey!

    That would take a lot of time and code and would have to be considered custom work. If it was me I would just insert an image element at the top of your page. It’s the same thing.

    Regards,
    Elliott

    • This reply was modified 5 years, 5 months ago by  Elliott.
    #507720

    Bump.

    This is an ongoing problem for several of my clients and your explanation to “just use the default editor” is flawed for the following reasons. Please add it as a feature request.

    • In WordPress, all posts of the same post-type should have a template-able formatting, independent of which editor you choose
    • There is no shortcode to add posts tags or meta to advanced layout editor posts.
    • Using a complex content slider within a post is very tricky using the ‘magic wand’ in default editor. Especially if you want to template the settings for reuse.
    • This reply was modified 5 years ago by  kdagnall.
    #508436

    Hey!

    thanks for your feedback. Feel free to make a feature request here: https://kriesi.at/support/enfold-feature-requests/

    Cheers!
    Andy

    #773311

    Considering this case :

    Featured image is set

    is it a bug or not that the featured image is not in fact being displayed on the individual post page ?

    • This reply was modified 3 years, 5 months ago by  maximaker.
    #774314

    Hi @maximaker,

    Could you post a link to your site and point out where we can see your problem please?

    Best regards,
    Rikard

    #855877

    Hello, is there something new about this options item? Is this a mistake or does it yet work, even though it’s not intended?
    thx Markus

    #855925

    Hi,
    Can you please explain in more detail, perhaps with screenshots?

    Best regards,
    Mike

    #856036

    Hello,
    thanks for replying, i mean isn’t there still any possibility that posts build with the layout builder will show the feature image without an extra image box, because the screenshot from the options dialog from maximaker (“Single post with big preview image(featured image”), reply #773311) implied that this feature was intended. Or is that just a misunderstanding or a “typo”?
    To put it in a nutshell, why is there a possible setting, when it does work on this way? Or is this a setting concerning just pure word posts (not build with layout builder)? Do you know what i mean?
    Thx Markus

    #856055

    Hi,
    This setting is for default editor posts, that is ones built without the layout builder.
    This is by design because when the layout builder is used you are controlling the total design of the page or post.
    Hope this helps.

    Best regards,
    Mike

    #856073

    Alright, thanks, i thought so, at least.

    #856099

    Hi,
    Glad we were able to help, we will close this now. Thank you for using Enfold.

    Best regards,
    Mike

Viewing 16 posts - 1 through 16 (of 16 total)

The topic ‘Featured Image Not Displaying on Post Page’ is closed to new replies.