Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #515470


    I am cross posting content from my blog to Linked In. When I put the URL in the update, it does grab the excerpt., but doesnt show the featured image. Just to confirm that it wasn’t just LinkedIn, I also tested it on Facebook…same problem. I have attached images. Thanks in advance for you help!

    Image URL

    View post on

    • This topic was modified 8 years, 9 months ago by candeos.

    Hey candeos,

    Did you try using a plugin like Yoast SEO to specify an image for social media? If you should have further problem then please send us a temporary admin login so that we can have a closer look. You can post the details in the Private Content section of your reply.



    I am actually using All in One SEO pro. Will that have an impact? I have posted the temp admin credentials.

    Thanks for the help!

    • This reply was modified 8 years, 9 months ago by candeos.


    I’m not too familiar with that plugin but looking at one your posts it looks like it doesn’t have an option for setting images. Could you link to one of the posts you are having problems with so that we can check if we get the same results as you please?

    Best regards,



    You need to have the Social Meta Module panel in the seo plugin to enable the og tags but I don’t see it in the dashboard, must be a plugin conflict. Please contact the plugin author.

    You can also try the jetpack’s open graph settings.

    Best regards,

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.