Tagged: 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1333799

    Hi at all,

    I’m using your theme in one of my clients website. Currently the website use a 7.2 php version and I want switch them to php 8.
    So I made a copy of the website migrate it to a staging system on XAMPP.
    The migration via duplicator run normally but at the end when I want to go to the login I reveived the following message:

    “Fatal error: Unparenthesized a ? b : c ? d : e is not supported. Use either (a ? b : c) ? d : e or a ? b : (c ? d : e) in C:\xampp\htdocs\zr1\wp-content\themes\enfold\functions-enfold.php on line 324″

    I found your threat at “https://kriesi.at/support/topic/deprecated-unparenthesized-a-b-c-d-e-is-deprecated/” and I also made this changes. After this changes I reveived the following message:

    Fatal error: Uncaught Error: Attempt to modify property “config” on null in C:\xampp\htdocs\zr1\wp-content\themes\enfold\config-templatebuilder\avia-shortcodes\slideshow_layerslider\slideshow_layerslider.php:28 Stack trace: #0 C:\xampp\htdocs\zr1\wp-content\themes\enfold\config-templatebuilder\avia-template-builder\php\shortcode-template.class.php(65): avia_sc_layerslider->shortcode_insert_button() #1 C:\xampp\htdocs\zr1\wp-content\themes\enfold\config-templatebuilder\avia-template-builder\php\template-builder.class.php(1305): aviaShortcodeTemplate->__construct(Object(AviaBuilder)) #2 C:\xampp\htdocs\zr1\wp-content\themes\enfold\config-templatebuilder\avia-template-builder\php\template-builder.class.php(427): AviaBuilder->createShortcode() #3 C:\xampp\htdocs\zr1\wp-includes\class-wp-hook.php(303): AviaBuilder->init(”) #4 C:\xampp\htdocs\zr1\wp-includes\class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array) #5 C:\xampp\htdocs\zr1\wp-includes\plugin.php(470): WP_Hook->do_action(Array) #6 C:\xampp\htdocs\zr1\wp-settings.php(578): do_action(‘init’) #7 C:\xampp\htdocs\zr1\wp-config.php(134): require_once(‘C:\\xampp\\htdocs…’) #8 C:\xampp\htdocs\zr1\wp-load.php(50): require_once(‘C:\\xampp\\htdocs…’) #9 C:\xampp\htdocs\zr1\wp-blog-header.php(13): require_once(‘C:\\xampp\\htdocs…’) #10 C:\xampp\htdocs\zr1\index.php(17): require(‘C:\\xampp\\htdocs…’) #11 {main} thrown in C:\xampp\htdocs\zr1\wp-content\themes\enfold\config-templatebuilder\avia-shortcodes\slideshow_layerslider\slideshow_layerslider.php on line 28
    Es gab einen kritischen Fehler auf deiner Website.

    Erfahre mehr über die Problembehandlung in WordPress.

    So I don’t know what to do. And I’m not sure if I can migrate the site to php 8? Thanks for your help

    #1333821

    Hey Flipper5183,

    Which version are you running when you are getting these error messages?

    Best regards,
    Rikard

    #1334844

    Hi Rikard,

    I’m running the latest version of your theme 4.5.5 which I’m updated on 2021-12-21.

    I also using a childtheme.

    Thanks and best regards,
    Philipp

    #1334864

    Hi,
    If you are using v4.5.5 then you will need to update to v4.8.8 to be compatible with PHP v8 & the latest WordPress.
    The reason that the theme update says you have the latest version is because about that version Theme Forest moved from the update API to the Token so you will need to manually update via FTP by downloading v4.8.8 from your Theme Forest account.

    Best regards,
    Mike

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.