Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1215083

    I keep getting this in any thing I try to do in the site. See a plugin description, activate a plugin, delete a widget, save a setting, etc…

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2621440 bytes) in /home/site/public_html/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow_fullscreen/slideshow_fullscreen.php on line 624

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2621440 bytes) in /home/site/public_html/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/product_snippets/product_snippet_meta.php on line 89

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2621440 bytes) in /home/site/public_html/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/progressbar/progressbar.php on line 218

    And so on, errors and more errors.

    It is a clean install, there is nothing, just WordPress and Enfold, nothing else.

    I have assigned 512 in config.

    Is that a bug?
    How to fix it?

    Thanks.

    • This topic was modified 2 weeks, 2 days ago by  peterolle.
    • This topic was modified 1 week, 3 days ago by  Yigit.
    #1215381

    Hey peterolle,

    You are the first users who has reported this so it’s very unlikely that it’s a problem with the theme. You can install these plugins to see what is consuming resources on your installation:

    https://wordpress.org/plugins/query-monitor/
    https://wordpress.org/plugins/p3-profiler/

    Best regards,
    Rikard

    • This reply was modified 2 weeks ago by  Rikard.
    #1215419

    Well, I found 181 results with memory problem, it is really strange I am the first one you noticed.

    https://kriesi.at/support/search/?bbp_search=Fatal+error%3A+Allowed+memory+size

    Have a look I enabled debug and installed both plugins so you can activate them and see. The only things in red are Missing Dependencies JS and CSS from enfold.

    You will have to reload and reload and reload until the site loads.

    If the site loads, just navigate and you will see how non stop errors will start to show up.

    Thanks.

    #1215772

    Hi,

    Yes, and those results range back to 2011, it’s really strange that you didn’t notice that. I’m of course referring to other users having this problem with the current version of the theme and not running any plugins. A lack of memory is a very common in WordPress, so 181 results in 9 years is surprisingly small number.

    I can’t login to your site because of the problem you are having, how can we access your site and check your settings?

    Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 12288 bytes) in /public_html/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/masonry_entries/masonry_entries.php on line 532
    There has been a critical error on your website. Please check your site admin email inbox for instructions.

    Best regards,
    Rikard

    #1215774

    Last 3 threads are from this month and this year. The next 11 threads are not even a year old. So there are people with the same problem.

    Just refresh until it loads and you will be able to see it.

    #1215878

    Hey,

    Your memory limit still seems to be 40M which is too low. Please contact your hosting provider and ask them to increase it. Please increase it to at least 128M and preferably to 256M.

    Regards,
    Yigit

    #1215935

    Thank you Yigit.

    Please share where are you seeing I have a 40M limit.

    #1216020

    Hi peterolle,

    It’s this fatal error that shows it, specifically 41943040:

    Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 12288 bytes) in /public_html/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/masonry_entries/masonry_entries.php on line 532

    Although adding something like this in the wp-config.php file most of the times work (try using lower values like 64M or 128M:

    define( 'WP_MEMORY_LIMIT', '512M' );

    But if it doesn’t please contact your host as they might not permit high memory usage.

    Best regards,
    Nikko

    #1216034

    Why one site has the problem an another one not? using exactly the same in the same server.

    Thanks.

    #1216176

    Hi,

    It may have less active plugins and therefore running less scripts. But you will probably have the same issue with your other site if memory limit is still set to 40M on that one. 40M is simply not enough :)

    Best regards,
    Yigit

    #1216858

    Thank you.

    The strange thing here is that only happens with Enfold. Maybe something you can look out for next releases.

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Fatal error: /config-templatebuilder/avia-shortcodes’ is closed to new replies.