Viewing 30 posts - 1 through 30 (of 30 total)
  • Author
    Posts
  • #1192072

    Hey Guys,
    I updated my enfold theme and got a fatal error in the logging and from the wordpress built-in notification.
    I have tried deactivating all plugins, which didn’t make any difference. I have also selected ‘use WP classic editor’ in the theme options but doesn’t make a difference.

    My site is running on
    PHP 7.4.2
    Enfold 4.7.3
    Woocommerce 3.9.3
    WordPress 5.3.2
    All other plugins are of the latest version.

    The WordPress built-in feature sent me the following details:
    Error Details
    =============
    An error of type E_ERROR was caused in line 13 of the file
    /public_html/wp-content/themes/enfold/config-woocommerce/woo-loader.php.
    Error message: Uncaught Error: Call to undefined function AviaGutenberg()
    in /public_html/wp-content/themes/enfold/config-woocommerce/woo-loader.php:13
    Stack trace:
    #0 ../public_html/wp-content/themes/enfold/functions.php(646): require_once()
    #1 ../public_html/wp-settings.php(497): include(‘/home/deb77506/…’)
    #2 ../public_html/wp-config.php(98): require_once(‘/home/deb77506/…’)
    #3 ../public_html/wp-load.php(37): require_once(‘/home/deb77506/…’)
    #4 ../public_html/wp-admin/admin.php(34): require_once(‘/home/deb77506/…’)
    #5 ../public_html/wp-admin/index.php(10): require_once(‘/home/deb77506/…’)
    #6 {main}
    thrown

    The server log lists more several Fatal errors off:
    Backend fatal error: PHP Fatal error: Uncaught Error: Call to undefined function AviaGutenberg()
    in /public_html/wp-content/themes/enfold/config-woocommerce/woo-loader.php:13
    Stack trace:
    #0 ../public_html/wp-content/themes/enfold/functions.php(646): require_once()
    #1 ../public_html/wp-settings.php(497): include(‘/home/deb77506/…’)
    #2 ../public_html/wp-config.php(98): require_once(‘/home/deb77506/…’)
    #3 ../public_html/wp-load.php(37): require_once(‘/home/deb77506/…’
    #4 ../public_html/wp-blog-header.php(13): require_once(‘/home/deb77506/…’)
    #5 ../public_html/index.php(17): require(‘/home/deb77506/…’)
    #6 {main}
    thrown in /public_html/wp-content/themes/enfold/config-woocommerce/woo-loader.php on line 13

    I hope you can help me to solve this problem.

    Regards,
    Jos

    #1192157

    Hey Jos,

    Please send us a temporary WordPress admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply. Did you try to downgrade the version of PHP you are using? If not then please try using 7.2 or 7.3 for example to see if that changes anything.

    Best regards,
    Rikard

    #1192178
    This reply has been marked as private.
    #1192264

    Hi,

    Thanks for that. You are getting a 500 internal server error on the URL in private. Could you try to disable that to see if that makes any difference?

    To disable WooCommerce carts fragment simply select “Disable Cart Fragmentation” under the WooCommerce section.

    https://perfmatters.io/docs/disable-woocommerce-cart-fragments-ajax/

    If you can’t get into the backend then please rename the plugin folder via FTP, that will disable all plugins. You can then login and activate WooCommerce again and attempt to disable the option from the link above.

    Best regards,
    Rikard

    #1192382

    Hi Ricard,

    I installed the perfmatters plugin and disabled the woocommerce cart fragments. The logging on the server mentions stille the same: PHP Fatal error: Uncaught Error: Call to undefined function AviaGutenberg().
    Don’t know how futher.

    Greats,
    Jos

    #1193444

    Hello,

    Is still get the error! WordPress notifies me too:

    Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

    In this case, WordPress caught an error with your theme, Enfold.

    What can I do??
    Greats,
    Jps

    #1194105

    Hi,

    Sorry for the delay. Are you using the block or Gutenberg editor? Please try to temporarily set the Enfold > Theme Options > Select Your Editor to the second option or the Classic editor.

    Best regards,
    Ismael

    #1194135

    Hi Ismael,

    As mentioned before the ‘use WP classic editor’ in the theme options doesn’t make a difference.
    I downgraded Enfold to version 4.6.3.1 and for now is there no fatal error anymore. But after upgrading Enfold it keeps resulting in the fatal error.

    Best Regards,
    Jos

    #1195381

    Hi,

    Thank you for the update.

    Please try to update the theme again to the latest version, then add this snippet in the functions.php file to disable the plugin configuration.

    current_theme_supports( 'avia_exclude_WooCommerce' )
    

    Best regards,
    Ismael

    #1197535

    Hi,

    Updating from Enfold 4.6.3.1 to 4.7.3 is now without an error in the frontend but de host errorlog still list:
    Backend fatal error: PHP Fatal error: Uncaught Error: Call to undefined function AviaGutenberg() in /home/deb77506/domains/livelycollection.com/public_html/wp-content/themes/enfold/config-woocommerce/woo-loader.php:13

    When the twenty twenty theme is activated or woocommerce is disabled this error isn’t raise

    Kind regards,
    Jos

    #1198226

    Hi,

    Thank you for the update.

    Are you sure that it’s not an old report? Did you add the above snippet in the functions.php file? The snippet should prevent the execution of the woo-loader.php file and prevent the error.

    Best regards,
    Ismael

    #1198316

    Yes i am sure. I first updated Enfold , put the snippets in the functions.php (child theme) and afterwards still got the following error:

    [Fri Mar 27 11:36:58.893706 2020] [lsapi:error] [pid 3828650:tid 139979007055616] [client 141.138.168.124:42668] [host http://www.livelycollection.com] Backend fatal error: PHP Fatal error: Uncaught Error: Call to undefined function AviaGutenberg() in /home/deb77506/domains/livelycollection.com/public_html/wp-content/themes/enfold/config-woocommerce/woo-loader.php:13

    #1198980

    Hi,

    Did you place the snippet in the child theme’s functions.php file? If you don’t have a child theme, try to add it around line 18 of the default functions.php file or below this line.

    if( isset( $avia_config['use_child_theme_functions_only'] ) )	{	return;		}
    

    Best regards,
    Ismael

    #1199025

    Hi Ismael,
    Yes, see me previous message! I placed the snippet in the child theme’s functions.php.
    What are other options to solve this problem?

    Kind regards,
    Jos

    #1199715

    Hi,

    Sorry I missed that info. If you can provide an account for the file server or an FTP account, we’ll try to debug the issue further. Adding that snippet should have prevent the error because it will prevent the woo-loader.php file from loading.

    Temporarily, try to edit the parent theme’s functions.php file and remove this code around line 645:

    if( ! current_theme_supports( 'avia_exclude_WooCommerce' ) )
    {
    	require_once( 'config-woocommerce/woo-loader.php' );			//compatibility with woocommerce plugin
    }
    

    Best regards,
    Ismael

    #1199875

    Hi Ismael,

    Thanks for your reply.
    Temporarily removing the mentioned snippet in the parent theme’s functions.php doesn’t raise the fatal error anymore. However the shop page is now a little bit crunched and the landing page results now in an other error.

    After installation of Enfold 4.7.4 I got still the fatal error in the server logging. The WP health check says now:

    The REST API is one way WordPress, and other applications, communicate with the server. One example is the block editor screen, which relies on this to display, and save, your posts and pages.
    The REST API call gave the following unexpected result: (500)
    There has been a critical error on your website.

    #1201114

    Hi,

    Thank you for the update.

    We temporarily disabled this line of code to prevent the error from occurring, but we got a 403 forbidden error when we try to access the dashboard.

    if( 'block' == AviaGutenberg()->selected_editor() )
    	{
    	require_once( 'class-avia-wc-block-editor.php' );
      }
    

    We tried to disable the plugins by renaming the directory but we still we get the 403 error, so it’s probably related to the server. Did you block certain countries’ access to the dashboard?

    Best regards,
    Ismael

    #1201203

    Hi Ismael,

    Sorry for that.
    Please add your IP address to the <Files wp-login.php> section in the .htaccess file in the public_html directory.

    Thank you,

    Jos

    #1202675

    Hello,
    Can somebody give me support on this subject??
    Thanks,
    Jos

    #1203422

    Hi,

    Sorry for the delay. We still can’t access the dashboard. Please temporarily disable the security configuration so that we don’t have to input our IP address in the .htaccess file.

    Best regards,
    Ismael

    #1203818

    Hi,
    The security configuration is disabled.
    Regards.
    Jos

    #1204606

    Hi,

    Thank you for the update. We didn’t find any errors in the site and the log files aside from a non-critical notice or warning generated from the jquery_diamond_flipbook plugin.

    [17-Apr-2020 04:16:58 UTC] PHP Notice:  Trying to get property 'post_content' of non-object in /home/deb77506/domains/site.com/public_html/wp-content/plugins/jquery_diamond_flipbook/index.php on line 94
    [17-Apr-2020 04:16:58 UTC] PHP Notice:  Trying to get property 'post_excerpt' of non-object in /home/deb77506/domains/site.com/public_html/wp-content/plugins/jquery_diamond_flipbook/index.php on line 95
    

    The shop page looks fine as well. Please check the screenshot below.

    Screenshot: https://imgur.com/a/FxgxnUY

    Best regards,
    Ismael

    #1204770

    Hi Ismael,

    The error still exists!
    The previous time you edited the woo-loader.php commenting the following lines:

    if( ‘block’ == AviaGutenberg()->selected_editor() )
    {
    require_once( ‘class-avia-wc-block-editor.php’ );
    }

    By uncommenting these lines the error is reintroduced:

    2020-04-17T17:56:07+00:00 CRITICAL Uncaught Error: Call to undefined function AviaGutenberg() in /home/deb77506/domains/livelycollection.com/public_html/wp-content/themes/enfold/config-woocommerce/woo-loader.php:13
    Stack trace:
    #0 /home/deb77506/domains/livelycollection.com/public_html/wp-content/themes/enfold/functions.php(646): require_once()
    #1 /home/deb77506/domains/livelycollection.com/public_html/wp-settings.php(514): include(‘/home/deb77506/…’)
    #2 /home/deb77506/domains/livelycollection.com/public_html/wp-config.php(99): require_once(‘/home/deb77506/…’)
    #3 /home/deb77506/domains/livelycollection.com/public_html/wp-load.php(37): require_once(‘/home/deb77506/…’)
    #4 /home/deb77506/domains/livelycollection.com/public_html/wp-cron.php(44): require_once(‘/home/deb77506/…’)
    #5 {main}
    thrown in /home/deb77506/domains/livelycollection.com/public_html/wp-content/themes/enfold/config-woocommerce/woo-loader.php on line 13

    Please have a look again.

    Regards,
    Jos

    #1206092

    Hi,

    Sorry for the delay. We can’t access the dashboard anymore. Did you disable the WordPress account above?

    Are you using the block editor? If you’re not using the new builder, you can keep that line of code disabled for now to keep the error from occurring.

    Best regards,
    Ismael

    #1206159

    Hi,
    Very strange that you can’t login. I have got a message form auditing system that you did login (see the private content).

    Keeping the lines of code disabled for now to keep the error from occurring is a temporary work around. It’s not a definite solution.
    Please take a look again, to come to a solution. Thanks in advance.

    Regards,
    Jos

    #1207434

    Hey!

    We found the issue at the very start of the config-gutenberg > class-avia-gutenberg.php file.

    
    $load_gutenberg = version_compare( $wp_version, '5.0', '>=' );
    if( ! $load_gutenberg )
    {
    	$load_gutenberg = defined( 'GUTENBERG_VERSION' );
    }
    
    if ( ! $load_gutenberg ) 
    {
    	return;
    }
    

    The file doesn’t continue because for some reason the version of your WordPress installation is unknown. Please check the dashboard and you should the text “Version unknown” in the lower right corner.

    Screenshot: https://imgur.com/a/nzFtXFk

    Please try to deactivate the plugins temporarily or download a fresh copy of WordPress, then use it to overwrite the current installation.

    Cheers!
    Ismael

    #1207621

    Hi Ismael,

    Thank you to determine the cause of the error.
    The reason the version of the WordPress installation was unknown is that in the Shield Security plugin the ‘Mask WordPress Version’ configuration was set. Undoing this setting resolves this error.

    Thanks again.
    Jos

    #1207994

    Hi,

    Did you need additional help with this topic or shall we close?

    Best regards,
    Jordan Shannon

    #1208587

    Hi,
    The topic can be closed.

    Regards,

    Jos

    #1208594

    Hi,

    If you need additional help, please let us know here in the forums.

    Best regards,
    Jordan Shannon

Viewing 30 posts - 1 through 30 (of 30 total)

The topic ‘Fatal error caused in enfold/config-woocommerce/woo-loader.php’ is closed to new replies.