Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #1396345


    I have a problem with an Enfold theme installation. I have the error Failed to initialize plugin: avia_builder_button on every post/page I try to edit. Furthermore, on theme options -: general styling I can not choose a color scheme (they are all greyed out).
    The error in console is refering to tynymce
    (Failed to initialize plugin: avia_builder_button TypeError: Cannot read properties of undefined (reading ‘openInstance’)
    at t.<computed>.t.<computed>.createMenuValues (avia-tinymce-buttons-4.js?wp-mce-49110-20201110:40:32)
    at t.<computed>.t.<computed>.init (avia-tinymce-buttons-4.js?wp-mce-49110-20201110:25:26)…..)
    I tried disabling all the plugins, reenabling. Install reinstall wp and theme and many many other and same result. Can you help me with that?


    Hey razvan_trend,

    Thanks for the login details. The Classic Editor plugin might be causing that to happen, could you try deactivating to see if that helps please?

    Best regards,


    Deactivated. Same. From the beginning of WP install (no plugins just the theme) it was the same. Tried different versions of WP and Enfold, same result.



    Thank you for the update.

    We get an error when we try to edit the theme options. Please try to add this code in the functions.php file temporarily, see if it helps.

    add_filter("avf_skip_enqueue_scripts_backend_gmaps", function($skip) {
       return "skip_loading";
    }, 10, 1);
    add_filter("avf_load_google_map_api_prohibited", function($prohibit) {
       return true;
    }, 10, 1);

    Best regards,


    Added the code. Same error.



    Thanks for the update. Could you share FTP login details with us as well, so that we can try to upload a fresh copy of the theme for you?

    Best regards,


    Sent the credentials in private content



    Thank you for the info.

    We managed to get into the server and when we checked the themes folder, the Enfold theme is named differently. Did you do any direct modifications to the theme files? Would you mind uploading a fresh copy of the theme?

    Best regards,


    Fresh copy on site but no change…



    I uploaded our latest dev version that fixes a problem with Google Maps.

    There is a problem with your server sending js files to client. It adds characters that cause syntax errors. These characters are not in the original files.

    I switched theme option to load minified files – and that works. Switching back to unminified again causes the error described above.

    To check with your hoster:

    File themes\enfold\framework\js\avia_advanced_form_elements.js line 811:

    This is what is rendered to browser:

    if(the_value != “” && the_value != null && baseurl) {Â the_value = the_value.replace(‘{{AVIA_BASE_URL}}’, baseurl); }

    instead of

    if(the_value != “” && the_value != null && baseurl) { the_value = the_value.replace(‘{{AVIA_BASE_URL}}’, baseurl); }

    And the same happens to other js files also.

    If you correct it with theme file editor (backspace and add blank) on your server and save the js file the additional character is no longer present.

    I hope this helps your hoster to solve/locate the problem.

    Best regards,


    Thank you. I see that now the theme is working with minified active but I will be in touch with the hoster do dig a little deeper. Thank you again for your support, you are great ;)



    Thanks for the update, we’ll keep this thread open for you.

    Best regards,

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.