Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #219292

    I´m working on my new website and I get extra paragraph which contains an empty a href URL above all headings (h1 to h6).

    This is how the code looks like in firebug. I needed to put [] around the a tag so it would be visible.

    <div class=”avia_textblock ” itemprop=”text”>
    [a name=”trusted-by-the-industry”][/a]
    <h2 style=”text-align: center;”>Trusted by the industry</h2>

    This is how the code is in my text block
    <h2 style=”text-align: center;”>Trusted by the industry</h2>

    Not sure if this is the Theme or simply wordpress adding this extra paragraph and adding white space above all headings.

    I appreciate any help.


    Hey andresandresson!

    Can you post the link to your website and point out the extra element?



    Hi Yigit, thank you for the reply.


    Above the text on the frontpage “Trusted by the industry” is for example this extra Paragraph.

    Also in our feature list is different heading and all have the extra paragraph





    Go to those specific text box elements and switch to the Text tab of the visual editor. Then delete the empty paragraph/link html.

    Best regards,


    Hi Devin,
    I have looked at the Text tab multiple times in all my pages and never found any extra paragraph.

    I did dome more investigating and found out that if I create a new page in Basic mode (and text editor) and add [h] tag I get an empty [a] tag above the heading.
    If I switch to Advanced mode and add a text block (in text mode) and do the same I get the empty [a] and paragraph around it.

    1) here is the page I did in basic mode (text editor)

    2) Here is a new page I did in Advanced mode, text block in text editor

    I have created multiple wordpress sites and never seen this before. Therefore I´m assuming this has something to do with the Theme. I appreciate any comments or thoughts on what might be causing this.

    Thanks again!


    If you can post temporary admin credentials so we can log in and take a look that would be the next step. Nothing within the theme should be doing that and its the first I’ve ever seen or heard of something like it in the 20k purchases of the theme so far.

    Make sure to mark your reply as private with the checkbox for Set as private reply when adding in the login information.

    This reply has been marked as private.

    Once I deactivate all plugins I’m not able to get the issue any longer. Looks like one of the plugins hooks into the theme incorrectly and adds in the code.


    Also make sure to update your theme files to the most recent version so that you have all of our current bug fixes and newest features. For a quick guide on updating your theme take a look at this video on updating the Enfold theme via FTP: https://vimeo.com/channels/aviathemes/67209750



    Thank you so much… I did not even think about look for bad plugins. I found the one causing the problem and got rid of it.

    10/10 Support!


    Glad we could help. Let us know if you have any other questions or issues.

Viewing 11 posts - 1 through 11 (of 11 total)
  • The topic ‘Extra a href above all headings’ is closed to new replies.