Viewing 16 posts - 31 through 46 (of 46 total)
  • Author
  • #596637

    Guys, it’s almost weekend again, PLEASE help me with this!???



    We are working on your ticket please wait while we update the results here soon.

    We have set up an example page for you please check the link in private section.

    Add class “only_desktop” or “only_mobile” to show/hide Advance layout builder elements in mobile or desktop.

    Vinay Kashyap

    • This reply was modified 4 years, 4 months ago by  Vinay.

    Hey Vinnie,

    Thx for your reply. I don’t mind knowing that your busy with my question, but if you don’t tell me that, I don’t know ;-)
    And normally, with all the previous questions, I was helped within a day, hence my impatientness :-P haha
    Sorry bout that, but I’m used to fast communication ;-)

    grt Boris


    Hey Vinay,

    Well, I clicked the link, and logged in and I can see you made the page and put the ‘classes’ in, but I can still see all 3 fiels on desktop AND on mobile!! :-S No matter what browser I’m using… How is that at your end?

    grt Boris



    well of course you need to add this code, to call the new classes:

    @media only screen and (max-width: 767px) {
    .only_desktop {
    display: none;

    Same for the other classes.



    Hey Andy,

    You mean in the Quick Css? Those were in there already for a while now!! C’mon guys, you keep telling me the same things over and over, but they don’t work and I appreciated your help VERY much untill now, but with this subject I get the feeling you guys don’t have a clue why it’s not working!?? :'(

    grt Boris



    Hey this is something really simple we have created an example page here which works perfectly fine! Just resize the page to see content appear and disappear. then look at the backend how it is setup as explained to you in this post earlier.

    See what classes are added in the backend.

    First section is visible in all device
    Second section is visible in desktop only
    Third section is visible in mobile only

    Best regards,
    Vinay Kashyap


    Hey Vinay,

    I understand why it should be so simple, but….

    When I resize your page, I see it change, so that works yes, but not with my page! :-S
    And I see your page work on my desktop, but not on my mobile! There the section doesn’t dissappear!? I have an Iphone 6 with iOs 8

    Below are a few screenshots to show the problem.

    So I know how it works and it should be simple, but I’m doing the same thing as you guys are, but with my things, it’s not working, that is strange, right? Ppffff tiring…

    grt Boris



    We are working on your ticket please wait while we update the results here soon.

    Vinay Kashyap


    Ok thx!



    We checked your installation the code is good!

    We found out the problem was caused by WPRocket plugin it cache the css and you need to empty the cache in the plugin when new css is added so that the changes will reflect in the frontend.

    Vinay Kashyap


    Hey Vinay,

    Ahaaaa, makes sense! Wow, we finally found it haha, what a journey, but you did it again! ;-) Now I’m happy again :-)
    You can close this thread..

    grtz Boris


    Btw, just a last question, if I want something NOT shown on just mobile phones, but on Tablets it should be the same as desktop, is that possible? How many px should I change it too?

    And is it even possible to have 3 options, everything showing on desktop, some things left away on tablet and even more things left away on mob phones?



    Glad you are happy :) and thanks for the kind words.

    Sure you can hide some things on only mobile, tablet and desktops

    We have added the below code in Quick CSS

    Please use only_tablet to hide things on tablets.

    /*Show only in mobile or desktop*/
    @media only screen and (min-width: 769px) {
    .only_mobile { display: none !important; }}
    @media only screen and (min-device-width: 768px)   and (max-device-width: 1023px)  {
    .only_tablet { display: none !important; }}
    @media only screen and (max-width: 1024px) {
    .only_desktop { display: none !important; }}

    Vinay Kashyap


    Cool, thx again! :-)



    Glad we could help you :)

    Vinay Kashyap

Viewing 16 posts - 31 through 46 (of 46 total)

You must be logged in to reply to this topic.