Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1317849

    Hi,
    I have a problem and hope you can help me.
    Since the last enfold update wordpress sends me error-messages:

    It’s the following message:

    Hallo!

    Seit WordPress 5.2 gibt es eine eingebaute Funktion, die erkennt, wenn ein Plugin oder ein Theme einen fatalen Fehler auf deiner Website verursacht, und dich deswegen mit dieser automatisierten E-Mail benachrichtigt.

    In diesem Fall hat WordPress einen Fehler in einem deiner Plugins, WooCommerce, abgefangen.

    Besuche zunächst deine Website (https://www.ak-messer.at/) und überprüfe sie auf sichtbare Probleme. Besuche als nächstes die Seite, auf der der Fehler aufgetreten ist (https://www.ak-messer.at/wp-login.php) und prüfe, ob es sichtbare Probleme gibt.

    Bitte kontaktiere dein Hosting-Unternehmen, um Unterstützung bei der weiteren Untersuchung dieses Problems zu erhalten.

    Wenn deine Website fehlerhaft zu sein scheint und du nicht mehr wie gewohnt auf dein Dashboard zugreifen kannst, hat WordPress jetzt einen speziellen „Wiederherstellungsmodus“. Auf diese Weise kannst du dich sicher in deinem Dashboard anmelden und weitere Untersuchungen durchführen.

    https://www.ak-messer.at/wp-login.php?action=enter_recovery_mode&rm_token=p06cu21HxGnfKPDrYr4oPI&rm_key=WhfqOtUYozJqZaHnlSuI8J

    Um deine Website zu schützen, läuft dieser Link in 1 Tag ab. Aber keine Sorge: Ein neuer Link wird dir per E-Mail zugeschickt, wenn der Fehler nach Ablauf der Frist erneut auftritt.

    Wenn du Hilfe bei diesem Problem suchst, wirst du möglicherweise nach einigen der folgenden Informationen gefragt:
    WordPress-Version 5.8
    Aktuelles Theme: Enfold (Version 4.6)
    Aktuelles Plugin: WooCommerce (Version 5.6.0)
    PHP-Version 7.4.22

    Fehler-Details
    ==============
    Ein Fehler vom Typ E_ERROR wurde in der Zeile 1807 der Datei /home/wp/disk/wordpress/wp-content/plugins/woocommerce/includes/wc-core-functions.php verursacht. Fehlermeldung: Uncaught TypeError: Argument 1 passed to Collator::asort() must be of the type array, bool given in /home/wp/disk/wordpress/wp-content/plugins/woocommerce/includes/wc-core-functions.php:1807
    Stack trace:
    #0 /home/wp/disk/wordpress/wp-content/plugins/woocommerce/includes/wc-core-functions.php(1807): Collator->asort()
    #1 /home/wp/disk/wordpress/wp-content/plugins/woocommerce/includes/class-wc-countries.php(53): wc_asort_by_locale()
    #2 /home/wp/disk/wordpress/wp-content/plugins/woocommerce/includes/class-wc-countries.php(38): WC_Countries->get_countries()
    #3 /home/wp/disk/wordpress/wp-content/plugins/woocommerce/includes/class-wc-countries.php(273): WC_Countries->__get()
    #4 /home/wp/disk/wordpress/wp-content/plugins/woocommerce/includes/wc-core-functions.php(1307): WC_Countries->get_allowed_countries()
    #5 /home/wp/disk/wordpress/wp-content/plugins/woocommerce/includes/data-stores/class-wc-customer-data-store-session.php(129): wc_get_customer_default_location()
    #6 /home/wp/disk/wordpress/wp-content/plugins/woocom

    Also i can’t visit the website, because it says: there is a critical error.
    When i turn off the woocommerce plugin everything works fine, but every time i turn it back on, the same error appears.
    I tried updating everything, deleting cache, turn off the other plugins, but nothing works.

    Maybe i could try downgrading enfold to an older version?
    Please tell me what information you need from me (and also where to find it, cause i’m very new at this).
    Please help me!

    Thanks in advance!

    #1317932

    Hey AK-Messer,

    Thank you for the inquiry.

    The error trace above seems to be incomplete, so we are not yet sure what actually triggers the error. We may have to enable debugging in order to further inspect the issue.

    Please post the FTP details in the private field so that we could edit the wp-config.php file. If you want to enable debug mode yourself, please refer to the following documentation.

    // https://wordpress.org/support/article/debugging-in-wordpress/#wp_debug_display

    You have to set WP_DEBUG and WP_DEBUG_DISPLAY to true.

    Best regards,
    Ismael

    #1317991

    Hi Ismael,

    Thanks for your answer and your help!
    Here are my FTP Details.

    #1318223

    Hi,

    Thank you for the update.

    The SFTP account above does not have write permissions, so we are not able to edit the wp-config.php file. You have to set WP_DEBUG constant to true.

    define('WP_DEBUG',              true);
    define('WP_DEBUG_LOG',          true);
    define('WP_DEBUG_DISPLAY',      true);
    

    We get this error when we try to edit the files.

    /dir/wordpress/wp-config.php: open for write: permission denied
    Error:	File transfer failed
    

    Best regards,
    Ismael

    #1318336

    I’m an IT dummy so i’m not sure what to do.
    I turned on the WP Debug in my raidboxes account. Is that what you meant? If not, please descripe to me what to do in an easy way. Thanks for your patience!

    Regards

    #1318594

    Hi,

    You may have to ask your hosting provider to adjust the above SFTP account and give it the proper permissions so that we could modify the wp-config.php file in the root directory and enable debugging, or just ask them to enable debugging.

    I turned on the WP Debug in my raidboxes account

    We are not really sure if enabling that option will enable both WP_DEBUG_DISPLAY or just the error log. Anyway, we have checked the error logs and found the error in the enfold/framework/php/function-set-avia-frontend.php file around line 74. We also noticed that the theme is outdated. You will have to upgrade the theme from version 4.6 to the latest version, 4.8.6.1. The upgrade should help fix the issue.

    Thank you for your patience.

    Best regards,
    Ismael

    #1318787

    Hi Ismael,

    I updated enfold, but the error still occurs.
    I asked raidboxes for proper permission or enabeling debugging. They said that i can enable debug in my dashboard (which i did) and that i can only look at the WP Debug live log within the Dashboard.
    Is there anything else i can do?

    Best regards

    #1318892

    Hi,

    We are now seeing a completely different error in the debug log, which seems to be related to WPCLI commands and the instagram widget from the theme. Are you using the instagram widget? If yes, then you will have to install the Smash Balloon Social Photo Feed plugin.

    [30-Aug-2021 01:47:09 UTC] PHP Notice: Undefined index: avia_key in /home/wp/disk/wordpress/wp-content/themes/enfold/framework/php/class-framework-widgets.php on line 3417
    [30-Aug-2021 01:04:50 UTC] PHP Notice: Trying to access array offset on value of type null in phar:///home/wp/rbsh/wp-cli.phar/vendor/wp-cli/extension-command/src/Theme_Command.php on line 473

    Are you experiencing any issues with the dashboard or the page builder?

    The previous error probably occurred because the WooCommerce Shipping & Tax plugin is still enabled while the base plugin Woocommerce is disabled. We deactivated the plugin temporarily.

    Best regards,
    Ismael

    #1320944

    Hi,

    Sorry, i been absent for some time. I was out of town.
    I don’t use the instagram widget. (at least not to my knowledge).
    I have not noticed any issues with the dashboard or the page builder yet.
    Yes, when all WooCommerce plugins are deactivated, there is no problem, but i really would need Woocommerce to work :(
    What shall i do next?

    best regards

    #1321123

    Hi,

    Thanks for the follow up.

    The base Woocommerce plugin should be turned on before enabling the WooCommerce Shipping & Tax extension. The base plugin is disabled previously, which is probably why the errors occurred. Make sure to enable the base Woocommerce plugin before enabling its extensions.

    Best regards,
    Ismael

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.