Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #671259

    Hi guys,

    After updating WP, theme and plugins this morning I get an error message (in the footer) of my website:

    Notice: Use of undefined constant ICL_LANGUAGE_NAME_EN – assumed ‘ICL_LANGUAGE_NAME_EN’ in /var/www/vhosts/………./wp-content/themes/enfold/framework/php/class-framework-widgets.php on line 73.

    How can I solve this?

    Thanks & regards,


    Hey Monique,

    Please send us a temporary admin login so that we can have a closer look. You can post the details in the Private Content section of your reply. You could try deactivating all plugins to see if it’s coming from one of them.



    Hey Rikard,

    See below.

    After posting this topic I continued a little search myself and think it may have to do with Polylang plugin. In the support forum for Polylang I found (Purchase code hidden if logged out) -malformed-wpml-configxml-files”>following message Could this maybe have to do with the error message I see?

    Thanks for your help,



    It has something to do with languages it seems so it might be related, could you try deactivating the plugin to see if it goes away?

    Best regards,


    Hi Rikard,

    When I deactivate the Polylang plugin, the error message disappears.
    However, the error message refers to an Enfold file (wp-content/themes/enfold/framework/php/class-framework-widgets.php on line 73).

    What to do?

    Thanks & regards,



    Yes, this is related to the polylang plugin. Please try this in the functions.php file to remove the error.

    $plang = pll_current_language('name');
    define ('ICL_LANGUAGE_NAME_EN', $plang);

    Best regards,


    Hi Ismael,

    Great, that solves the problem!

    You can flag this topic as closed.

    Thanks & have a nice day,

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Error message after update’ is closed to new replies.