Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #685242

    Hello,

    I’m using Enfold with WPML (English and French) and have added fontawesome and flaticon icons.
    I have set separate sub-domains for languages.

    When I insert a fontello icon in a post, it is well displayed in both languages.
    When I insert another icon, it is well displayed in English but not in French.

    Here are links for you in a test environment where you can clearly see what happens.
    All plugins have been disabled except WPML.

    > English : https://test.ethiopiatropicaltours.com/
    > French : https://testfr.ethiopiatropicaltours.com/

    This happens only if I use sub-domains per language. If I use folders per language, it works well.

    Thanks !

    Bérangère

    #687001

    Hey caudebert,

    I am not able to switch to French so i could not see the issue. Can you please post a screenshot and show the issue?
    You can upload your screenshots on imgur.com or Dropbox public folder and post the links here.

    Best regards,
    Yigit

    #687051

    Hi Yigit,

    sorry I provided the links to the home page and not to the test post.

    Here you are :

    French version : https://testfr.ethiopiatropicaltours.com/test-icon-fr/
    English version : https://test.ethiopiatropicaltours.com/test-icon/

    Bérangère

    #687439

    Hi,

    Please refer to this post – http://kriesi.at/documentation/enfold/enable-cors/

    Best regards,
    Yigit

    #687535

    Hi Yigit,
    I have made the change in the .htaccess file, it works now for the fontawesome icon but not for the one from flaticon :
    https://testfr.ethiopiatropicaltours.com/test-icon/

    I have added icons from Flaticon ollowing those instructions :

    and it works perfectly except with WPML multi-domains.

    FYI : I have updated the test site to the latest Enfold version. No plugins (except WPML) and no child theme currently activated on the test site.

    Bérangère

    • This reply was modified 7 years, 9 months ago by caudebert.
    #688899

    Hi,

    We can still see the same error:

    https://test.ethiopiatropicaltours.com’ has been blocked from loading by Cross-Origin Resource Sharing policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource. Origin ‘https://testfr.ethiopiatropicaltours.com’ is therefore not allowed access.

    On which domain did you put the .htaccess file and the CORS fix? It should be added to the “testfr” domain.

    Best regards,
    Ismael

    #689075

    Hello Ismael,

    Yes the change in the .htaccess has been done in the relevant domain.

    In parallel I have reinitialised the .htaccess file, re-entered the lines for the CORS fix, and then deleted and reinstall all plugins which write into the .htaccess file (WP Rocket, Wordfence, Move Login) and now IT WORKS.

    I have applied the same method to the live site and it also works.

    Problem solved : Thanks for the support !

    Bérangère

    #690107

    Hey!

    Great! Glad it is working now. :)

    Cheers!
    Ismael

Viewing 8 posts - 1 through 8 (of 8 total)
  • The topic ‘Enfold with WPML : Fontawesome icons don't display’ is closed to new replies.