Tagged: 

Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #456127

    Dear sirs,

    First of all thank you for a great work you are doing with Enfold theme.

    Several months ago I started having problems when trying to make an automatic update of Enfold theme. Everytime I try to do it, following error occurs:

    An error occurred while updating Enfold: Download failed. Could not open handle for fopen() to C:\*******\*****\***********/enfold.zipAWSAccessKeyIdAKIAJYG5ROGJ6X7Z3M6QExpires1433769399Signature0v3kvHNcFVPtAVq52ohXUvwaiBI%3Dresponse-content-dispositionattachment%3B-filename%3Dthemeforest-4519990-enfold-responsive-multipurpose-theme-wordpress_theme.tmp

    (asterixes in path are just replacement of real directory names)

    We are running the website on Windows Server 2008, IIS 7.5. I have checked directory permissions, PHP setup as well as WP-config. Unfortunately I was not able to find a solution.

    There are no problems with plugin updates, only Enfold theme comes with an error message.

    Would you please advise me what to do?

    Thanks.

    • This topic was modified 8 years, 8 months ago by Maximus_.
    #456427

    Hi Maximus_!

    Are you getting that error every time or just occasionally? If you want to update manually instead: http://kriesi.at/documentation/enfold/updating-your-theme-files/

    Best regards,
    Rikard

    #456479

    Hi Rikard,

    I get the error everytime I try to do automatic update of the Enfold theme. It started several months ago. Before that it was working without problems.

    Yes, the manual update is working – it is how we are doing the update last months. However it is not very comfort way and we would really need your help to find a solution.

    Do you have any idea?

    Kind regards,

    Max.

    #456574

    Hi!

    Could you please provide us with a temporary admin login so that we can take a closer look? You can post the details here as a private reply.

    Best regards,
    Rikard

    #456679
    This reply has been marked as private.
    #456960
    This reply has been marked as private.
    #457092
    This reply has been marked as private.
    #457648

    Hi Rikard,

    do you have any news in this matter?

    Regards,

    Max

    #457709

    Hi Max!

    Please contact your service provider and ask them to enable “allow_url_fopen” in php.ini file. Also, please make sure that your API key is correct – http://kriesi.at/documentation/enfold/updating-your-theme-files/


    @organicanita
    You can activate child theme and go to Enfold theme options > Import & Export and click “Import Settings from your Parent Theme” button to import parent theme settings. If you have more questions, please start a new thread ( https://kriesi.at/support/forum/enfold/#new-topic-0 ) as your issue is not the same as the one OP having :)

    Best regards,
    Yigit

    #457915

    Dear Yigit,

    The API is correct. I have re-checked it now. Moreover, we didn’t change it for many months therefore I guess that this error has nothing to do with API key. Did you find any reason why you ask to check it? Or can you see any problem there?

    I am administrator of the server and ofcourse i tried to play with the allow_url_fopen option before without positive results. Now the “allow_url_fopen” it is turned on again and the problem is still there.

    We changed nothing, and it is only Enfold theme that we are not able to autoupdate – even though before it was warking flawlessly.

    Everything looks to be good from WP point of view. Maybe it is a bug in Enfold updating system.

    Do you have any idea?

    Best regards,

    Max

    #457922
    This reply has been marked as private.
    #458185

    Hello Rikard,

    do you have any news in this matter please?

    Max

    #458191

    Hey!

    I have checked your web site. The %#D characters that generate on your web site, do not work on linux, so the URL provided is wrong. You need probably to activate something, but I am not a sysadmin so I do not know how to convert those characters on the URL string.

    The solution for now would be to update manually, as my colleagues sayed.

    Cheers!
    Basilis

    #458197

    Hey!

    Enable the allow_url_include directive then test it again. You can ask your hosting provider to change it for you or add this in the .htaccess file:

    php_value allow_url_fopen on
    php_value allow_url_include 1

    If it doesn’t work, try to increase the post_max_size to at least 15M. It is currently set to 8M. Again, you can ask your hosting provider to adjust the value or add this in the .htaccess file:

    php_value upload_max_filesize 15M
    php_value post_max_size 15M

    You need to shift refresh every time you change a php directive. I think increasing the php_value post_max_size to 15M will fix the issue.

    Best regards,
    Ismael

    #458217

    Hi guys,


    @Basilis

    The wordpress website is installed on Windows Server 2008, IIS 7.5, not on the Linux. I have mentioned it in my first post with problem report.

    Manual update does work, ofcourse. But it is not a solution of the problem! It is only a “fallback option” to keep Enfold updated. Moreover it is very uncomfortable way of updating. Automatic updates was working and should be working. Please, let’s focus on finding a real solution of the error.


    @Ismael

    I am the administrator of the server where our WP website is being hosted. I will try your ideas and let you know.

    Max

    #458232

    @Ismael
    I have changed PHP values according to your advise and unfortunately the automatic update of Enfold theme still displays the same error. Please see:

    An error occurred while updating Enfold: Download failed. Could not open handle for fopen() to C:\*******\*******\********/enfold.zipAWSAccessKeyIdAKIAJYG5ROGJ6X7Z3M6QExpires1434088548SignatureW3hE20NIJwUavO76wgDwIEOahiw%3Dresponse-content-dispositionattachment%3B-filename%3Dthemeforest-4519990-enfold-responsive-multipurpose-theme-wordpress_theme.tmp

    Both php_values upload_max_filesize and post_max_size are now 15M..

    The idea of Basilis about the %#D characters might be a good one. It looks like a generator of the link inside enfold updater is adding blank characters to the link with downloaded ZIP file. Can you check it please?

    I don’t want to upgrade the Enfold theme until we find the real cause of the problem. As soon as it would get updated, we would loose possibility to eliminate things to find real solution.

    What are your next ideas friends? What should I do now?

    Small remind: I am running the website on Windows Server 2008.

    #458249

    Hi!

    Since you are the administrator, I’m sure you restart the server after you change the values? Or at least wait for a few minutes for it to take effect.

    1.) Please check the php info then look for “upload_tmp_dir” directive, check the file permission of that directory, make sure that it is writable (755).

    2.) Again, restart the server or wait for a few minutes. Or try to add this to the wp-config.php file to override the default tmp folder.

    define( 'WP_TEMP_DIR', ABSPATH . 'wp-content/tmp/') ;
    

    Go to wp-content folder then create “tmp” folder there. Please create a back up or a restore point before doing this. Regarding the characters, you’re seeing a raw url that hasn’t been decoded yet so don’t worry about that.

    Regards,
    Ismael

    #458257

    Hi Ismael,

    Yes, I always perform IISRESET – the full reset of all webservers, including the one with this wordpress website.. Moreover i always check the PHPINFO through above mentioned link to make sure whether all changes has been correctly adapted.

    1) Yes, the directory is writable, I have checked these permissions many times before I went to support forum. Moreover all other plugins or original WP themes are being updated through automatic update system flawlessly.

    2) I know where you are pointing to. But, unfortunately, I tried this too before I have rised this thread (someone mentioned it in Enfold support forum earlier). I have changed the WP_TEMP_DIR also now and here is the result:

    An error occurred while updating Enfold: Download failed. Could not open handle for fopen() to C:\******\*******\*********/wp-content/tmp/enfold.zipAWSAccessKeyIdAKIAJYG5ROGJ6X7Z3M6QExpires1434092383SignaturejwW9OiIQeKLb9k0riAi3Jslj%2BWQ%3Dresponse-content-dispositionattachment%3B-filename%3Dthemeforest-4519990-enfold-responsive-multipurpose-theme-wordpress_theme.tmp

    The error is still there :( ..

    #458264

    Hi!

    I got no bullets left in my pocket. I’ll ask the rest of the support team to check it. Is this “C:\*******\*******\********:” directory same as the value in the upload_tmp_dir value?

    Best regards,
    Ismael

    #458269
    This reply has been marked as private.
    #458734

    Hey!

    Actually, this is not a theme related issue but a server one. Please create an inquiry on Windows Server forums, maybe you’ll find the appropriate solution there. If not, for the meantime, you can update the theme via FTP.

    https://social.technet.microsoft.com/Search/en-US/windowsserver?query=Download%20failed.%20Could%20not%20open%20handle%20for%20fopen()&refinement=9&beta=0&ac=4

    Best regards,
    Ismael

    #458905

    Hi!

    I will close the topic here, as it is not relevant to an Enfold issue, while we did what we could to make it work.

    Best regards,
    Basilis

Viewing 22 posts - 1 through 22 (of 22 total)
  • The topic ‘Enfold theme – problem with fopen() when updating the theme’ is closed to new replies.