Viewing 27 posts - 1 through 27 (of 27 total)
  • Author
    Posts
  • #754112

    Hi, I am unable to edit any of my text in my website as my text boxes won’t allow me to edit or save. If I do manage to edit something and I press save I get a blank screen, my text is still there as if I mouse over it I can see it. It then locks up and I have to restart the whole page. I have upgraded to the latest theme update and I have disabled all plugins but the problem is still there.

    #754288

    Hey biancajolly,

    We would need username and password for your wordpress admin area. the username and password you provided are for the ftp server I assume? (Since they did not work for the admin area)

    Best regards,
    Kriesi

    #754297

    I have put details in private thanks

    • This reply was modified 3 years, 7 months ago by  biancajolly.
    #754780

    Hi did you manage to get into my site to have a look? I really need to change my site but I am unable to change anything.

    #755466

    Hi,

    Your login screen is displaying errors unfortunately, please see private. Could you try renaming the plugin folder via FTP in order to disable all plugins?

    Best regards,
    Rikard

    #755470

    I just managed to log in OK, I have now disabled all plugins is it possible to look asap so I can enable them again?

    Thanks

    #756099

    is it possible to look at this asap, now I have all my plugins disabled google can’t crawl me so I need to get my plugins back up asap and also need to be able to edit my website.

    #756149

    Hi,

    It looks like your initial problem is solved? If so then your can reactivate plugins one by one to see which one is causing the problems.

    Best regards,
    Rikard

    #756166

    Hi Rikard,

    No it is not solved, I have only reactivated Yoast as Google wouldn’t crawl my site. I am still having the same issues with no plugins activated, can you please have a look asap I really need to be able to edit my site.

    Thanks

    #756195

    There is two ways it again starts to work. Change the PHP version to 7.0.x from 7.1.x ..then again change it back to 7.1.x.
    Another option is to make a new user or make another of your users as admin and login to that account, open the page from that account and text box starts to work again.. Very strange!!!!!

    #756272

    Hi Chowdhury, thank you for your solutions, the PHP didn’t work but I did create a new user and it worked for the first page and now won’t work again, same problem with no builder and then when I save the text it won’t save so I try and edit it again but the text is not there and the page locks up and I have to shut it down.

    #756462

    Did you clear your browser cache? Making a new user, or making an user admin, then clearing browser cache and login with that user also work for me.

    #756614

    Hi Chowdhury, yes I have been clearing the browser cache every time I do something new. Just can’t get it to work. I have noticed a few people on this forum are having the same problem.

    #756729

    I found the solution :D. This also explains why a new user able to save text box.
    This is related with wordpress visual editor. Just go to your edit profile, and under Personal Options>Visual Editor… deselect Disable the visual editor when writing. If selected, text box does not allow you to save. By default all new users profiles have the feature of using the wordpress visual editor. Kriesi has to release an update to address this issue. Until then …. :D

    #756734

    Hi Chowdhury, thank you so much for getting back to me so quickly!! My Visual Editor box isn’t checked though.

    #756737

    What also works for me is – select it, save, and then deselect and save it again.

    • This reply was modified 3 years, 7 months ago by  Chowdhury.
    #756740

    I thought the same thing, so I tried it but still didn’t work.

    #756741

    Have you ever used any plugin like “User Role Editor” and modified the role of your admin or editor?

    #756743

    Also ever since I have started having this problem, google has also been having problems crawling my site. They can index my post and category sitemaps but not my page sitemaps. Not sure if these two are linked it is just a coincidence they started happening at the same time.

    #756744

    What are the list of plugins that you use?

    #756748

    No never used a plugin like that, only plugins that were new when this started happening was Optimisation plugins and found that not one of them worked for this site for some reason. I have them on other sites and they make a difference but not on this site. I have since disabled all these plugins as I thought they might be the culprit but still not working.

    #756750

    At the moment I only have Yoast SEO but I had disabled this to test it and it still didn’t work. I did have Use Google Libraries, Async JavaScript, Easy Theme and Plugin Upgrades, Google Tag Installer and One-Click Child Theme also but these are all now disabled.

    #756755

    Async JavaScript might cause a problem, but as you said its disable, so there is no question of that.

    From version 4, css minification does not work, always giving a hard time, specially if you use premium pluging like wp-rocket. Why would I use something else when I already paid for wp-rocket. Wp-rocket not address this issue of minification as it’s not the problem of their plugin, its a problem of enfold version 4. For now, all my css are not minified. So please so check if anywhere minification in enable or not, some servers have server side minification enabled.

    #757460

    Chowdhury I found it!!! After going through every file I could think of I found this in my child themes function.php file:

    add_filter(‘clean_url’,’async_js’,11);
    function async_js($url) {
    if ( false !== strpos( $url, ‘jquery.js’ ) || false === strpos( $url, ‘.js’ )) {
    return $url;
    }
    return “$url’ defer=’defer”;
    }

    Thank you so much for your help, I wouldn’t have found it if you didn’t mention the Async, I really appreciate it.

    #757900

    You are most welcome. :)

    #758139

    My mistake, there was a folder of child theme with some old files, whcih I didn’t notice. I might have put them back in 2014, and forget about it. The minification works perfect now as well as the text box and others.

    #759019

    Hi,

    glad you could help each other!
    Let us know in a new ticket if you have some more questions related to the theme. We are happy to assist you.

    Best regards,
    Andy

Viewing 27 posts - 1 through 27 (of 27 total)

The topic ‘Enfold text block not working even after updating’ is closed to new replies.