Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #758409

    Hi,

    Our sites running the latest version of Enfold are filling our error logs with the following message:
    2017/03/09 13:46:36 [error] 26195#26195: *2863325 FastCGI sent in stderr: "PHP message: script not found:<script type='text/javascript'>var avia_preview = {"error":"It seems you are currently adding some HTML markup or other special characters. Once all HTML tags are closed the preview will be available again. If this message persists please check your input for special characters and try to remove them.","paths":"<link rel='stylesheet' href='http:\/\/www.pronetsweb.com\/wp-content\/themes\/enfold\/css\/grid.css?ver=0.9.5' type='text\/css' media='all' \/><link rel='stylesheet' href='http:\/\/www.pronetsweb.com\/wp-content\/themes\/enfold\/css\/base.css?ver=0.9.5' type='text\/css' media='all' \/><link rel='stylesheet' href='http:\/\/www.pronetsweb.com\/wp-content\/themes\/enfold\/css\/layout.css?ver=0.9.5' type='text\/css' media='all' \/><link rel='stylesheet' href='http:\/\/www.pronetsweb.com\/wp-content\/themes\/enfold\/css\/shortcodes.css?ver=0.9.5' type='text\/css' media='all' \/><link rel='stylesheet' href='http:\/\/www.pronetsweb.com\/wp-content\/themes\/enfold\/js\/aviapop" while reading response header from upstream, client: 172.99.68.144, server: www.pronetsweb.com, request: "GET / HTTP/1.0", upstream: "fastcgi://unix:/var/run/php-fpm/pronetswebsites.sock:", host: "www.pronetsweb.com"

    This isn’t causing issues with our sites but is making our logs unusable.

    #759150

    I am running Enfold, Woocommerce, WP-Rocket, Yoast and have a kind of similar issue.
    The slashes in the enfold css., js urls got all escaped. https:\/\/http://www.dummy.nix\/super. (only the enfold css, js)

    ex:
    href=’https:\/\/http://www.dummy.nix\/wp-content\/themes\/enfold\/css\/custom.css?ver=0.9.5′

    … The broweser translates this in:
    https://http://www.dummy.nix//wp-content//themes//enfold//css//custom.css?ver=0.9.5

    If I turn off wp-rocket, everything is fine. It only affects the Enfold CSS, JS Urls.
    The double slashes also show up in the Apaches Access logs because the Browser loads the double Slash Urls.

    Very strange behaviour. I am not a WordPress Wiz, how should I address this issue.
    WP-Rocket support?

    P.S:
    WP-Rocket also has another new issue. It removes the redirect from the “non” trailing slash Woocommerce Product site.
    Got a lot of duplicate Content recently. Very bad for SEO and the google ranking.
    I just solved it with this solution.
    http://docs.wp-rocket.me/article/ (Purchase code hidden if logged out) -slash-on-urls

    Every thing happens after I updated to the new enfold. I am not sure if these issues are connected.

    If somebody has an idea to that … please let me know.

    #759499

    Hi,
    Thank you @e9 for pointing out this WP Rocket issue.

    Best regards,
    Mike

    #761347

    Hi,

    I have the exact same issue – using the same plugins Yoast Premium, WP-Rocket – I also use Woocommerce on a development site at present, but will need this in production soon. So, the same issues apply.

    I have contacted WP-Rocket support and they pointed out the issue is related to the Enfold theme – Here’s the post of the rocket team reporting this to the Kriesi team: https://kriesi.at/support/topic/wp-rocket-compatibility/

    In the reply it’s mentioned there’s a script which should not be in the Enfold theme – Can you tell me where to find this and I will manually remove it.
    Also if it’s fixed in the next version, when is the ETA?

    Many Thanks

    #761430

    Hi,

    It’s in this file: wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/template-builder.class.php line 325-326:

    $html  = "<script type='text/javascript'>var avia_preview = " . json_encode( array( "error" => $error, "paths" => $output.$icon_font, 'title' => __('Element Preview','avia_framework') , 'background' => __('Set preview background:','avia_framework')) )  . "; \n";
    			$html .= "</script>";

    Hope this helps.

    Best regards,
    Nikko

    #761462

    Hi Nikkio,

    Thank you very much, commenting those out did the trick.
    Cheers!

    #761677

    Hi stop0bit,

    Glad we could help :)

    Best regards,
    Nikko

    #854056

    I have to reopen this.

    How can this problem be actually solved? Commenting out the error message doesn’t do the job for me.

    When I try to defer CSS using WP Rocket (with the critical Path CSS filled in), the site looks terrible. In the console, I am getting the error this topic is about, also with the escaped css files in them and double slashes like e9 pointed out above.

    How can this be fixed? I tried a lot, and currently it seems like Enfold is simply not possible to have its CSS deferred without errors?

    #854888

    Hi alexandervellguth,

    Here are some articles for you to consider:
    http://www.wpbeginner.com/wp-tutorials/ (Purchase code hidden if logged out)(Purchase code hidden if logged out) /
    https://www.wpfaster.org/blog/ (Purchase code hidden if logged out) -and-defer-css-option

    If you need further assistance please let us know.
    Best regards,
    Victoria

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.