Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1296113

    Hello!

    I’ve been trying to apply the page layout options under “header visibility and transparency” to modify the effects of the top navigation bar. For some reason, if I select any of the transparency options, the header still appears static with a black background color. If I select the “header is invisible until the user scrolls down”, the header is invisible but remains invisible even after I scroll down. I checked my Quick Css but couldn’t find anything that looked like it might be overriding and interfering with this – is there something else that I’ve done or need to change which could be causing this?

    Thanks,

    Joe

    #1296266

    Hi jifei,

    Please post us your login credentials (in the “private data” field), so we can take a look at your backend.

    1. Install and activate ” Temporary Login Without Password “.
    2. Go to ” Users > Temporary Logins ” on the left-side menu.
    3. Click ” Create New “.
    4. Add the email address for the account ( you can use (Email address hidden if logged out) ), as well as the ” Role ” making that the highest possible and the expiry about four days
      ( to be sure that we have enough time to debug ).
    5. Click ” Submit “.
    6. You’ll now have a temporary account. Please provide us here in the private section the URL, so we can login and help you out.

    When your issue is fixed, you can always remove the plugin!
    If you prefer to not use the plugin, you can manually create an admin user and post the login credentials in the “private data” field.

    Best regards,
    Nikko

    #1296799

    Hi Nikko,

    Thanks for getting back to me! Apologies for the delay, I just created and submitted the temporary account. Let me know if you have any problems with logging in, since I’ve also been having some trouble logging into my wordpress account recently.

    Even though I’ve checked to make sure that the username and passwords are correct (and created a new account with new login credentials) I am still unable to log in with the wordpress admin page for some reason. I tried disabling the security plugin that I downloaded recently to see if that was causing the issue, but I’m still having issues with the login and have had to go through my godaddy login instead. Any help with the login issues too would be much appreciated.

    Best,

    Joe

    #1297024

    Hi Joe,

    Thanks for giving us admin access.
    The reason why it’s showing like that is because of this code in Quick CSS:

    #header_main {
    background: black !important;
    }

    I have commented it out so it will not execute that code.

    As for the login issues, can you try to change password via phpmyadmin (database): https://www.wpbeginner.com/beginners-guide/how-to-reset-a-wordpress-password-from-phpmyadmin/

    Best regards,
    Nikko

    #1297043

    Thanks Nikko!

    I must have added the code in quick CSS and forgot about it.

    On a related question, I noticed that there is still a black header in the mobile versions of the pages linked below, where I have hidden the main menu. I tried implementing the code from the thread here but the blank black bar still shows up. Is there a way just to disable the black bar on the mobile for just these pages, and not the main menus of all? Additionally, there are some sticky menus on those same pages that work on desktop but that I can only scroll past on mobile. Can I get these to stick to the top of the page when scrolling?

    Best,

    Joe

    #1297161

    Hi Joe,

    The black header in the mobile version is caused by this code:

    .responsive #top #main {
        padding-top: 75px !important;
    }

    it’s inside this media query:

    @media only screen and (max-width:767px) {

    I have already commented it out.

    As for the sticky submenu, please refer to Ismael’s answer in this thread: https://kriesi.at/support/topic/force-fullwidth-sub-menu-to-be-sticky-on-mobile/

    Best regards,
    Nikko

    #1297201

    Thanks Nikko looks like that worked well! I tried following the suggestions in the thread you forwarded and disabled the line of code in enfold\config-templatebuilder\avia-shortcodes\menu\menu.js that Ismael was referring to. However it looks like the menu still isn’t sticking on the pages below. Is there something else that I missed?

    Thanks,

    Joe

    #1297446

    Hi Joe,

    Can you try to disable Javascript file merging and compression in Enfold > Performance?
    If you have any caching plugin please flush out the cache, as well as clear browser cache.

    Best regards,
    Nikko

    #1297614

    Hi Nikko,

    I followed your instructions and disabled the Javascript file merging and compression and cleared my mobile browsing cache, and tried on a few other mobile devices as well. For some reason the mobile menu is still not sticking to the top. I don’t think I have any caching plugins activated, but I’m also not completely sure if some of the plugins I do have are performing some sort of caching – please advise.

    Thanks again,

    Joe

    #1297830

    Hi Joe,

    There are generally two types of plugin that have some caching component in them, caching plugins and optimization plugins.
    Can you give us FTP access? so we can check on it further.

    Best regards,
    Nikko

    #1298072

    Hi Nikko,

    I renewed general access to the site in the link below. I haven’t been using any FTP plugins for the wordpress site, do I need to set that up for you to test out?

    Thanks,

    Joe

    #1298294

    Hi Joe,

    Yes please setup FTP access, you won’t need a plugin for that.
    This article might help: https://www.greengeeks.com/support/article/getting-started-ftp-accounts-cpanel/
    Also please extend the time for the admin access.

    Best regards,
    Nikko

    #1298355

    Hi Nikko,

    I extended the admin access and have included the FTP details below. Let me know if this works

    Best,

    Joe

    #1298960

    Hi Joe,

    Thanks for giving us FTP access.
    It seems the code works only if Mobile Menu Display is not Display full menu (works best if you only got a few menu items)
    It would need a lot of rework for the js file in order for it to work in Display full menu (works best if you only got a few menu items)
    The only workaround I could find is via CSS (this should result similar with the screenshot in private content):

    @media only screen and (max-width:767px) {
      .responsive #top.page-id-6383 #sub_menu1,
      .responsive #top.page-id-6081 #sub_menu1 {
        top: 0 !important;
        position: fixed !important;
      }
    
      .responsive #top.page-id-6383 .sticky_placeholder,
      .responsive #top.page-id-6081 .sticky_placeholder {
        display: none;
      }
    
      #top .mobile_menu_toggle {
        color: white !important;
      }
    }

    Best regards,
    Nikko

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.