Tagged: ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #317487

    I can’t seem to make my heading fonts any bolder than 400. I’m using Open Sans, and I know there is a bolder version (I used Open Sans Extra-Bold in my site mockup), but it’s not showing up.

    I’ve tried…

    font-weight: 900;

    and

    font-weight: bold;

    I’ve also tried and adding !important as well as putting the <strong></strong> tag around the text.

    Any pointers?

    • This topic was modified 5 years, 8 months ago by  zerozendesign.
    #317525

    Hi David!

    Insert this code into your child theme functions.php file:

    
    add_filter( 'avf_google_heading_font', 'avia_add_heading_font');
    add_filter( 'avf_google_content_font', 'avia_add_heading_font');
    function avia_add_heading_font($fonts)
    {
    $fonts['Open Sans'] = 'Open Sans:400,600,700,800&subset=latin,latin-ext';
    return $fonts;
    }
    

    If you want to add it to enfold/functions.php insert it directly below this code:

    
    <?php
    global $avia_config;
    

    Afterwards go to Enfold > Theme Options and you should be able to use the 600, 700 and 800 weight too.

    Best regards,
    Peter

    #317577

    I added that code to my child theme functions.php and it still doesn’t seem to work… thoughts?

    Thanks in advance!

    #317822

    Hey!

    Please use this on Quick CSS or custom.css:

    #top .av-main-nav > li > a {
    font-weight: bold !important;
    }

    If that code doesn’t work alone, add this on functions.php:

    function add_opensans_script(){
    ?>
    <link href='http://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800' rel='stylesheet' type='text/css'>
    <?php
    }
    add_action('wp_head', 'add_opensans_script');
    

    Best regards,
    Ismael

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.