Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #309423

    I use Enfold on two sites, and I have confirmed that this problem affects both sites, both on different hosting. When I upload a .png file into the featured image slot, I get an HTTP error and the upload does not go through. If I refresh the page, the upload did in fact happen, and the document is in my media library. If I attach it as a featured image, it does not display in the post edit backend. It does not show in the front end single view. It DOES show in the blog roll. It also does show in the backend post list.

    On the post edit backend where the featured image should be there is one period. If i right-click inspect element, this is the code:

    <p class="hide-if-no-js"><a title="Set featured image" href="" id="set-post-thumbnail" class="thickbox"><img width="1" height="1" src="" class="attachment-266x266" alt="Buyer Intent and the Longtail Keyword" title="Buyer Intent and the Longtail Keyword"></a></p>

    If I look at that link to the image, the link is valid. I can even click the link and follow the image to the backend, and it shows up just fine. It seems as if something in the theme is hiding it from the single blog view and from the post edit backend.

    Here are some screenshots:


    And here is the blog, if needed:



    The generic ‘http error’ that WordPress can spit out when uploading images is unfortunately incredibly difficult to debug. If you have any common plugins or setups between the two sites first try deactivating them before anything else.

    Its definitely not something we’ve had any bug reports for at this point so it will most likely be something on the server side (if its a common server) or in a plugin conflict/install setup.



    I think it started happening on the last Enfold update, when the lightbox changes were made- to be honest. If I publish the post and go to the front end, the image IS there. Go see for yourself:

    <div class="big-preview multi-big"><a href="" class="lightbox-added"><img width="1" height="1" src="" class="attachment-entry_without_sidebar wp-post-image" alt="Buyer Intent and the Longtail Keyword" title="Buyer Intent and the Longtail Keyword"><span class="image-overlay overlay-type-image"><span class="image-overlay-inside"></span></span></a></div>

    While I agree with you on the HTTP upload error, I think this problem is something different- I believe the theme is hiding my image. Maybe this is your bug report :)


    The image width and height are set to 1 pixel. If I delete those values using Chrome, the image pops up- though it appears in full height versus the normal theme-cropped height.


    I am not 100% positive of this, but it only seems to affect .png files, and not .jpeg.

    Also, if I upload the image using the media uploader, and then go into the post and set it as featured, it seems to work. But uploading and setting as featured while editing the blog post does not.



    Thank you for the update.

    Please try to delete all images on the Media Library that doesn’t have any thumbnails then regenerate the existing images again using this plugin:

    If you have the time, please refer to this link for a possible fix:

    Best regards,

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.