Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #1228608

    Hi everyone.
    I have an issue while trying to use the user email as “from” and “reply-to” on the contact forms of a customer’s website.

    I left the “Your from address” field empty but instead of using the user email or no-reply@***.com it uses the email address I have configured as the sender for Mailpoet (and only that)(and I use their server for the newsletters and the woocommerce emails).

    Do you know I can find a workaround for the contact form because it is way more friendly to have the “from” and “reply-to” adress of the user and just having to click “reply” instead of copy/pasting the email each time (my client have around 50 requests per day).

    Thank you very much for your support.


    Hey arsenelesueur,

    Please send us a temporary WordPress admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,


    Hi Rikard,
    you will find attached the temporary credentials to access the website admin.

    Please keep in mind that this is a french production site while conducing your tests (please prefer local night time if it can disturb customers navigation).

    Best regards



    We are sorry for the late reply!

    On my testing installation, I set from address in Mailpoet and left “Your from address” field in Contact Form settings empty and it worked for me.

    Do you have a staging site or could you create one so we can test further on your site? We would not like to test on your live site as we are going to need to change “Your email address” :)



    Hi yigit.
    The problem occus only while you use their premium service that redirects every woocommerce email through their own server. It seems to overwrite the sending process of WP and/or the Enfold contact form.

    Do you have a way to force the sending method for your theme ?

    Thank you.



    Hi Arsène,

    You might want to write to Mailpoet’s support, maybe they will give you guidance on the issue.

    Best regards,

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.