Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #174389


    I have WP SMTP (can help us to send emails via SMTP instead of the PHP mail() function) plugin installed and
    have SMTP configured for Google Apps.

    I’m able to receive test emails from the plugin test. This plugin uses wp_mail() to send emails. All SMTP settings
    are correct and I’m able to send emails from WordPress.

    The contact form keep reporting Your message has been sent!, but no message is recieved.

    I added the follwoing code to functions.php, but still no success.

    add_filter(‘avf_form_use_wpmail’, ‘avia_change_php_mail’, 10, 3);

    function avia_change_php_mail($active, $new_post, $form_params)
    return true;

    Any other suggestions. Enfold version: Version 2.3.2


    Hello dgoranov!

    Since v2.1 Enfold uses wp_mail() by default and you don’t need this code. The mail code can be found in wp-content\themes\enfold\framework\php\class-form-generator.php and Enfold uses following code

    				$header .= 'From: '. $from . " <".$from."> \r\n";
    				wp_mail($to, $subject, $message, $header);

    to send the mail.




    New member of the forum here.

    It’s been pleasure to create with Enfold but I am also having problems with the contact form not sending emails as well.

    I will have the client take a look at their server settings and explore some other options in addition to downloading the WP_SMTP plug-in and trying that.

    Any suggestions about what we should look at?

    I have version 2.1 installed.

    Thanks you,




    First update your theme to the most recent version so that you have the most recent round of bug fixes and features.

    If you have issues sending mail you may also want to talk to the hosting provider and see if there are limitations on using wp_mail and mail in general through php mail functions.


Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Enfold Contact Form does not send emails’ is closed to new replies.