Viewing 30 posts - 1 through 30 (of 37 total)
  • Author
  • #958847

    Dear Devs,
    I get spam via contact form. I have enabled the captcha – I get spam. I have set a checkbox and mark it to “required” – I get the messages with text in the content “checkbox: false”. And get contactform – messages again. All fields used, telefon, subject, mailaddress.

    How are the messages sent? I cant use my contact form without check the checkbox.

    • This topic was modified 6 years, 1 month ago by SDUS.

    Hey SDUS,

    Could you post a link to the page in question so that we can take a closer look please?

    Best regards,


    Exactly the same problem here. Spam started after last update.
    Spam mail comes with required checkbox: false



    Can you please create a different ticket and add your details there please?

    Best regards,


    Hi everybody,

    the same here – massive Spam-Mails! Captcha is enabled.
    The suggested plugin is no longer available. Anyone an alternative?

    Thanks in advance and best regards,


    Hi Nenad,

    Could you post a link to the page in question so that we can take a closer look please?

    Best regards,


    The same thing. Check the contact form spam bot protection because it is not working properly.


    Hi L,

    Could you post a link to the page in question so that we can take a closer look please?

    Best regards,


    I have the same problem here



    Unfortunately that is not basically an issue of our form, but a problem that does come from your server or site, to be attacked from spam-my links.

    Best regards,


    Our site has recently exhibited the same behaviour via the contact form page. So, are you saying that it is just coincidence that all these posters noticed the same thing around the same time?
    If it is a result of an attack by spam-my links how is that to be averted or dealt with? Any suggestions?


    i always replace the enfold contact form with “contact form 7” and “antispam bee” and captcha – i have never problem with this solution.


    same problem here too. enfold contact form is not blocking the robots with its captcha.
    any Solutions?


    I too have recently seen an increase in spam (from the form) on a number of my sites running Enfold. Never had this issue before & I’ve been with the same host (SiteGround) for some time now.


    Same here. Loads of customers complaining about spam coming in via their contact forms and all of them have the captcha enabled.


    I’m wondering whether it is because Captcha/ReCaptcha has been stopped by Google and now replaced by ReCaptcha v2 And v3?
    Normally you need to set up a Secret Key and ID for your site domain, don’t you? I don’t see that anywhere within the Enfold settings.


    Hi all,

    Here is a thread for you to consider

    If you need further assistance please let us know.
    Best regards,


    Hi Victoria, so your suggestion is to consider using Wordfence or some other plugin?
    I am already using Defender Pro and Akismet and it is still happening. We have a Gravity Form in use and that is not getting any spammy mail it would appear to be only the Enfold generic Contact Form that it attracting spam like moths to flame.
    It could, of course, be a complete coincidence but it only started to occur after the last update we did.
    Can you confirm why the Enfold Contact Form does not require a key id and secret key for the use of Recaptcha?


    Its definitely something wrong with enfold form captcha. robots can bypass it. it will be nice to have google recaptcha with enfold form. for now I have to change all forms to contact 7 and flamingo. hopefully next update they can fix or add google recaptcha.


    Sure, its a bypass. I have change the contact form with another contact form plugin = no Spam.



    Thank u very much for all the feedback.

    Best regards,


    I’ve changed one client who was being flooded with contact form spam to the Contact Form 7 plugin with Google reCAPTCHA and the spam stopped overnight.

    The Enfold contact form Captcha is not blocking spam.


    I have noticed a significant increase in spam also. I very rarely got any spam and now there are 100 x the amount I thought it was because i had moved to another Hosting provider, but actually, it is a better hosting provider than previous.
    It seems a shame to dismiss this as an increase in the Russian population rather than an Enfold specific issue ;)


    Unfortunately this is happening for all our clients since this topic appeared on May 2018. And it is not a server issue because the websites are hosted in different servers including WP Engine, Kinsta and other well known providers. We have to abandon using the Enfold contact forms and change them with CF7 with reCAPTCHA from Google. Using wordfence/sucuri or any 3rd party WordPress plugin is not a fix of the cause. Please escalate this to the dev team asap.


    I have now paid for the Anti-Spam by CleanTalk plugin and that has seemed to stop the spam. I was getting sick of the spam that has filled our inboxes since a recent update. Something broke, as I very rarely received spam before.


    “We have to abandon using the Enfold contact forms and change them with CF7 with reCAPTCHA from Google.”

    We did the same thing and have noticed a huge improvement, almost no spam now.



    We created an enfold recaptcha plugin here:

    This is going to add a recaptcha widget to the theme’s contact form. Get a site and secret key from your recaptcha admin or console, make sure that it is set to V2, activate the plugin and then go to the Enfold > Google Services panel to register your keys. This should mitigate the spams meanwhile or, if we are lucky, prevent it completely.



    Is that plugin compatible with previous versions of theme? Or only 4.4+ covered?



    I haven’t tested that on older versions but it should work as long as you’re using reCAPTCHA V2, not V3.

    Best regards,


    Any chance, to get reCAPTCHA v3 to work with it?

Viewing 30 posts - 1 through 30 (of 37 total)
  • The topic ‘Enfold Contact form and spam’ is closed to new replies.