Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #1395269

    I have recently installed the Cloudinary plugin and everything works except for my background images on color section. The page url is below as well as info to access the page. This is relatively urgent. Thank you.


    Hey virtualbis,

    Thank you for the inquiry.

    There is no selected image in the Styling > Background Image when we checked the color section. Have you tried reselecting the image?

    Best regards,


    You can see the background image in the colour section before opening it but when you open the section , it is no longer there. Please have a look at the video then try it yourself.



    Thank you for the short clip.

    We are not yet sure what is causing the issue, but it might be due to the post css styles. The styles for the color section including the background image are generated correctly but the image URL still points to the local domain instead of Cloudinary. This is the generated style for the color section.

    .avia-section.av-l7a1c31a-38c7edcd1656db1258c1a6ad67074612 {
        background-repeat: no-repeat;
        background-image: url(;
        background-position: 100% 100%;
        background-attachment: fixed;

    We will forward the issue to our channel. For the meantime, you can add the above css in the Quick CSS field and adjust the URL manually using the image URL from Cloudinary.

    Best regards,



    After reaching out to Cloudinary as well they seem to think Enfold is hardcoding the link. I would rather find a fix than do temporary css on each background image as there are quite a few. Please let me know if this is something you can help fix today.

    See below.

    hardcoded on the CSS, our delivery system on the frontend won’t be triggered hence the image not being displayed.

    I believe there might be a way to handle this via the theme probably by replacing the reference with the wp_get_attachment_url which should return a Cloudinary URL.


    I tested it on an installation now – and all images – except the background-images were replaced by the cloudinary images.
    I could not see why this is the fact. Sorry


    Guenni007, sorry, I am confused by your comment. Are you part of support?


    I just reverted to cloudinary and wordpress which is a temporary fix. Could you continue to look into it though so the background images on the colour sections are pulled from cloudinary? Right now they are being pulled from the website.


    Do you only accept responses from developers/mods?
    I tried to find a solution for you – but it is actually the same result on my test environment.



    Thanks for your patience!

    Our developers pointed out that this is related to post file generation. I tested it on my test installation and disabling it works:

    You can add the following code to the bottom of the Functions.php file of your child theme in Appearance > Editor to disable post file generation:

    function custom_avf_post_css_create_file( $create )
    	return false;
    add_filter( 'avf_post_css_create_file', 'custom_avf_post_css_create_file', 10, 1 );

    Best regards,

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.