Viewing 30 posts - 1 through 30 (of 34 total)
  • Author
    Posts
  • #1132306

    Hello there,

    since already a long time ago Enfold causes two update markers that are not correct: One under Dashboard > Updates and one under Plugins. Although everything is updated to the latest versions Enfold causes a “1” in the red circle on both places.

    I thought this would be fixed from update to update but it isn’t. The red “1” is still there. Now – after Enfold update to v4.6 – I want to know when this bug will finally be fixed since it is quite annoying.

    Thank you very much in advance and also thanks for the per se great theme,
    -doffine

    • This topic was modified 3 months, 2 weeks ago by  doffine.
    • This topic was modified 3 weeks, 4 days ago by  Ismael.
    #1132470

    This is not really a mistake. The Advanced Layerslider as a bonus to the theme is not to be found within the plugins. The update notification is correct, but since this is only a bundle and not the standalone plugin, the integrated version always lags a bit behind the current version.

    If you can not live with the update notification you can hamper its function on that “Plugin”- put this to child-theme functions.php:

    //Remove layerslider update nag
    function remove_ls_update_notification($value) {
    	if($value) {
    		unset($value->response['https://YOUR-DOMAIN/wp-content/themes/enfold/config-layerslider/LayerSlider/layerslider.php'] );
    		return $value;
    	}
    }
    add_filter('pre_site_transient_update_plugins', 'remove_ls_update_notification');

    complete the absolute path by “your-domain”

    #1132785

    Hi,

    Thanks for sharing and for helping out @guenni007, did you have any luck with that @doffine?

    Best regards,
    Rikard

    #1133098

    @guenni007, thank you so much. This solves our problem perfectly.

    @rikard, we cannot understand why Enfold doesn’t do this on itself. Since you cannot upgrade anything after all when you see this update notification it litters up the admin backend with useless information. At least there should be a checkbox to deactivate this in Enfold. Or even better – integrate the filter of @guenni007. We remember that we are not the first ones coming up with this “problem” in the years.

    Here is the modified code from @guenni007 so that you don’t have to replace the current domain path – perhaps it can be useful for someone (this code is for the case when WordPress resides in the domain’s root)…

    function remove_ls_update_notification($value) {
    	if($value) {
    		unset($value->response['//'.$_SERVER['HTTP_HOST'].'/wp-content/themes/enfold/config-layerslider/LayerSlider/layerslider.php']);
    		return $value;
    	}
    }
    add_filter('pre_site_transient_update_plugins', 'remove_ls_update_notification');
    • This reply was modified 3 months, 1 week ago by  doffine. Reason: Added the hint that our code is for WordPresses in the domain's root
    #1133810

    @doffine

    those pending updates are coming usually from themes, but also from plugins etc.
    For this put this in your functions.php or the Code-Snippets-Plugin:

    https://pastebin.com/4MrfQH5t

    The advantage of this code snippet is, that you see in backend what is causing this “update marker” you mentioned above.
    It will look like this:

    View post on imgur.com

    #1133819

    @colorit
    Thanks for this indeed interesting variant. But it is nothing we think we need for our particular case. We trust Enfold developers that they would instantly supply really urgent third party software updates with an Enfold update, let’s say in terms of a security problem or so. In the meantime we just don’t want to see this annoying update notification all the time – since it doesn’t have any benefit, because we cannot perform any update anyway.

    Enfold’s update notification of this type kinda says “Hey, there’s an update for a software component used in our theme. But ha-ha, you cannot perform it!” That’s bothersome.

    @guenni007 ‘s solution stops this perfectly.

    #1133929

    Thanks Colorit – i will save it in my snippets archiv. You never know if you might need it after all.

    #1134267

    yes it is very helpful. I have a plugin, that – right now – does not work with multisite and when there is an update, I see the marker, but nothing in the normal update list. But with this snippet, I see that it is this plugin. So it is independent from theme or plugins.

    #1151283

    Hello again @guenni007,

    we just noticed that the above code not only makes the Enfold update notification disappear but all other WordPress plugin update notifications disappear, too. So in this way you block all WordPress plugins’ updates effectively without even knowing it. Just try it and you will see it. Do you have an idea how the code can be fixed to only let Enfold notifications disappear?

    Many greetings again,
    -doffine

    #1151351

    @doffine

    yes, his snippet works not correctly. Please use this one:

    https://pastebin.com/aAxiD6CK

    It will then looks like this:

    View post on imgur.com

    and yes, you will see other plugin updates, too, as you can see in the screenshot.

    #1152115

    @BeeCee

    Thank you for your reply. This snippet is interesting, but it doesn’t solve our problem. We just want to get completely rid of these annoying update notifications caused by hidden Enfold components. It is not of help for us to have an area in that we get informed about the cause of the update notification. We simply don’t want to see it anymore.

    Greetings,
    -doffine

    #1152531

    Hi,

    Please check this plugin

    and let us know if issues are solved.

    Best regards,
    Basilis

    #1152540

    Hey @basilis,

    thank you for coming back to us. But this plugin won’t solve our problem. It is not that we don’t want to see ANY plugin update notifications any more. It is that we ONLY don’t want to see this “phantom” update notification(s) caused by Enfolds bundled plugin(s).

    Greetings,
    -doffine

    #1154205

    Hi,

    Thank you for sharing the details and sorry for the delay.

    The “phantom” update notification(s) form bundled plugin cannot be disabled unless you deactivate the plugins.

    You can de-activate bundled plugins from Enfold theme options and install the plugins which you use from the WordPress plugin directory.

    Unfortunately, at the moment there is no other way to stop the update notification from the bundled plugins.

    Best regards,
    Vinay

    #1154299

    Hey @vinay,

    thanks for coming back to us. Have you taken a closer look at the code snippet at #1133098? For us it seems that there might be a possibility to remove update notifications from the backend. Unfortunately the snippet above removes all update notifications at once. But if you look at the code perhaps it seems to be possible to modify it so that only the update notification of one (the bundled one) plugin isn’t shown any more.

    The filter “pre_site_transient_update_plugins” might be the key to this. Would it be possible to check this with one of your developers?

    Many greetings and thanks again,
    – doffine

    #1155502

    Hi,

    @doffine: Did you install layer slider as a stand alone plugin? Have you tried deactivating the integrated version of the layer slider from the Enfold > Layout Builder > Integrated (Bundled) LayerSlider Plugin settings? Deactivating the bundled plugin should disable the notifications if it proves to be a nuisance on your part. If it doesn’t work, the filter @guenni007 suggested above should do the trick.

    Best regards,
    Ismael

    #1156022

    Hey @ismael,

    no we didn’t install it as a stand alone plugin, since we didn’t license it and don’t want to pay for a Layer Slider license just to get rid of the notifications. It’s enough for us to use the bundled version that comes with Enfold.

    Unfortunately the filter @guenni007 suggested doesn’t work – please read my posting #1154299 directly above yours. There you’ll read that @guenni007‘s filter disables ALL plugin notifications in a WordPress, not only the ones of the bundled Layer Slider plugin.

    But: The code of @guenni007 looks like it could be possibly fixed to do what it should: Only to disable bundled Layer Slider update notifications. That’s why I asked you in #1154299 whether you could let your developers check that up.

    Many greetings,
    -doffine

    #1156656

    Hi,

    Thank you for the clarification.

    Unfortunately the snippet above removes all update notifications at once.

    Sorry for missing that info. The filter should only unset notifications from the layer slider plugin. Can we access the dashboard and the file server? We would like to test the filter in your installation. Please post the login details in the private field.

    Best regards,
    Ismael

    #1156789

    Hey @ismael,

    we made use of your suggestion to investigate whether our installations of Enfold use Layer Slider at all and we saw: No – none of our three Enfold installations use this plugin. So we deinstalled it as suggested by you via Enfold > Layout Builder Settings and got rid of this problem one and for all.
    So we cannot provide you a possibility to test it out anymore. But we recommend you to offer a solution for other customers to get rid of this annoying update notification that simply tells a useless “Haha! There is an update, but you cannot install it!”. Best solution would be a checkbox in Enfold settings “Disable update notifications of bundled plugins”.

    We are out now. Thanks for coming back to us in this thread and many greetings,
    -doffine

    #1157821

    Hi,

    Thank you for the info. We’ll forward the request to the team for further considerations. Please don’t hesitate to open a new thread if you need anything else. We’ll close this one for now.

    Have a nice day.

    Best regards,
    Ismael

    #1158032

    Hi!

    @-doffine: I was just notified and informed by @guenter that the removal of the notification is actually embedded in one of the theme’s config file, but it’s only going to work if you’re using the bundled version of the plugin. It has been available since 4.1.3, which is probably why we missed it. It’s located in the config-layerslider > config.php file, look for the handler_remove_layerslider_update_notification function. You can also use the “avf_show_layerslider_update_notification” filter to control the update notification.

    Cheers!
    Ismael

    #1160455

    hi ismael – how to use it: This does not have effect:

    function remove_ls_update_notification() {
    	return 'no';
    }
    add_filter('avf_show_layerslider_update_notification', 'remove_ls_update_notification');
    #1160670

    Hi,

    @guenni007

    Please try to replace enfold\config-layerslider\config.php with

    https://github.com/KriesiMedia/enfold-library/blob/master/temp_fixes/Enfold_4_6_3/layerslider/config.php

    You can remove the filter function above – ‘no’ is the value passed to the filter.

    Best regards,
    Günter

    #1161578

    hey Günter – as far i can see this is only added a condition for an existing standalone layerslider plugin – and that makes sence.
    But we only want to know how to use the existing filter ( avf_show_layerslider_update_notification ) to hamper the update nag of the included layerslider.
    My first thought on: Link – blocks all update nags not only the layerslider one.

    the code we can find here on board:

    function remove_ls_update_notification() {
    	return 'no';
    }
    add_filter('avf_show_layerslider_update_notification', 'remove_ls_update_notification');

    does not work

    #1161827

    Hi,

    @guenni007

    I cannot reproduce the problem on my dev system. It works for me.

    The only idea I have is that file systems could translate to lower case – that would break checking the string as Enfold has upper case elements in directory.

    I changed the logic a little:

    Replace enfold\config-layerslider\config.php with

    https://github.com/KriesiMedia/enfold-library/blob/master/temp_fixes/Enfold_4_6_3/layerslider/config.php

    By default notifications are hidden for the bundled version. The filter is only needed if you want to show notifications also for the bundled.

    Best regards,
    Günter

    #1162068

    Thanks Günter – That worked right away.
    ______
    But what I don’t understand at all, because in the original file, it is noted with “LayerSlider”. So I have it on my server too.
    614 : $layerslider = str_replace( '\\', '/', get_template_directory() . '/config-layerslider/LayerSlider/layerslider.php' );

    In the changed config.php line 633 it now says “layerslider” – and that’s how it runs ??? allthough i got LayerSlider folder.
    633: $layerslider = '/config-layerslider/layerslider/layerslider.php';

    it wouldn’t have bothered me personally, but there are still some customers with admin access who always believe that there is a need for action because of this little red sign.

    For me it is solved now – and can be closed.
    Will this be implemented in a future Enfold version? Certainly not yet into the next one, after Envato hastily announced the new version, which will be released soon.

    #1162070

    By the way: @doffine
    it is not a bug. When that little red 1 shows up, the layerslider has updates – the only error is that this red 1 is displayed in the Plugin Tab, but there is no LayerSlider there.
    I for my part am very satisfied that the Layerslider is included as a bonus in Enfold.
    Or do we want to complain here until it is removed from the package?
    ;) https://www.youtube.com/watch?v=-2iZjxSGca8

    #1162121

    Hi,

    @guenni007

    The update note from Envato is because Kriesi launched the black friday/ciber monday sale – not a real update of enfold.

    The script works because I added a more flexible logic to check for the plugin (comparing both lower case modified strings and only searching with path to our config folder) – see line 635ff the foreach loop.

    It is already merged for 4.6.4.

    Best regards,
    Günter

    #1162167

    Wow – thats nice – one thing not to remember on updating enfold.

    #1162210

    @guenni007,

    hehe, no ;-). For sure it’s cool having Layer Slider as a bonus. It simply is not cool to be shown the red 1 although it is not possible to perform an update.

    As I said further above – the red sign only tells you “Ha-ha! There’s an update for the bundled plugin. But you cannot perform it! Ha-ha!”. As long as there is no possibility to perform an update, a notification for it is nothing else than annoying. At least it should be possible to switch off this notification for the case an admin doesn’t want to be bothered about it.

    We are maintaining 200 WordPress installations (and counting) with several hundrets of different plugins and dozens of different themes. So we are always endeavored to keep all installations at the current update level. It is not helpful to get into an Enfold’s backend and always have to be aware: “Oh, this red 1 doesn’t mean anything.” If all plugins and themes would throw around with unnecessary notifications like this you wouldn’t take notice of these notifications anymore, even if a notification made sense and would be important. So when there is a notification then it should make sense.

    So ok – of course, it is not a bug in the narrower sense. But telling that this is also not “a feature” is clear in our eyes and just a suggestion for improvement for Enfold if you want to follow our above arguments.

    Many greetings,
    – doffine

Viewing 30 posts - 1 through 30 (of 34 total)

You must be logged in to reply to this topic.