Tagged: ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #1363695

    First time using enfold. The images are not rendering as webp despite imagify. I checked the settings in imagify after reading through this forum and I have it on the rewrite option. The images have all been compressed and converted to webp but page speed shows them as .jpg or png. I tried to replace the images directly again with the compressed webp version but there is no change in page speed…still shows them as .jpg or png I have wprocket, rocket cdn ( I tried the second option in imagify and listed the cdn, again no change) and cloudflare in addition and the latest version of enfold 5.1.1. I have cleared all cache from the cdn, cloudflare, wprocket….still no change.

    Can you suggest how to get the images to render as webp and improve my mobile page speed?


    Hey Larrian28,

    Thank you for the inquiry.

    We cannot find the images (k4-kimble-beauty, k-black-beauty-products) listed above. Are you using the Advance Layout Builder? Which builder elements are you using for the images?

    Best regards,


    Using advanced layout builder…color section. the image on the home page that shows the bottle and soap by clean beauty and wellness products is k4 and the banner on all the other pages that is behind the text at the top is the k-black image.



    Thank you for the info.

    It is possible that the plugin cannot convert images to webp when they are applied as background using css, which is how the background image in the color section is applied. According to this article, you have to set the Settings > Imagify > Optimization Webp format to “Use rewrite rules” instead of using the picture tag.

    // https://imagify.io/blog/how-to-convert-images-to-webp/
    // https://imagify.io/documentation/how-to-check-if-webp-image-is-displayed-on-your-site/

    Best regards,

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.