Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #1044832

    Hi

    My hoster provides PHP 7.3, so I did an upgrade of my website to this PHP version (had PHP 7.2 previously).

    The result is the following error message after the backend login:
    No input file specified.

    I guess that Enfold (in my case v4.5.1) is not compatible with PHP 7.3 yet. Is that possible and if yes, when will that be resolved?
    (downgraded to PHP 7.2 now to make the backend available again)

    Best regards and thanks in advance
    Michael

    #1045883

    Anyone? :)

    #1046673

    Hi,

    Thank you for using Enfold.

    We haven’t tested the theme on that version yet. Do you have a staging site where we can see this? Did you flush the permalink or reset the .htaccess file after the upgrade?

    I checked the list of the soon to be deprecated functionalities but I didn’t find anything that would affect the theme aside from the “String search” changes, but I could be wrong.

    // https://wiki.php.net/rfc/deprecations_php_7_3

    Best regards,
    Ismael

    #1046693

    Hi Ismael

    Thanks a lot for your feedback.

    So if you haven’t tested the theme with PHP 7.3 yet, who can tell me when these tests will happen?
    I can setup a staging site and give you access to it as soon as it’s ready, but I think you should do separate tests as well.

    In addition:

    Did you flush the permalink or reset the .htaccess file after the upgrade?

    No I didn’t do any of them. How do I flush the permalinks if I am not able to sign in to the WP backend?

    Thanks
    Michael

    #1046699

    I am using PHP 7.3 and so far there is no issue of login in or anything else. I think it must be one of your plugins that do the conflict, not enfold.

    #1046713

    Hi Chowdhury

    Thank you very much for your input – that’s very valuable!
    As already mentioned I will check it on my staging environment, disable all plugins and then try again.

    Cheers
    Michael

    #1046716

    If it helps, you can give the list of all the plugins you are using then I can point out which are the plugins I don’t use in my website. I am very selective with my plugins and I know them well.

    #1046717

    Yes me too – I currently use the following ones:
    Classic Editor
    Intercom
    Statify
    UpdraftPlus WPML
    Yoast SEO

    Do you think any of them may not be ready for PHP 7.3 yet?

    #1046719

    I am using classic editor and yoast seo, but not the other three – Intercom, Statify, UpdraftPlus WPML

    #1046720

    Alright thanks – I can’t just get rid of them :)
    I will just wait for now until theme and plugins are updated.

    #1046723

    If I were you, I would look at the least popular plugings. Intercom installed only 10,000 times, so there might not be enough users to report the bugs yet.

    #1046827

    Hi Chowdhury

    Thanks again.
    I removed Intercom now but unfortunately still no luck.

    Still getting the same error after changing to PHP 7.3:
    No input file specified.

    Cheers
    Michael

    #1046830

    A default Enfold installation does work with PHP 7.3 on my end.
    Seems like your issue is not directly Enfold related.
    Did you try one of the normal WP themes?

    Test-Site of Enfold with PHP 7.3: => https://enfold.tabulor.de/

    (Purchase code hidden if logged out) .png” alt=”Enfold with PHP 7.3″ />

    Edit: I reverted my Test-Site back to PHP 7.2 … because WordPress itself throwed some errors with PHP 7.3

    • This reply was modified 8 months ago by  cg.
    #1046833

    Sorry I didn’t read your error “No input file specified.” before. If that’s the error then it is related to php settings. First check the open_basedir setting then make sure short_open_tag is off.

    #1046849

    @cg: Ok I see, thanks. So it must have another reason in this case and not Enfold I guess. Did not try another theme yet.

    @Chowdhury: No worries. I am not sure if I can change the PHP settings by myself tough or if it’s enabled by my hoster. I also altered my .htaccess file – no luck so far. Will see what my hoster says.

    #1046897

    My guess for now is that it is connected with WPML and its not-yet-compatibility with PHP 7.3.
    Opened a separate ticket there as well. Lets see what they think.

    #1047077

    Hi,

    @michaelH: Thanks for the info. By the way, you can manually flush the permalinks in your functions.php file if the dashboard is not accessible.

    https://codex.wordpress.org/Function_Reference/flush_rewrite_rules

    Best regards,
    Ismael

    #1047080

    Hi Ismael

    Thanks a lot for your input, but this sounds quite risky to me:

    However, this is an expensive operation so it should only be used when absolutely necessary.
    […]
    This is bad practice.

    And also:
    // do not use on live/production servers

    So I think I will just wait and be patient for now.

    Cheers and thanks
    Michael

    #1047085

    Hey!

    It is bad if you’re calling it on every page load. You can add it to your functions.php file. refresh the page once or twice and then remove it.
    For safety purposes, create a backup first. Or do it on a dev site.

    Cheers!
    Ismael

    #1047212

    Hi all

    The issue in my case was actually my hosters “fault”.
    There was a bug in their nginx configuration which has been resolved now.

    I am currently using PHP 7.3 without any issues.

    @ismael: Please close this thread.

    Thanks and cheers
    Michael

    #1047614

    Hi,

    Thanks for the update. We’ll close the thread now.

    Best regards,
    Ismael

Viewing 21 posts - 1 through 21 (of 21 total)

The topic ‘Enfold and PHP 7.3’ is closed to new replies.