Tagged: , ,

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #522214

    Hello,

    I have a problem using enfold with the popular form builder called Formidable. The arrows inside dropdown fields are not shown. Everything else is working like a charme but the dropdown arrows are disappeared. How do I get them back?

    You will find the form I’m talking about below.

    Thanks
    mindator

    #522304

    Hi mindator!

    Please add following code to Quick CSS in Enfold theme options under General Styling tab

    .frm_style_formidable-style.with_frm_style select { 
    background-image: url(data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAB4AAAANCAYAAAC+ct6XAAAAGXRFWHRTb2Z0d2FyZQBBZG9iZSBJbWFnZVJlYWR5ccllPAAAAyJpVFh0WE1MOmNvbS5hZG9iZS54bXAAAAAAADw/eHBhY2tldCBiZWdpbj0i77u/IiBpZD0iVzVNME1wQ2VoaUh6cmVTek5UY3prYzlkIj8+IDx4OnhtcG1ldGEgeG1sbnM6eD0iYWRvYmU6bnM6bWV0YS8iIHg6eG1wdGs9IkFkb2JlIFhNUCBDb3JlIDUuMC1jMDYwIDYxLjEzNDc3NywgMjAxMC8wMi8xMi0xNzozMjowMCAgICAgICAgIj4gPHJkZjpSREYgeG1sbnM6cmRmPSJodHRwOi8vd3d3LnczLm9yZy8xOTk5LzAyLzIyLXJkZi1zeW50YXgtbnMjIj4gPHJkZjpEZXNjcmlwdGlvbiByZGY6YWJvdXQ9IiIgeG1sbnM6eG1wPSJodHRwOi8vbnMuYWRvYmUuY29tL3hhcC8xLjAvIiB4bWxuczp4bXBNTT0iaHR0cDovL25zLmFkb2JlLmNvbS94YXAvMS4wL21tLyIgeG1sbnM6c3RSZWY9Imh0dHA6Ly9ucy5hZG9iZS5jb20veGFwLzEuMC9zVHlwZS9SZXNvdXJjZVJlZiMiIHhtcDpDcmVhdG9yVG9vbD0iQWRvYmUgUGhvdG9zaG9wIENTNSBNYWNpbnRvc2giIHhtcE1NOkluc3RhbmNlSUQ9InhtcC5paWQ6RjBBRUQ1QTQ1QzkxMTFFMDlDNDdEQzgyNUE1RjI4MTEiIHhtcE1NOkRvY3VtZW50SUQ9InhtcC5kaWQ6RjBBRUQ1QTU1QzkxMTFFMDlDNDdEQzgyNUE1RjI4MTEiPiA8eG1wTU06RGVyaXZlZEZyb20gc3RSZWY6aW5zdGFuY2VJRD0ieG1wLmlpZDpGMEFFRDVBMjVDOTExMUUwOUM0N0RDODI1QTVGMjgxMSIgc3RSZWY6ZG9jdW1lbnRJRD0ieG1wLmRpZDpGMEFFRDVBMzVDOTExMUUwOUM0N0RDODI1QTVGMjgxMSIvPiA8L3JkZjpEZXNjcmlwdGlvbj4gPC9yZGY6UkRGPiA8L3g6eG1wbWV0YT4gPD94cGFja2V0IGVuZD0iciI/Pk5mU4QAAACUSURBVHjaYmRgYJD6////MwY6AyaGAQIspCieM2cOjKkIxCFA3A0TSElJoZ3FUCANxAeAWA6IOYG4iR5BjWwpCDQCcSnNgxoIVJCDFwnwA/FHWlp8EIpHSKoGgiggLkITewrEcbQO6mVAbAbE+VD+a3IsJTc7FQAxDxD7AbEzEF+jR1DDywtoCr9DbhwzDlRZDRBgACYqHJO9bkklAAAAAElFTkSuQmCC)!important;
    }

    Best regards,
    Yigit

    #759251

    I have this same problem. No arrows on Formidable dropdowns in Enfold. I tried the above code but it does not work. Any other suggestion?

    Thx

    #759542

    Hi draig,

    Could you post a link to the site in question so that we can take a closer look please?

    Best regards,
    Rikard

    #759562

    Hi,

    Here is the link to the form…

    The dropdown look just like text fields in Safari. In Firefox there is a dropdown arrow

    #761835

    Hi draig,

    There is an js error in disable-gf-fields.js?ver=7f1db0f… and that base64 image data also gives an error net::ERR_INVALID_URL. You should check for the correct encoding of the image in their (Formidable) styles and see if that base64 still gives a valid image.

    Let us know if you have any more questions.

    Best regards,
    Victoria

    #762136

    Hi Victoria,

    Thanks for the reply… I don’t really understand much of what you said… and I don’t know what “You should check for the correct encoding of the image” means.

    Cheers

    #762187

    Hey!

    She means that – you need to check with formable pro, the issue is somewhere there and not listed on theme.
    It is not something related to our theme.

    Thank you for your understanding

    Cheers!
    Basilis

    #762188

    Thanks! I’ll do that

    #762383

    Formidable suggested this

    #top select, #top .avia_ajax_form .select, #top .entry-content-wrapper
    select {
    -webkit-appearance: menulist !important;

    Now the dropdowns look like dropdowns

    #763332

    Hi draig,

    This is what is in file

    
    jQuery(document).ready(function($){
    	$(".disabled input").attr('disabled','true');
    	$(".readonly input").attr('readonly','true');
    });
    
    $(document).bind('gform_post_render', function(){
    	$(".readonly input").attr("readonly", true);
    	$(".disabled input").attr("disabled", true);
    });
    

    This give Javascript error, because it should be

    
    jQuery(document).ready(function($){
    	$(".disabled input").attr('disabled','true');
    	$(".readonly input").attr('readonly','true');
    });
    
    jQuery(document).bind('gform_post_render', function(){
    	$(".readonly input").attr("readonly", true);
    	$(".disabled input").attr("disabled", true);
    });
    

    I still don’t see the arrows in Chrome on Mac and in Firefox I see the browser arrows not Formidable. Looks ok in Safari. Google fonts are blocked, because you’re requesting them over http, instead of https.

    Let us know if you need any more help from our side.

    Best regards,
    Victoria

    #763919

    gform is Gravity Forms, not Formidable (we use both)

    Also, you wrote
    “Google fonts are blocked, because you’re requesting them over http, instead of https.”

    How do I correct this?

    #765689

    Hi draig,

    I see you got your arrows back and no more arrows with fonts. Great job! :)

    Let us know if you have any more questions.
    Best regards,
    Victoria

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.