Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #242738

    Hi, i installed woocommerce and create a variable product with different size. When it publish it and go to the product page
    http://yannickbardagi.com/photographe/produit/photographie-bebe-n1/ as you can see i don’t have the Button ” Add to cart ” that show up
    like in this example http://kriesi.at/themes/enfold/product/eva-solo-my-teapot/

    Everything works fine on Simple product, i just have this issue with the variable product. Any tips to fix that ?
    Ps : i’am running the lastest Enfold version + the lastest woocommerce version too.

    #242826

    Hi Stephane!

    Please add following code to Quick CSS in Enfold theme options under Styling tab

    .single_variation_wrap {
    display: block!important;
    }

    Cheers!
    Yigit

    #253532

    Hi Yigit, I’m sorry if this is seen as highjacking the post, but I had this issue and tried the fix you suggested. It worked for displaying the add to cart button, but when I select an option and click on the button it just refreshes the page and does not add item to cart. Please help?

    Thanks in advance!

    #253795

    Hi!

    @styletheluxe: Thank you for the update. If you don’t mind, we would like to see the actual website where this is happening. Please post the website url here or open a new thread then post the website link there.

    Best regards,
    Ismael

    #257393

    Hello, I had the same problem. The quick CSS worked, however the add to cart button bounces when it shows up. You can see it here http://www.gcoutureshop.co.za/product/animal-print-cardigan-dpamn01/

    Is there a solution?
    I deactivated all the plugins and it also didn’t change.

    Thanks
    -Nicolas

    #257602

    Hello, I had the same problem.

    I updated the CSS and it brought up the add to cart button, but when I select an option and click add to cart, it returns a message saying ‘Please choose product options…’.

    Sample product is here http://themakeupfactory.com.au/product/flawless-mineral-foundation-suvi/

    Also, the ‘clear selection’ does not work.

    Thanks
    Julie

    • This reply was modified 7 years ago by  bluff03.
    #258241

    Sorry to bother you again, but could somebody please have a look at this, as my client wishes to sell her products now.

    #258453

    Hi!

    @bluff03 Please deactivate all active plugins except for WooCommerce and check if that helps

    Cheers!
    Yigit

    #258784

    Hello, I’m also still having this problem. Are there any ideas? I deactivated all my plugins but it still has the same jumping effect on the add to cart button after I added the quick CSS code posted here.

    =Nicolas

    #258909

    Hey!

    Please add following code to Quick CSS as well

    .single_variation_wrap { height: auto !important; }

    Cheers!
    Yigit

    #259114

    Thanks Yigit, now the description/review box is jumping.

    Please check this page http://www.gcoutureshop.co.za/product/animal-print-cardigan-dpamn01

    Thanks,
    Nicolas

    #259129

    Hey!

    Please add following code to Quick CSS as well

    form.variations_form.cart { height: 187px !important; }

    Best regards,
    Yigit

    #259296

    @yigit thank you for your quick responses, unfortunately I have deactivated all plugins and I still have the same issue. I have also added all the CSS in the other posts.

    Please refer this URL: http://themakeupfactory.com.au/product/flawless-mineral-foundation-suvi/

    Does not recognise that a variant is selected and the *clear selection* does not work.

    Any other suggestions?

    #259626

    Hey!

    Thank you for the update.

    Please try to add this at the very bottom of functions.php:

    add_action( 'wp_print_scripts', 'avf_descript_cart_fragments', 100 );
    
    function avf_descript_cart_fragments() {
        wp_dequeue_script( 'wc-cart-fragments' );
        return true;
    }

    Let us know what happens. We’ll check it again after.

    Cheers!
    Ismael

    #259649

    @ismael, thank you, this has worked. I put it in the child functions.php, so it won’t be overwritten. Will this fix be included in the next version?

    Awesome, work and fast response. :D

    #259869

    My apologies, but I think this may have now caused another issue.

    You can no longer see the ‘cart’ icon that usually pops up top right of the page. Also, you can see that there are no products showing in the cart in the cart widget.

    http://themakeupfactory.com.au/product/flawless-mineral-foundation/

    There are currently two products in the cart.

    #259878

    Hi!

    Thank you for the info.

    I just tested if the snippet above will fix the script error on the console and it does remove the errors but somehow break the cart icon and the cart widget. Please remove the code on your child theme functions.php. I’ll ask Dude to check this. Also, please visit the wp-content/plugins folder then remove any unused plugin folders there.

    Regards,
    Ismael

    #260088

    Hi!

    1) Please Update WooCommerce & Enfold to the latest version.

    2) Revert Ismael’s code mod.

    3) Deactivate all plugins except WooCommerce and check if the issue persists. If not activate the plugins one by one to find the conflicting plugin.

    Best regards,
    Peter

    #260216

    @dude, I have done as requested and all works well. I have also re-activated my plugins and everything is still working.

    Thank you and Ismael for the help.

    Cheers
    Julie

Viewing 19 posts - 1 through 19 (of 19 total)

The topic ‘Enfold : Add to cart button not showing up on variable product’ is closed to new replies.