Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1292198

    Hello everyone, I need to solve a problem urgently and, unfortunately, I still haven’t found the solution :-(
    Therefore, Enfold 4.8.1, Max Mega Menu plugin that does not work when viewing the mobile version (it is not possible to click the hamburger icon).
    Also in the manufacturer’s official website the problem is mentioned but I can’t get it to work.
    Has anyone solved it?

    Here the link of the manufacturer: https://www.megamenu.com/documentation/enfold/

    Thanks in advance to those who can fix the problem!

    #1292529

    Hi elfuego1340,

    Can you give us a link to your site? so we can take a closer look.

    Best regards,
    Nikko

    #1292606

    Hi Nikko! I have prepared a test site for you to perform all the checks .. I have looked for tutorials everywhere but it seems that there is nothing for the version of Enfold 4.8.1 that solves the problem with Max Mega Menu on mobile devices :-(
    I have clients who I have bought your theme but who need this plugin and unfortunately the plugin support always refer me to the theme programmers.
    Well Nikko, I hope it works out!
    I have already installed the plugin, if you reduce the size you see that the hamburger icon is not clickable .. I think it is a Java script conflict problem, that of Enfold that overlaps that of the plugin (perhaps it would be enough to disable the native Enfold script) .
    Thanks in advance!

    • This reply was modified 3 months, 4 weeks ago by  elfuego1340.
    #1292805

    Hey,

    I went to Enfold theme options > Performance and disabled “Javascript file merging and compression” and that helped.
    Please review your website :)

    Regards,
    Yigit

    #1292832

    Hi Yigit, thanks for the answer .. unfortunately I had already tried this procedure and if you try, the Enfold menu is always active :-( I tried with a standard theme and obviously it works .. but I don’t want to give up Enfold. something programmatically to eliminate in order not to start the Enfold mobile menu.
    Can you solve? The manufacturer’s website also mentions the problem but it doesn’t work ..

    http://i.szoter.com/e20138e5bee765d7

    #1292834

    Maybe I found the solution :-) I run some tests and then write here!

    #1293164

    Hi,

    Thanks for the update. We’ll keep this thread open for you.

    Best regards,
    Rikard

    #1311436

    Hello elfuego1340

    Did you solve your problem with that?
    I have the same situation on my side. Disabling “Javascript file merging and compression” it solve the issue but the website is slower.
    Maybe you can share your solution.

    Thank you.

    #1311899

    Hi Holla! Sorry if I haven’t written the solution before, I humbly ask for forgiveness. So to get the MegaMenu to work you need to add this code CSS in Enfold:

    /*MAX MEGA MENU*/
    @media only screen and (max-width: 989px) {
    .responsive #top #wrap_all .main_menu,
    .responsive #top #wrap_all .av_mobile_menu_tablet .main_menu {
    display: none !important;
    }
    .responsive #header_main_alternate,
    .responsive #top #wrap_all #header_main_alternate .main_menu,
    .responsive #top .av_mobile_menu_tablet #header_main_alternate {
    display: block !important;
    position: relative;
    }
    .responsive .av-burger-menu-main,
    .responsive.html_mobile_menu_tablet .av-burger-menu-main {
    display: none !important;
    }
    }

    and thus configure in Enfold performance:

    http://i.szoter.com/8b220952272bf39a
    http://i.szoter.com/316c6a6bedf72ffd

    I hope I was useful, have a good day everyone!

    #1312011

    Hi elfuego1340,

    Thanks for sharing your solution, it’s much appreciated :-)

    Best regards,
    Rikard

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.