Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #1216263

    Dear Support,

    on my complete website, i have now gaps. If I compare older cached version and the new, I see added rules:

    #top .flex_column_table {
    float: left;
    margin-top: 50px;
    }

    Is it from you and why? What is to do to get old behavior and my known design?
    Best

    S.

    #1216368

    Hey S.,

    Could you post a link to where we can see the problem you are having please?

    Best regards,
    Rikard

    #1216703

    Same problem for me as well. Every page that’s using 2/3 1/3 (within color section), which is at top of every webpage except home page now got an added 50px top margin with 4.7.5. Example page if you still need it. If I have time, I’ll try to remedy, so gap maybe gone by then.

    This is culprit – in avia-merged-styles CSS file:

    #top .flex_column_table {
    display:table;
    table-layout:fixed;
    width:100%;
    float:left;
    margin-top:50px
    }

    #1216706

    Adding this did the trick for now, but like OP, still wondering why was added.

    #top .flex_column_table {margin-top:0 !important;}

    #1216947

    Hi lampije,

    Glad you got it working for you! :)

    If you need further assistance please let us know.

    Best regards,
    Victoria

    #1217733

    Dear Rikard,

    it’s now inside the corresponding source code.
    margin-top:50px is added without any input from us for my understanding.

    Best

    S.

    #1219451

    The problem is something to do with the default margins on the paragraph ALB element.

    If you insert a paragraph and tick the box for custom margins and set the top to 0px it solves the problem.

    Enfold – Can you look into this and why it is applying itself after the update to the latest version?

    • This reply was modified 4 months, 2 weeks ago by  thinkjarvis.
    #1219538

    Hi @thinkjarvis

    You mean, I should go to >15 clients, hundreds of thousands of pages and go to every section to set a new value?
    I use this:

    #top .flex_column_table {margin-top:0 !important;}
    

    Because the 50px is a new feature inside enfold since last update. I overwrite it and I have the same layout as before.

    Best

    S.

    #1219723

    No it was just a solution that didnt require modifying the CSS.

    I am using your method. Not entirely sure of the purpose of adding 50px as default. Looks like a mistake to me!

    #1219740

    Confirm same behaviour across all sites – ruins layouts – must be a bug surely. Can we pls get confirmation of forthcoming fix so that we can deal with this accordingly?

    #1220741

    Hi,

    We will forward the issue to our channel. For now, you can use the css code that @Hokuspocus suggested above.

    #top .flex_column_table {margin-top:0 !important;}
    

    Best regards,
    Ismael

    #1221236

    Hey!

    The top margin was added because of inconsistency between columns with equal and non-equal heights. Columns with individual heights have a 50px top margin by default, but when set to have equal heights, the top margin is not added, so we adjusted the css a bit. The css might be retained in future updates.

    Regards,
    Ismael

    #1221254

    Hey Ismael – yes, problem is a lot of us have compensated for this already – not sure why you need to force any top margin on columns really, I end up having to strip them off anyway for more layout control. Personally I’d have gone the other way and removed the top margin value from individuial heights. Anyway – consistency is always a good thing – thanks.

    #1221288

    I’m still trying to figure out what I am going to do long-term. I’ve set them to 0 when first noticed this got added, but this was only for the first template section on each page as it made it look terrible.

    Now, have had to live with all others set at 0 when 30 was our standard that we took the time to implement already between all the different sized margins as you said. This took us a lot of time and effort.

    Perhaps you could add this to the main Enfold Theme Options and let the user decide what’s best for their site? It would be much better than any scenario for nearly any user I can envision.

    Thanks much.

    #1221292

    It is always an Enfold issue that things have to be changed, and we then have to change this ourselves at our expense to our clients. This is very rude of Enfold and not fair.

    Many of us have been using Enfold for years, and we have accepted many things and built the rules the way they were delivered. For new users this is ok. But to change existing things just like that. I don’t see this explicitly described in the change log either.

    And how often did the answer come: “You can change it manually. Enfold doesn’t care about that. We override you. No matter what you say.” That is, what i understand, what you’re want telling me. I find it very sassy and encroaching.

    #1222046

    Hi,

    @lampije, @m1000000, @Hokuspokus

    Yes, we’ll add the top margin to the columns by default. Other users noticed that there were irregularities between equal and non-equal height columns, so we added the previous css in an attempt to fix the issue and make the column layout consistent. We would like to apologize for the inconvenience.

    We’ll probably add this one in the next update:

    #top .flex_column_table.av-equal-height-column-flextable:not(:first-child) { margin-top: 50px; }
    

    This is the previous thread and the reason why the default top margin was added: https://kriesi.at/support/topic/same-height-column-does-not-work/#post-1206143

    Best regards,
    Ismael

    #1229013

    EDIT: I moved it up higher on my CSS and all the sudden it works.

    This is definitely frustrating. I agree it should be removed.

    I used #top .flex_column_table { margin-top:0 !important;} and it didn’t solve it.

    • This reply was modified 3 months, 1 week ago by  sproutstudio.
    • This reply was modified 3 months, 1 week ago by  sproutstudio.
    #1229315

    Hi sproutstudio,

    Great, I’m glad that you got it working and sorry again for the problem.

    Best regards,
    Rikard

Viewing 18 posts - 1 through 18 (of 18 total)

You must be logged in to reply to this topic.