Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #961321

    Hi Guys!

    I just updated a site on my dev server to WP 4.9.6 and Enfold 4.4. I wanted to try some of the new performance settings, so I went to the Theme Options page, Performance tab. When I turned on CSS and JS compression, it was fine, but the performance increase wasn’t what I was expecting. However when I set Disable Template Builder Elements to Load Only Used, it broke the layout of the Content Slider on the home page. If I leave it on Always Load All, the slider is fine. The site is running PHP 7.1, but I put it on 5.6 temporarily and it made no difference.

    The slider in question is on the home page, down just a bit on the right side under the heading The MAGLOGIX® Product Family. I put the site in a test area and created an admin login for you guys so you can check it out. Please see the private content below.


    Hey scotthco,

    When you disable the elements, are you clearing your cache?

    Best regards,


    Hi Basilis:

    I don’t use the caching plugin on the development server, so that’s not an issue. I set it to Load Only Used Elements on the Performance tab of Theme Options, made sure to empty my browser cache, and the problem still occurs in Firefox, Chrome, MS Edge, and IE 11.




    Sorry for the late reply.

    Thank you for reporting this bug.

    For the moment I deactivated “Disable the blog” and this fixed the problem.

    We will try to find the reason why this breaks the layout and will add the fix to one of the next releases (hopefully the next).

    Best regards,



    I found a solution:




    Do not forget to make a backup of the original file for a fallback.

    Best regards,


    Thanks, Gunter! That did the trick!



    Great, glad you got it working. Please let us know if you should need any further help on the topic or if we can close it.

    Best regards,


    Will this be incorporated in an update.
    I had the same problem but I don’t feel the need to implement this patch as disabling the blog probably won’t make a whole lot of difference.


    Hi mcdragon,

    This should be implemented in the next update since the issue is confirmed and the solution is already provided by Günter.
    For the meantime since the update isn’t released yet, you can follow the instruction and modify: enfold\config-templatebuilder\avia-shortcodes\contentslider\contentslider.php

    Best regards,


    Hi Nikko

    Will wait till the update goes live but there was an update yesterday 4.4.1 – does this one not address the issue?



    Hi Martin,

    I have checked contentslider.php on Enfold 4.4.1 and the code for the fix is there, have you tested it out?
    If that still causes issues, please try to modify contentslider.php (line 37):

    wp_enqueue_style( 'avia-module-postslider' , AviaBuilder::$path['pluginUrlRoot'].'avia-shortcodes/postslider/postslider.css' , array('avia-layout'), false );

    then replace it with (basically just commenting it out):

    // wp_enqueue_style( 'avia-module-postslider' , AviaBuilder::$path['pluginUrlRoot'].'avia-shortcodes/postslider/postslider.css' , array('avia-layout'), false );

    Let us know if this helps.

    Best regards,


    Seems to be working fine now. Thank you.
    Only disabled the blog and using 4.4.1


    Hi mcdragon,

    Glad that it’s working properly now :)
    Feel free to comeback if you need further assistance.
    Thanks for using Enfold and have a great day!

    Best regards,

Viewing 13 posts - 1 through 13 (of 13 total)
  • The topic ‘Enfold 4.4 Breaks Content Slider Layout’ is closed to new replies.