Tagged: ,

Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #947471

    Since the update to Enfold 4.3, the background image is no longer found, as soon as I activate the option “CSS file merging and compression”.

    The image is always searched in the following path. I think that’s a bug?

    • This topic was modified 6 years, 1 month ago by MSchrauf.
    #947853

    I have the same problem with background images that I set in Theme options -> General styling.
    It looks like it’s referring to a dynamically created URL, but it’s a 404 for all images:
    https://koltsokosan.hu/wp-content/uploads/dynamic_avia/koltsokosan.hu/wp-content/themes/enfold/images/background-images/gradient-bottom-light.png

    #948428
    #948490

    same problem

    #948500

    Hi MSchrauf,

    Could you please give us a link to your website, we need more context to be able to help you.

    Best regards,
    Victoria

    #948501

    Hi Vrout,

    Could you please give us a link to your website, we need more context to be able to help you.

    Best regards,
    Victoria

    #948604

    Hi Victoria,

    Please find in private content the link to the website that doesn’t load image-background since enfold last update + a screenshot so you can see where the image background doesn’t load (one example).

    When I inspect the page, I can see that the url to the background image has changed, in now has a “dynamicavia” and others new “words” inside the url.

    Thank you

    #948651
    This reply has been marked as private.
    #949142

    Yesss – same problem. As soon as I enable the CSS file merging and compression, the body background image (to be set in “general styling”) disappears. The body background color is still working, but the structure, formed by the image vanishes. I tested in several of our websites. It is always the same.

    #949941

    Hi,

    We pushed the issue to the development team. To fix the issue temporarily, just copy the css code and put the correct path. Put it on the Quick CSS field to override the one with the invalid path.

    Best regards,
    Ismael

    #952552

    Hi!

    We would like to implement a few changes in your installation. Please provide the WP/FTP login details. Or edit the config-templatebuilder > php > asset-manager-class.php file, replace everything with this code.

    // https://pastebin.com/T4aYxGX4

    Don’t forget re-minify the css files aflterwards.

    Regards,
    Ismael

    #952596

    Thank you very much. You probably meant the following file:
    wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/asset-manager.class.php

    At least I entered the changes in this file and it works. ;-) Thank you!

    #953124

    Hi!

    @MSSchrauf: Thank you for the confirmation. This is going to be included in the upcoming patch.

    Regards,
    Ismael

    #953187

    Wonderful. Thank you for the excellent support.

    #953525

    Same problem So what should I overwrite or replace?

    #953963

    Hi,


    @MSchrauf
    : Ah yes. That’s the one. Thanks. :)


    @uuniversal
    : You should update this file. wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/asset-manager.class.php

    Use this code. https://pastebin.com/T4aYxGX4

    Best regards,
    Ismael

    #954135

    @Ismael
    I copied the php page into the old file. Then I downloaded the file and renamed it to asset-manager.class.php. Neither worked.
    For now the only solution was to disable “CSS file merging an compression”.
    Does that slow down the site much?

    #955165

    Hi,

    It will affect the size of the page but the speed will still depend on a lot of other factors like content, images, hosts, hardware etc. The compression is a small part of it.

    Best regards,
    Ismael

    #1089839

    Hi,

    We just update our enfold version and had a same problem.
    The image doesn’t load in few pages.

    #1090242

    Hi Rieckermann GmbH,

    Please open a new thread and include admin login details in private so that we can have a closer look at your site.

    Best regards,
    Rikard

Viewing 20 posts - 1 through 20 (of 20 total)
  • You must be logged in to reply to this topic.