Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #859595

    I updated wordpress to 4.8.2 , since then google map not loading .

    #859972

    Hey idvisionme,

    Your map is displaying fine on my end, did you try to clear your browser cache and reload the page?

    Best regards,
    Rikard

    #865690

    Hello Rikard ,

    It was working fine for few days . Now still the same issue .

    Kindly check-

    #866123

    Hi,

    Thanks for the feedback. It’s not working on my end either. You are getting the following error message:

    You have included the Google Maps API multiple times on this page. This may cause unexpected errors.

    Are you running any plugins which uses Google Maps as well? If so then try to disable them.

    Best regards,
    Rikard

    #866125

    if so Rikard is right – ( and i use sometimes mappress pro plugin) you can avoid loading enfolds google routine by:

    add_filter('avf_load_google_map_api', 'disable_google_map_api', 10, 1);
    function disable_google_map_api($load_google_map_api) {
            $load_google_map_api = false;
            return $load_google_map_api;
    }

    The third party plugin got his own loading routine so after that you can use nevertheless the enfold google alb element.
    But first : aktivate the api on Enfold dialog.
    On my case the third party plugin got his own input field for api code.

    #866589

    Hi,

    Thanks for the input @guenni007 :-)

    Best regards,
    Rikard

    #867175

    Hi Rikard & Guenni007 ,

    I’m not using 3rd party google map plugin . I have only Enfold default google map .
    It was working fine , after upgrading enfold issue started .Even now I deleted the multiple entries of Google map API , having only 1 API key now . Still issue not resolved . Kindly help

    thank you

    #867187

    Hi, I’d like to stay updated on this post!
    I have the same problems with the Google Maps element, on 2 pages:
    https://www.passe-partout.nl/locaties/
    https://www.passe-partout.nl/projecten/

    The steps I took to try solve the issue:
    – Update everything : WP, theme, plugins
    – Disable all plugins
    – Search on internet
    – Try in different browsers
    – Update the Google API settings (put the 2 pages in the Google API settings)
    – Watched the JS consone in Chrome, giving the following error: Google Maps API error: RefererNotAllowedMapError https://developers.google.com/maps/documentation/javascript/error-messages# (Purchase code hidden if logged out)
    Your site URL to be authorized: https://www.passe-partout.nl/projecten/ < this I already did!

    Still no improvements.
    The weird thing is dat it does show the map for a second and then immediately shows the error.
    Please, do you see the same on these pages, and do you know how to resolve this?

    Best regards, Marcel.

    #867327

    Hi Marcel,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Please check functions.php for the function with the key for the maps and remove it. You have 2 keys in two different places.

    Best regards,
    Victoria

    #867356

    Hi Victoria,

    Thank you so much! Apparently the wrong key was in the functions.php. I erased that and immediately it works :) Next time I’ll check that first :)

    Best regards, Marcel

    #867459

    Hi Marcel,

    Great, glad you got it working and thanks for the feedback. Please let us know if you should need any further help on the topic.

    Best regards,
    Rikard

    #871615

    @victoria: SAVED MY DAY! Couldn´t find a solution for “Google Maps Error” on my site for 3 days. There was an old API Key in my child theme functions.php. Wouldn´t have found it in a hundred years! THANKS SO MUCH!

    #872023

    Hi marcolemgo,

    Great, glad we could help :-)

    Best regards,
    Rikard

    #876288

    Thanks for posting this. I was having this problem, also. For others with this issue, THIS is the fix. There was a time, many Enfold versions ago, when there were Google API issues with the map on the contact page. Someone came up with a workaround at that time that involved adding some code (and your Google API key for the map) to the child theme functions.php file. I had forgotten about it, and the old API key on that functions.php file was causing the problem. I deleted the workaround code from the child theme functions.php and all is well now. With newer versions of Enfold, the API key created via the Google Developers Console should be entered in the Enfold Theme Options area (under Google Services) of the WP dashboard.

    • This reply was modified 1 week, 2 days ago by  promosapien.
    • This reply was modified 1 week, 2 days ago by  promosapien.
    #876602

    Hi,

    Thanks for sharing @promosapien, much appreciated :-)

    Best regards,
    Rikard

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.