Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
    Posts
  • #1174898

    Hi Support
    Wishing you and all the team a very Happy New Year 2020 !

    I encounter a strange problem : I’ve developped a site on my own server, then export all the parameters, media, text on the new server. Everything is quite ok, but the layer slider’s list is empty on the back office, althought there’s 7 active slider well displayed in the front.
    I tried to re-import the various slider on my new hosting..Still empty list.

    What should tou recommand to solve this problem ?

    Kind regards !

    NB : WordPress core + plugins + theme up to date, PHP 7.2

    #1175212

    Hey Ikyo,

    Please post us your login credentials (in the “private data” field), so we can take a look at your backend.

    1. Install and activate ” Temporary Login Without Password “.
    2. Go to ” Users > Temporary Logins ” on the left-side menu.
    3. Click ” Create New “.
    4. Add the email address for the account ( you can use (Email address hidden if logged out) ), as well as the ” Role ” making that the highest possible and the expiry about four days
      ( to be sure that we have enough time to debug ).
    5. Click ” Submit “.
    6. You’ll now have a temporary account. Please provide us here in the private section the URL, so we can login and help you out.

    When your issue is fixed, you can always remove the plugin!
    If you prefer to not use the plugin, you can manually create an admin user and post the login credentials in the “private data” field.

    Best regards,
    Basilis

    #1175274

    Many thanks for your quick answer
    It has been done

    #1175757

    Hi,

    Thanks for the update, but I can’t see any login details in this thread. Please try to send them again.

    Best regards,
    Rikard

    #1176218

    Hi Rikard
    Please find then Within

    Kind regards

    #1176587

    Hi,

    Thank you for the update.

    We tried to access the site but the login credentials seem to be invalid. Please check the info carefully or provide another user account.

    The following thread might be related to this issue.

    // https://kriesi.at/support/topic/layer-slider-fails-on-enfold-update-4-6/#post-1159740

    Best regards,
    Ismael

    #1178095

    Many thanks Ismael

    I’ve update and change the password, so the access will be granted now.
    I’ve also followed the recipe you gave with the database
    I’ve add a column in wp_layerslider with an SQL command

    ALTER TABLE wp_layerslider
    ADD group_id INT NULL

    The column have been created, but whithout effect.
    Please help and give a step to step method, because I encounter this similar issue in another site (with enfold theme) since last update

    Many thanks
    Kind regards

    #1178556

    Hi,

    Thank you for the update.

    An error still occurs in the database same as in the previous thread.

    SELECT SQL_CALC_FOUND_ROWS *
    FROM wp_layerslider
    WHERE group_id IS NULL
    AND flag_deleted = '0'
    ORDER BY <code>date_c</code> DESC
    LIMIT 0, 25
    
    Error: Unknown column 'group_id' in 'where clause'
    

    Are you sure that the new column was added correctly?

    Best regards,
    Ismael

    #1178583

    Hi Ismael

    I’ve re-added the column and seen it appear in PHPMysql
    Same (no) result for the moment
    What should I do now for this aprticular site and another (who is running with enfold and present the same issue ?).

    Many thanks Ismael

    #1178610

    Hi,

    Is it alright if we access the database? Please post the login details in the private field. We’ll try to check it.

    Thank you for your patience.

    Best regards,
    Ismael

    #1178614

    Yes it’s allright
    I’ve installed an extra plugin to do so (please see the private content), because the client does not control the database access which is on a foreign server.

    Thks !
    Best regards

    • This reply was modified 2 months ago by  Ikyo.
    #1179268

    Hi,

    Thank you for the access.

    We changed the default value of the group_id column from NULL to None and the type to tinyint. The sliders are displaying properly now.

    Best regards,
    Ismael

    #1180174

    Many thanks for your work
    The slider have always been correctly displayed in the front office
    But they’re always missing in the back office :(

    Sorry

    #1180207

    Hi,

    Thank you for following up.

    They are now displaying in the backed but without the previews. Please check the layer slider panel again and try to remove the browser cache prior.

    Best regards,
    Ismael

    #1181867

    Hi there,

    we have the same problem: suddenly the slider appears in the frontend, but not in the backend. After reading your instructions, we compared the wp_layerslider table in the MySQL DB with the same table in another Enfold project, where everything works correctly.

    We noticed that the fields group_id and flag_group are missing in the table of the faulty layer slider. We created these manually and provided them with the same values as in the correct table, but without success.

    We then changed the original type INT to TINYINT, but also without success. So we went through the proposed solution, but are stuck.

    We ask for quick help.

    Thank you very much.

    #1181871

    …and sorry but nothing change on my side either
    I had wait, hoping the problem will cure by itself after your intervention
    Empty my cache, navigate in private mode
    Update with the last enfold theme

    Still nothing in the back-office
    Many thanks for your help

    Regards

    #1182564

    Hi there,
    we were able to solve the problem that an already created slider is shown in the frontend, but not in the backend.
    Here is a brief overview of what we have tried:

    • Create new slider – did not work
    • Followed the instructions described by Ismael – no result
    • WordPress database repaired and optimized – no result
    • All plugins deactivated – no result
    • layerslider.php whitelisted in security plugins – no result
    • Bought a separate license for Layer Slider, downloaded the plugin and installed it separately – no result
    • The Layer Slider plugin deactivated and reactivated – no result
    • New slider created – New slider was displayed in the backend, but the original slider was no longer displayed in both the backend and the frontend
    • Newly created slider deleted – Original slider reappeared in the frontend, but still did not appear in the backend
    • Compare the original slider and the newly created slider in the database – the only difference was that in the first group_id was "0" and in the new one was "NULL"
    • Database entry edited for the original slider, value for group_id changed from "0" to "NULL" – THE SLIDER APPEARED IN THE BACKEND AND NOW EVERYTHING WORKS AS IT SHOULD!

    This solves the problem for us. I hope that with this description I have helped someone to save time, nerves and money.
    Best regards

    #1182610

    Thanks for you useful return of experience
    Problem is the actual and invisible slider ine the B.O have already a NULL value in an added column named group_id
    A new slider created has the exact same values, column by column
    So i’m stuck :(

    • This reply was modified 1 month, 3 weeks ago by  Ikyo.
    #1182684

    Hi,

    @ikyo: Did you refresh the page before checking the backend? The sliders are there, but without the preview as we previously mentioned. Please check the screenshot of the dashboard or the layer slider panel below.

    Screenshot: https://imgur.com/a/YGbrFlx

    @heartbit: Thank you for the info.

    Best regards,
    Ismael

    #1184120

    Hi, I am also dealing with this issue. Letting you know as to whether this is widespread. I was presuming an update would sort it out, but…
    I will take a look at Heartbit’s solution…
    Cheers, Iain

    #1185053

    Hi,

    Yes, we encountered a few threads with this issue. What is the version of your theme prior to the update? It seems to be happening on installations that upgraded from a very old version of the theme containing a different version of the layerslider.

    To fix the issue, you have to manually create the group_id column in the layer slider table. Please check the following thread.

    // https://kriesi.at/support/topic/layer-slider-fails-on-enfold-update-4-6/#post-1159740

    Best regards,
    Ismael

    #1185590

    Hi, Thanks for that,
    Not sure where I updated from, could well be it was a bit behind.
    I have added the ‘Group_id’ in the layer slider table, but it hasn’t fixed the issue for me. I was wondering if you could take a look.
    The login details are in the private section.

    Cheers, Iain

    #1186261

    Hi,

    @iainski: Thank you for the info. We installed the Query Monitor plugin, but we are not seeing the query error related to the group_id column in the layer slider panel same as we had seen on other installation, so this is probably different. Please create a new thread/ticket and post the login details (WP, FTP and MySQL) in the private field. We’ll close this thread for now.

    Best regards,
    Ismael

Viewing 23 posts - 1 through 23 (of 23 total)

The topic ‘Empty list slider in layer slider’ is closed to new replies.