Tagged: , , ,

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #1112923

    Hi,

    I just noticed that all of my blog posts have duplicate h1 tags. In addition to standard h1 tag that I added by myself to titles <h1> title </h1> the theme adds this one automatically: <h1 class=’post-title entry-title’ > Post Title <span class=’post-format-icon minor-meta’></span> </h1>

    The same issue was already discussed in this thread, but I tried the offered solution and it didn’t work for me (I checked after clearing the cache, cookies and so on).

    Thanks in advance for your help!

    Regards,
    Artem

    • This topic was modified 1 year, 12 months ago by  artemtik.
    • This topic was modified 1 year, 12 months ago by  artemtik.
    #1113272

    Hey artemtik,

    Could you please attach some screenshots of the issue?

    Best regards,
    Victoria

    #1113280

    Hi Victoria,

    Sure! Please, see below:

    #1113380

    Hi artemtik,

    Thank you. Looks like the first is the post title rendered by the code and the second one is manually added to the post content. Am I correct?

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Best regards,
    Victoria

    #1113393

    Looks like the first is the post title rendered by the code and the second one is manually added to the post content. Am I correct?

    Yes, that’s right. I have added manually h1 tag in text editor. And that’s the way I would like to do it – to have a full control over them.

    Thanks,
    Artem

    #1113693

    Hi Artem,

    If you want full control you can use the Advanced Layout Builder to build post, then you will have to add all the elements manually. Please try that.

    Best regards,
    Victoria

    #1113712

    I just want not to have any auto generated H1 tags. I don’t want to use ALB for several reasons.

    Also, I have quite a lot of posts to re-build them in ALB even If I wanted to do it.

    There was a solution in another thread I mentioned above, but for some reason it doesn’t work for me. I would be really thankful if you can help me to have no auto-generated H1 with the default editor.

    #1113885
    #1114212

    Hi Artem,

    Can you please have Appearance > Editor enabled?

    Best regards,
    Victoria

    #1114221

    Hi Victoria,

    Done ;)

    Best regards,
    Artem

    #1114434

    Hi Artem,

    Please disable all caching for now too.

    Best regards,
    Victoria

    #1115429

    Hi Victoria,

    Sorry for the delay – I was offline for a few days.

    I’ve disabled cache plugin and CDN for now.

    Best regards,
    Artem

    #1116054

    Hi,

    Thank you for the update.

    That is the default post title container. If you want to remove it, use the following snippet in the functions.php file.

    remove_filter( 'post-format-standard', 'avia_default_title_filter', 10, 1 );
    

    OR edit the includes > loop-index.php file and remove this code (line 286).

    echo $title;
    

    Best regards,
    Ismael

    #1116097

    Hi Ismael,

    Thank you for your help. Adding the snippet in the functions.php didn’t work for me. But removing echo $title; has done the job!

    Thanks once again for your help.

    Best regards,
    Artem

    #1116322

    Hi,
    Glad Ismael could help, unless there is anything else we can help with on this issue, shall we close this then?

    Best regards,
    Mike

    #1117402

    Hey Mike,

    Yes, sure – you can close the thread now.

    Thanks once again, and have a great day ;)

    Best regards,
    Artem

    #1117421

    Hi,

    I’m glad this was resolved. If you need additional help, please let us know here in the forums.

    Best regards,
    Jordan Shannon

Viewing 17 posts - 1 through 17 (of 17 total)

The topic ‘Duplicate H1 tags in posts’ is closed to new replies.