Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #1310037

    Hello,

    For some reason the drop down menus on “treatments” and “products” are not opening on desktop. Mobile seems to be fine.

    Can someone look in to why? They were working,

    • This topic was modified 2 weeks, 6 days ago by  damon129.
    #1310256

    Hey damon129,

    Please send us a temporary WordPress admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,
    Rikard

    #1310294
    This reply has been marked as private.
    #1310371

    Hi,

    Thanks for that. It’s working when I’m logged in, although the mega menu seems to be displaying a bit too high. It’s not working when I’m logged out though, which suggests that the problem might be caused by caching or minification. Could you try clearing the cache from your caching plugin, or disable it temporarily please?

    Best regards,
    Rikard

    #1310391

    Cache cleared and also turned off minification. No change.

    #1310488

    Hi,

    Did you try to disable the plugin? If not, then please try that out. We can try it out for you if you give us permission to do so.

    Best regards,
    Rikard

    #1310489

    Plugin disabled and no change. Feel free to test / turn off on your own as well. I turned it back on for the time being.

    #1310591

    Hi,

    Thanks for the update. Could you disable the CDN which is active on the site as well please? See private for example. Note that the theme doesn’t apply any caching to your content.

    Best regards,
    Rikard

    #1310619

    There is no CDN running on the site. I’m not sure what I’m supposed to do with the CSS file in private data. Please advise.

    #1310633
    This reply has been marked as private.
    #1310635
    This reply has been marked as private.
    #1310800

    Hi,

    Thanks for the update. I’m not sure what is going on with your site, but it seems like it’s still being cached even after turning off WP Rocket. It doesn’t show the same results when logged in though, which again suggests that the problem is caching. I’m seeing correct results when logged in, but not when logged out and checking in private/incognito browser windows. Please see private for an example. I’ve left your caching plugin deactivated, and file compression in the theme options as well. It might be a good idea to keep it like that for at least a few hours, to see if the caching expires after that.

    You might want to reach out to WP Rocket support as well, to see if they can help you with clearing all caches, since it doesn’t seem to do that even though the plugin is disabled.

    We don’t have any other support option other than this forum.

    Best regards,
    Rikard

    #1310885

    Ok, it would seem that the CDN is not the issue. Here is what I have done to try to isolate the issue.

    1. I copied the current site to a dev instance: https://rmsdev21.wpengine.com/ You can see the dropdowns are now working but not in the right place when they open.

    2. I restored production a previous backup to a point where the dropdowns were working. You can now see this on: https://radiancemedspaatlanta.com/

    3. I also turned the CDN back on for production and as you can see it’s still working.

    So the difference between the two installs is this: dev is running your theme version 4.8.3, and prod is running version 4.8.1 with jquery active. It would seem to me that there is an issue with the theme.

    Can you please advise?

    #1311043

    Hi,

    Thanks for the update. If we could reproduce the problem on 4.8.3 then yes, it might be theme problem. I’m not able to reproduce the problem though, please see private, and we have no other reports of any other users having this problem. The fact that your dev site is displaying different results if you are logged in or not, is not a theme problem either, it’s very likely that your caching plugin is responsible for that. You can easily verify this behaviour if you are logged in, and check the names and locations of the style sheets, then compare the names and locations of the style sheets when not logged in. Like the example in my last reply; that is theme style sheet, but it’s being served from a location which is not generated by Enfold. Note the /cache/min/1/ folder structure.

    Best regards,
    Rikard

    #1311140

    I’m going to take this to my server admin to investigate more. On this site, https://rmsdev21.wpengine.com/, can you please tell me:

    1. Where my theme files should be served from?
    2 An example of where they are serving from the wrong place.

    Thanks,

    #1311418

    Hi,

    Thanks for the update.

    1. It depends if you are using a caching plugin or a CDN, both of those will change the location from where your resources are being served from.

    2. Ties in with 1. It doesn’t really matter where your resources are being served from, as long as things are working as they should. When you sought help from us, then we started debugging the problem. In this particular case, it seemed like caching was responsible for the problem, since the site is displaying different results depending if you are logged in or not (most caching plugins do not show cached content for logged in users). Like the file example in private, that file should not be served if all caches are cleared, and the plugin is disabled. The problem here was that is was being served, even though the plugin was disabled and caches were cleared from it. If it was being served from the theme, it would look like the second line in private, as an example. Please note the extra folders in the first example, which is likely coming from the caching plugin. Also, the avia-merged-styles-xxx.css file should only be served if file compression is active under Enfold->Performance. If it’s not, then you should see multiple, differently named CSS files being served from the theme.

    Best regards,
    Rikard

Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.