Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #997926

    Hello Kriesi Support,

    We want to use the option “Load only used elements (recommended)” under “Disabling of template builder elements”. For normal pages it works great. But we have some customisations in our websites and sometimes (if we use enfold shortcodes) Enfold does not know that we do. We see errors like “his element was disabled in your theme settings. You can activate it here: Performance Settings”. This is also if we use Enfold shortcodes in widgets (think that’s a bug).

    How can we fix this? How do we tell Enfold we are using those shortcodes? Some code in private content.

    Cheers,
    Nico

    #998254

    Hey vdlpwp,

    Thank you for using Enfold.

    We have a shortcode called [vdlp_sc_page_content] which gets the content of a given page.

    Have you tried the builder’s Page Content element? I think it’s the same as your shortcode.

    Best regards,
    Ismael

    #999270

    Hello Ismael,

    Thanks for your reply. I will take a look at the Page Content Element.

    Cheers,
    Nico

    • This reply was modified 2 years, 7 months ago by  vdlpwp.
    #1000199

    Hello Ismael,

    Can you also give your thoughts about the use of Enfold elements in WP Widgets? If you use them the error is also displayed. Can’t you use the shortcodes in widgets?

    For example icon in text-widget:

    [av_font_icon icon='ue854' font='entypo-fontello'][/av_font_icon] 123 456 789

    Cheers,
    Nico

    #1000574

    Hi,

    Using an icon shortcode in a text widget should work without any issue. Please make sure the shortcode is pasted in text view of the editor.

    If you still have any issue please post the WordPress login details in private content area so we can take a closer look at it.

    Best regards,
    Vinay

    #1011357

    Hello Vinay,

    Need some more help, see private content for info. Thanks!

    Cheers,

    Nico

    #1011596

    Hi,

    I think you see that notice because your shortcode is not recognized by the builder manager. Again, you can replace that shortcode with theme’s Page Content because that element was specifically created to show the content of a particular post or page.

    Best regards,
    Ismael

    #1011707

    Hello Ismael,

    Thank you for the reply.

    It’s not only our shortcode, issue 1-3 we do not use this shortcode. It’s default Enfold Avia shortcodes. Could you look again? Also some extra info in private content.

    Cheers,
    Nico

    #1011887

    Hi,

    1-2.) This is certainly a bug. We’ll report the issue to the dev team. The builder manager doesn’t include the shortcodes in the widget areas. Please set the theme to load all elements temporarily. Or as a workaround, try to disable the default footer columns and then set a custom footer page. Go to the Enfold > Footer panel and then set the “Default Footer & Socket Settings” to “Select a page to display as footer and socket”.

    3.) This is the same bug as the previous one. The footer columns are visible across the site and they don’t have to be updated per page, so I don’t think it’s necessary to use your custom shortcode or the theme’s Page Content element in that area.

    Best regards,
    Ismael

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.