Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1043903

    Hi Everyone,

    We are an Enfold user that does not want to use the Gutenberg Block Editor. If that makes us Luddites, so be it.

    We thought we had solved the problem by installing the “Disable Gutenberg” plugin two days ago, but for whatever reason that stopped working today (10h00 USA EDT). We disabled the plug-in and then added this code to the very bottom of functions.php file for Enfold Parent, which appears to turn off the block editor completely:

    add_filter(‘use_block_editor_for_post’, ‘__return_false’);

    Two questions:
    1. Should we copy over the modified functions.php to Enfold Child?
    2. Is there a better way to turn off the Block Editor?

    Thanks!

    Cliff Brody

    #1044190

    Hi Cliff,

    If you don’t want to use Gutenberg at all then yes, please deactivate it using this code in your child theme functions.php file:

    // disable for posts
    add_filter('use_block_editor_for_post', '__return_false', 10);
    
    // disable for post types
    add_filter('use_block_editor_for_post_type', '__return_false', 10);

    We will likely add a theme option for this in a coming release as well.

    Best regards,
    Rikard

    #1044389

    Thank you, Rikard. A perfect fix! Best, Cliff

    #1044812

    Hi Cliff,

    Great, glad we could help :-)

    Please let us know if you should need any further help on the topic or if we can close it.

    Best regards,
    Rikard

    #1044882

    Hi Rikard, thank you again. For sure you can close this! Wishing you all the happiest of holidays and the best for the coming year! Cliff

    #1045259

    Hi Cliff,

    Great, thanks for letting us know. Happy holidays to you too :-)

    Please open a new thread if you should have any further questions or problems.

    Best regards,
    Rikard

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Dealing With Gutenberg After Disable Gutenberg Plugin Stops Working’ is closed to new replies.