Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1046970

    Hi team,

    The portfolio grid shortcode doesn’t have full functionality when used in a sidebar. The grid is displayed but the sorting options are unavailable. I think the CSS classes are not being picked up by the portfolio.js when the shortcode is in the sidebar, so the animations are prevented from working.

    Is this deliberate or a bug? Is there a way we can get this working?

    Many thanks,
    Joe

    • This topic was modified 7 months ago by  JoeLovell.
    #1047432

    Hey JoeLovell,

    Best regards,
    Victoria

    #1049279
    This reply has been marked as private.
    #1049775

    Hi,
    Sorry for the late reply, I have tested your issue on my localhost and will report this to the dev team.
    In the meanwhile I have found that if you use the widget area element to create a “sidebar” on your page, the sort option will show and work correctly.
    2019-01-03-212811

    Best regards,
    Mike

    #1050086

    Hi Mike,

    Thanks, I thought this might be the case. Looks like the js doesn’t select the correct classes when the element is in aside instead of main.

    Please could you let me know an eta on fixing the issue (or a temporary patched js file). This site is relatively close to launch and it’s a lot of work to create manual widget area elements for every page that needs this sidebar.

    Many thanks,
    Joe

    #1050147

    Hi,
    I will keep you updated, Thank you for your patience.

    Best regards,
    Mike

    #1052538

    Hi,
    Good news, the dev team has corrected the issue and it be in the next update. But for now you can use this patch.
    Please download the zip file in the Private Content area, and extract it, then upload the two files to your
    /enfold/config-templatebuilder/avia-shortcodes/portfolio/
    directory.
    You will need to ensure the new files overwrite your cached files, please disable your Enfold Theme Options > Performance > JS & CSS file merging and compression for testing, afterward enabling again should overwrite the cache.
    Also clear your browser cache a few times.
    Then you will need to wrap your shortcode in the widget with this div:

    <div class=" (Purchase code hidden if logged out) ">
    [your shortcode]
    </div>

    2019-01-10-173131
    I tested this on my localhost, but please let us know if it also works for you.
    Thanks again for your patience.

    Best regards,
    Mike

    #1052734

    Hi Mike,

    This is excellent. We’re close to launch and today was going to be the day I tried to fix it myself so I’m very pleased your devs beat me to it.

    Thank you.

    #1052741

    Hi,
    Glad to hear, I’ll report back that the solution works for you, unless there is anything else we can help with on this issue, shall we close this then?

    Best regards,
    Mike

    #1052742

    You can, thanks

    #1052752

    Hi,
    Glad we were able to help, we will close this now. Thank you for using Enfold.

    For your information, you can take a look at Enfold documentation here
    For any other questions or issues, feel free to start new threads under Enfold sub forum and we will gladly try to help you :)

    Best regards,
    Mike

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Portfolio shortcode not working in widget area’ is closed to new replies.