Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1293060

    Hello,

    Can anyone direct me to the correct solution?

    The customer hasn’t updated their website since 2016.

    We’re running now
    PHP 7.4.16
    MariaDB 10.4.8.
    and a new version of WordPress

    I have followed the steps from this thread –> https://kriesi.at/support/topic/updating-to-enfold-4-5-and-validating-personal-token/
    After updating the theme the website reports the following: A critical error has occurred on this site.

    What should be my next step

    #1293068

    Debug update.

    Fatal error: Cannot redeclare av_countdown_events_fallback() (previously declared in /var/www/vhosts/DOMAIN.EXT/httpdocs/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/events_countdown/events_countdown.php:16) in /var/www/vhosts/DOMAIN.EXT/httpdocs/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/events_countdown.php on line 12

    • This reply was modified 6 days, 1 hour ago by  studiojumble.
    #1293074

    I am one step further after reading this thread https://kriesi.at/support/topic/problems-with-enfold-in-combination-with-wordpress-5-6/#post-1283825

    I uploaded the newest version of the theme to a separate folder via FTP and called it enfold_new. After that i changed the name of the old folder to enfold_old, and the new one to only enfold.

    #1293086

    Hurray! The website can now partially be visited again.

    unfortunately the front page doesn’t work yet.

    ——
    Debug ‘spits out’ the following messages:

    Notice: Trying to access array offset on value of type null in /var/www/vhosts/DOMAIN.EXT/httpdocs/wp-content/themes/enfold/config-layerslider/LayerSlider/assets/classes/class.ls.sources.php on line 57

    Deprecated: contextual_help is verouderd sinds versie 3.3.0. Gebruik in plaats daarvan get_current_screen()->add_help_tab(), get_current_screen()->remove_help_tab(). in /var/www/vhosts/DOMAIN.EXT/httpdocs/wp-includes/functions.php on line 5236

    #1293240

    I have removed LayerSlider from the front page. This made the front page visible again.

    Is there any possibility to fix LayerSlider?

    #1293272

    Hi,

    Thanks for contacting us!

    I see that you are currently using the latest version of Enfold and WordPress so you should not be having this issue.

    If you are still having it, please post temporary FTP and WP admin logins here privately so we can look into it :)

    Regards,
    Yigit

    #1294063

    Hi Yigit,

    If I encounter any problems, I will contact you.
    At the moment everything is running fine.
    Thanks for the fast support.

    #1294069

    Hi,

    You are welcome! :)

    For your information, you can take a look at Enfold documentation here – https://kriesi.at/documentation/enfold/

    If you have any other questions or issues, feel free to start a new thread under Enfold sub forum and we will gladly try to help you :)

    Enjoy the rest of your day!

    Best regards,
    Yigit

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘critical error after update from version 3.5.4. to version 4.5’ is closed to new replies.