Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #802587

    This is most likely a silly question but I haven’t seen it in the documentation- what is the best way to set up a onepage site, like the one page portfolio demo?

    Do you simply create a single page with multiple areas (that you can link in menus) or multiple work pages that act as a ‘front page’?

    Thanks, Christian

    #802843

    Hey silvercorn,

    You only create one page, then you give ID’s to Color Sections to act as anchors. You then link to those anchors under Appearance->Menus. For example:

    http://your.site/#anchor

    Best regards,
    Rikard

    #803725

    Hi Rikard,

    I have tried this but for some reason the menus dont seem to work. To specify, I have added ‘Banner’, ‘TheSound’, ‘TheBand’ and ‘Contact’ as section IDs for 4 Color sections and added them to the menu, as .no/#Banner etc. Any tips?

    #803728

    Hi Rikard,

    I have tried this but for some reason the menus dont seem to work. To specify, I have added ‘Banner’, ‘TheSound’, ‘TheBand’ and ‘Contact’ as section IDs for 4 Color sections and added them to the menu, as .no/#Banner etc. Any tips? The permalink simply leads to the root domain if that makes any difference.

    #803762

    Hi,

    Did you use the full URL of the site? Please see private for example. Also, the anchors are case sensitive, so #Anchor is not the same as #anchor.

    Best regards,
    Rikard

    #804441

    Hi Rikard,

    I am doing exactly as suggested but for some reason the menus are not working. I’m not placing the hashtag in the Section ID, just the exact letters (tried both though). Does it matter how the permalink are set? Are there any other settings that would affect the menu links?

    Bets regards,
    Christian

    #804816

    Hi,

    Please send us a temporary admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,
    Rikard

    #804979

    Sure thing, appreciate it Rikard.

    Best regards,

    #805625

    Hi, this is still broken and apart from reinstalling I have no idea what is wrong. I may have missed something but I think I have done everything right. Please find an admin user attached.

    Best regards

    #806315

    Hi,
    Ok I fixed the menu for you, your menu links were to new pages.
    I created custom links such as #thesound, #theband, & #contact.
    and now they work, please review :)

    Best regards,
    Mike

    #806337

    Hi Mike, thanks for your fix.

    From what you have found I can only conclude that
    – the #anchor has to be all small letters in the meny structure, but not necessarily in the ID sections.
    – no full urls are necessary, as suggested.

    I think this indiscrepancy should probably be fixed in the next update. I suggest maybe posting a short video intractable for the one page setup.

    Again, thanks for your help Mike!

    #806340

    Hi,
    Glad we were able to help, we will close this now. Thank you for using Enfold.

    Best regards,
    Mike

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Creating a one page site’ is closed to new replies.