Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1154737

    Hello,
    when I last checked my contact page I realized that Google Maps shows an error und checked my API Key in the Enfold backend. It says: “Could not connect to Google Maps with this API Key”. I have no idea why the key should not work anymore. Also tried it with a new key but without success – it’s alyways the connection issue. There is no restriction enabled.

    Enfold: 4.6.3.1
    PHP version: 7.3.11
    MYSQL: v10.4.9-MariaDB-1:10.4.9+maria~bionic

    Enabled APIs for the project:
    Geocoding API
    Maps JavaScript API
    Directions API
    Distance Matrix API
    Geolocation API
    Maps Elevation API
    Maps Embed API
    Maps SDK for Android
    Maps SDK for iOS
    Maps Static API
    Places API
    Roads API
    Street View Publish API
    Street View Static API

    #1154930

    Hey Neverlands,

    Credentials did not work for me. Could you please update the credentials?

    Best regards,
    Victoria

    #1155011

    Hello Victoria,
    sorry for the inconvenience – I’ve created a new password for you.

    I double checked the Google payment methods and – in deed – the credit card was expired so I set up my actual one.
    But still the Enfold backend cannot connect with the API key.

    • This reply was modified 1 week, 2 days ago by  Neverlands.
    #1155161

    Hi,

    Thanks for the update and login details, I see that you haven’t added an API key under Enfold->Google Services. Did you remove it from there? If not then please try to add it back again to see what happens then.

    Best regards,
    Rikard

    #1155211

    Hello Rikard,

    no, I didn’t remove it. It’s Enfold’s behaviour.
    This is what I do: I enter an API key and save all changes,
    Then I hit “Check API key”.
    I get the error message: “Could not connect to Google Maps with this API Key”
    After this the key gets removed from the field.

    I save one now without hitting “Check API key”.

    #1155213

    Update: When I just saved the Key without hitting “Check API key” the console showed a new error message: You must enable Billing on the Google Cloud Project at https://console.cloud.google.com/project/_/billing/enable Learn more at https://developers.google.com/maps/gmp-get-started

    I didn’t know before that I had to upgrade something, I just had the billing account connected. So I followed the link and upgraded the Google Cloud project. Now it is working!
    Thank you very much for your help.
    Best regards,
    Marion

    #1155320

    Hi Marion,

    Great, I’m glad that you got it working and thanks for the update. Please let us know if you should need any further help on the topic or if we can close it.

    Best regards,
    Rikard

    #1155406

    Hello Rikard,

    yes you can close the topic :)

    Best regards,
    Marion

    #1155486

    Hi,

    Thanks for letting us know, I’ll close this thread for now then. Please open a new thread if you should have any further questions or problems.

    Best regards,
    Rikard

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Could not connect to Google Maps with this API Key.’ is closed to new replies.