Viewing 24 posts - 1 through 24 (of 24 total)
  • Author
    Posts
  • #1272555

    Hello Kriesi Support,

    Hope you’re keeping safe and well.

    I’ve been trying to update the Copyright to show “2021”, but after changing this from “2020” and saving, I see the web page loses the background image set in the “Footer” section.

    Have tried changing the image, and adjusting settings to tile/not tile and it makes no difference.

    Can you point me in the right direction please?

    Many thanks,
    Graham

    #1272624

    Hi Graham,

    Thanks for providing the screenshot.
    I have checked for the footer image and it seems to be coming from a different domain (link in private content) and when checking on it, the link requires username and password before you can view the image. Please try to re-upload the image on your site (current domain).

    Best regards,
    Nikko

    #1272810

    Thank you Nikko!

    I’ve saved and re-upload the image to Media and attached to Footer, and it is now displaying on desktop but not on mobile, where it’s reverting to the default blue background only.

    Another thing I’m finding odd is that when editing “Footer” > Background Image > Position of Image, there is no difference shown to the image regardless of whether I pick Top Left, Top Center, or Top Right.

    Admin credentials shared in Private Content Below For Your Use.

    Many thanks,
    Graham

    #1273187

    Hi Graham,

    Thanks for giving us admin access.
    I tried to check on the issue and I noticed that Positions of the image does not work if the child theme is used, on the parent theme it works properly.
    There may be some codes (most likely in footer.php) in the child theme that affects this feature.

    Best regards,
    Nikko

    #1297237

    Thank you Nikko!
    Sorry for the vert late response – appreciate your feedback.
    Warm wishes,
    Graham

    #1297254

    Hi Graham,

    No worries and you’re welcome :)
    Just let us know if you need further assistance.

    Best regards,
    Nikko

    #1297386

    Thank you Nikko,
    The reason I came back to this thread yesterday is that I have just experienced the same issue – with the footer image disappearing – but this time when I updated the parent theme. I’ve been able to share your response, of Jan 18, with the creator of the child theme and hope to find an ongoing remedy for this recurring issue.
    Any thoughts/feedback are welcomed!
    Warm wishes,
    Graham

    #1297466

    Hi Graham,

    I have checked your site (link in private content) and it seems to show the footer background image properly and I could also check in the backend that you’re already using the child theme.
    Can you setup a staging site for us? so we can update it to the latest version of Enfold and see how the issue recurs and try to fix it, I believe last time it was just singled on the child theme.
    Here’s a simple tutorial on how to setup a staging site: https://themeisle.com/blog/wordpress-staging-site/

    Best regards,
    Nikko

    #1297631

    Thank you Nikko,

    Yes the footer image is displaying as I rolled back the site and restored from a backup – that I’d made before updating the parent theme.

    The site has a Staging environment (at getFlywheel.com) – would you be able to use that instead of my needing to create a new staging site as per your suggested method/link?

    Best wishes,
    Graham

    #1297714

    Hi Graham,

    Yes, that would be fine as well.
    Can we ask for login link as well as credentials for the staging site?

    Best regards,
    Nikko

    #1297731

    Thank you Nikko,

    Info attached below, and I appreciate you taking a look at this!

    Best wishes,
    Graham

    #1297732

    PS – Additional info also shared in Private Content.
    Thank you,
    Graham

    #1297733

    Sorry, one final note in Private Content below:

    #1298210

    Hi Graham,

    Thanks for setting up a staging site.
    I have updated it to the latest version and the issue I have with it is partial background image.
    I have added this CSS code in Quick CSS and it fixed the issue:

    #footer {
      background-attachment: scroll;
    }

    Best regards,
    Nikko

    #1298233

    btw: if you put this to your child-theme functions.php:

    function year_shortcode() {
      $year = date('Y');
      return $year;
    }
    add_shortcode('year', 'year_shortcode');

    you can use the current year as shortcode in your content: [year]
    on footer you now can insert: © [year] … whatever you like [nolink]
    last shortcode you know is to get rid of backlink : powered by Enfold

    #1298301

    Hi Guenni007,

    Thanks for helping out :)

    Best regards,
    Nikko

    #1298353

    Hi Nikko,
    I do appreciate you looking at this and for the CSS code & I see the footer working.
    Another issue I have noticed is that image/buttons do not work as they should on rollover. Previously an arrow would appear on rollover, but now it’s not showing any change on rollover. This Dropbox link in private content shows two screen shots showing BEFORE (Dec 30 2020) and CURRENT (May 1 2021) button differences.
    Many thanks,
    Graham

    #1298354

    Thank you Guenni007,
    Graham

    #1298381

    again btw:
    you can extend this shortcode by f.e.:

    function show_date_with_shortcode() { 
      date_default_timezone_set('Europe/Berlin');
      setlocale(LC_TIME, 'de_DE.UTF-8');
      $uhrzeit = date_i18n( 'l, \d\e\n ' . get_option( 'date_format' ) . ' ' . get_option( 'time_format' ). ' \U\h\r'  );
      return $uhrzeit ;
    }
    add_shortcode( 'show-date', 'show_date_with_shortcode' );

    shortcode is then : [show-date]

    the get option is concerning to that what you have set on Dashboard – Settings – General : “Date Format” and “Time format”

    you see the timezone setting and if there must be binding words the letters had to be escaped
    f.e. on german “Uhr” for hour and “den” for the may the fourth be with you :lol

    see here in the socket: https://webers-testseite.de/pureinstall/#socket

    #1298633

    Great to know Guenni007 – thank you! Graham

    #1298788

    Hi,
    Glad to see that Guenni007 was able to help you with this, and it seems that your question has been resolved, shall we close this thread then?

    Best regards,
    Mike

    #1298836

    Hi Mike,

    Guenni007’s response didn’t address the issues I’m having with image rollovers not working.

    Another issue I have noticed is that image/buttons do not work as they should on rollover. Previously an arrow would appear on rollover, but now it’s not showing any change on rollover. This Dropbox link in private content shows two screen shots showing BEFORE (Dec 30 2020) and CURRENT (May 1 2021) button differences.

    Many thanks,
    Graham

    #1298870

    so post your code that you entered to the footer copyright input field on enfold options.
    i guess that there are some html tags or a non closing bracket (f.e. on the nolink shortcode ) in it that causes the issue.

    My snippet from above was only intended to avoid such input errors by automatically changing the copyright year to the new year.

    • This reply was modified 5 days, 5 hours ago by  Guenni007.
    #1298943

    Hi,
    Thank you for the feedback, please try disabling Enfold Theme Options > Performance > JS & CSS file merging and compression and at the bottom of the performance settings page enable the Enfold Theme Options > Performance > Delete old CSS and JS files and then clear your browser cache and any cache plugin, and check.
    If this corrects then you can reset the performance settings back to the way they were.
    I noticed that this css was in your merged css file twice:

    #top .all_colors .image-overlay-inside {
        display: none
    }

    If this is in any of your Quick CSS or custom css, please remove.
    This this doesn’t help please try this code in the General Styling > Quick CSS field or in the WordPress > Customize > Additional CSS field:

    #top .all_colors .overlay-type-extern > .image-overlay-inside {
        display: block !important;
    }

    and then clear your browser cache and check, this should correct.

    Best regards,
    Mike

Viewing 24 posts - 1 through 24 (of 24 total)

You must be logged in to reply to this topic.