Tagged: ,

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #357370

    Email Protection Code (marked as bold below) was added automatically when using CDN from CloudFlare. When this happen the text for field Form Title and Submit Button are ignored and the text is replaced with default text.

    Temporary solution: every time i need to edit the page i have to change “email protection code” with the email before saving. Otherwise the Form Title and Submit Button are restored with default text which are not suitable.

    Any help would be appreciated!

    [av_contact email=’[email protected]<script type=”text/javascript”>
    /* <![CDATA[ */
    (function(){try{var s,a,i,j,r,c,l,b=document.getElementsByTagName(“script”);l=b[b.length-1].previousSibling;a=l.getAttribute(‘data-cfemail’);if(a){s=”;r=parseInt(a.substr(0,2),16);for(j=2;a.length-j;j+=2){c=parseInt(a.substr(j,2),16)^r;s+=String.fromCharCode(c);}s=document.createTextNode(s);l.parentNode.replaceChild(s,l);}}catch(e){}})();
    /* ]]> */
    ‘ title=’……


    Hey Khanh Hong!

    Is this code for protecting your email from robots? If so then it should only be used when your actually listing the email on your site and not with a contact form. Does cloudflare have a setting where you can turn this off? It seems weird that they would be changing it automatically when you update the post.

    I think you will need to contact cloudflare about this. If they don’t have a setting then they probably have a filter you can turn off.

    Best regards,

    • This reply was modified 9 years ago by Elliott.

    The codes lines is not inserted from CloudFlare. It must be Enfold or WP Super Cache. Could you please confirm that Enfold does not insert such code for email protection? Any idea how i can debug this error and find which function add such code?



    No it doesn’t look like it’s from Enfold. Does it get added when you save your page? Be sure to deactivate all plugins while testing.



    Did you get to the bottom of this issue please? I’m having similar issues.



    No, unfortunately not, we don’t have enough information regarding the issue. Is the site using CloudFlare as well? Please contact them regarding the issue. The theme doesn’t have any email protection feature so it’s either the CDN or a third party plugin that injects the script in the contact form shortcode.



    Thank you Ismael. I got to the root of the issue which was, like you say, the CloudFlare CDN. It was simply a setting in there for email security. A toggle switch!

    Just log in to your CloudFlare account in your browser, go to the Security tab and the setting is in there.

    Took me ages to find what was causing the problem, and I’m a little frustrated with myself that I didn’t find it sooner, but very relieved that once you toggle the switch to off then the email addresses are reverted back to how they were originally.

    Hope this helps other people!



    • This reply was modified 8 years, 9 months ago by SimonB.


    Glad you figured it out. Thanks for sharing. :)


Viewing 8 posts - 1 through 8 (of 8 total)
  • The topic ‘Contact Form changes email with Email Protection Code…’ is closed to new replies.