Viewing 30 posts - 1 through 30 (of 33 total)
  • Author
    Posts
  • #621487

    Hi guys,
    Been working on my site all last night, and I can’t figure out why the Avia Editor on most of my pages is still spinning.
    Usually it’s because of a plugin or an old theme version, or a cache problem.

    I will add the login details and the pages that the editor is spinning below in private.

    When I update to 4.5 WordPress my tab, testimonial, and gallery elements broke. I fixed it by adding the code in the functions.php file.
    Everything seemed ok, then tried to edit some of my inner pages and the Avia Editor just keeps spinning.

    I know this is a common problem, I have fixed it a few times but nothing is working this time.

    Things I have tried.
    Updated Theme
    Turned off all plugins, then checked
    Updated WordPress
    Cleaned Cache on both the website, and computer browser…
    Tested on 3 computers, and three browsers…

    I’m stuck now, not sure what else i can do.
    Something is messing with just the inner pages I have added.
    The home page, and a few other pages still work. Strange. I’ll keep investigation but I need your help now.

    Thanks Andy

    #621494

    added some ides to the other post about this.

    check for lingering wordfence WAF entries in your .htaccess files

    #621552

    I deleted my Wordfence plugin would that help, or would the lines in the .htaccess stay there still.
    I’ll take a look.

    #621578

    Nope cleaned out htc access, along with deleting a few plugins.
    Keep working on it.

    #621590

    have you tried updating the wordpress core tinymce js files? I found those were corrupted on a site I support. I manually uploaded via FTP and the issues were corrected.

    ~/your/website/wp-includes/js/tinymce

    • This reply was modified 4 years, 5 months ago by  BeyondBOLD.
    #621817

    Hmmm, not sure how to do that.

    Do I download WordPress, pull out the WordPress tinymce js files and add them FTP?
    I try that…

    Have not heard anything back from support, guess we’re getting lost in the crowd.

    Keep working.

    #622091

    Any further news of this??

    I’m having the same issues. With other themes also.

    Andy

    #622239

    thehijinx,
    yes, that is right. how did it work?

    #622285

    Hi BeyondBOLD…

    No it didn’t fix it. Hmmm I’m not sure I have the skills to try anything else.
    I wonder if doing a manual theme update FTP may help? It did it through the API maybe something was missed.

    Hopefully the Kriesi guys will check it out in the future.
    I can’t update half my website because of the spinning Avia Editor.

    Stumped.
    Andy

    #622292

    Also guys they just updated the Enfold theme, go and do an update :)
    Andy

    • This reply was modified 4 years, 5 months ago by  thehijinx.
    #622303

    did the update fix your problems?

    #622316

    I had to put this code in the functions file at the bottom again…

    ————————-

    function modify_jquery() {
    if (!is_admin()) {
    wp_deregister_script(‘jquery’);
    wp_register_script(‘jquery’, ‘https://code.jquery.com/jquery-1.11.3.min.js’);
    wp_enqueue_script(‘jquery’);
    }
    }
    add_action(‘init’, ‘modify_jquery’);

    ——————-

    Seems to get things back on track, gonna check the spinner, my guess is no.
    fingers crossed.

    #622322

    Nope spinner is going, I’m getting dizzy.

    #622330

    Hi,

    Same issues and tried same thins as you

    Wordpress 4.5. + enfold 3.5.4 + code in functions.php (function modify_jquery ……)

    I hope support may help ?

    • This reply was modified 4 years, 5 months ago by  serge esteves.
    #622335

    I also have the same problem and have had a ticket/thread open for two days on here and still no resolution.

    thehijinx, I have done everything that you have done as well and my head is also spinning.

    I am also hoping SUPPORT can help us SOON.

    #622343

    Hi Beyondbold,

    I applied the tinymce core wp files and still no luck.
    Upgraded the New theme files – no luck
    applied the java patch – no luck
    de-activated all plugins – no luck.

    Any other ideas.

    #622353

    the only thing I can think of without digging into code is to run a virus / malware scan on your site to ensure you don’t have any extra code injected into your files, or extra files being created. I like wordfence personally, but it looks like there might be an issue with it and enfold right now.

    #622359

    Thanks, I have been running these scans since yesterday. I will continue to run more just to verify again.

    Thanks

    #623086

    Up!

    Support! Help ! we are many in this case

    Thanks

    #623155

    I just updated to wordpress 4.5.1 and enfold 3.5.4 with wordfence 6.1.4

    wordfence firewall enabled, avia advanced editor spins
    wordfence firewall disabled, avia advanced editor works.

    #623434

    Agreed, took a day off. Back at it :$

    #623477

    Anyone from Support get a chance to login into my site and see why the Avia is still spinning?
    I may have to start a new treat, seems nobody is home on this one lol

    AP

    #623891

    Up!

    There is someone ?

    #623905

    have you checked that file permissions are all ok?

    #623956

    File permissions on the plugin Wordfence? or theme…
    I’ll try it, just not sure what you mean.

    It’s worth a go.
    Andy

    #624041

    I was reading around and found people had issues with file permission setting on some of the core ajax files. figured it might be worth a go with security plugins changing file permissions in some cases to protect the files.

    #624073

    I found a solution to editing the site for now.
    I have to rebuild the pages, save as a template… and keep doing it over and over again till it’s right…. Yeah, nightmare.

    I can’t waste anymore time, I have a business to run.

    Thanks for the help, I tried everything and still no solution.

    I’ll take another look at those files.
    I’m guessing the permissions are still changed even if the security plugins have been deleted.

    12 support messages over 4 days, and still nobody. bummer.

    #624087

    Thank you, BeyondBOLD! You rescued me after a day of agony trying to figure this out.

    I can also confirm that the Avia advanced editor

      spins when the Wordfence firewall is active
      works when the Wordfence firewall is disabled
    #624334

    @thehijinx
    I checked your backend and can see the issue with the spinning ALB. Though I can’t reproduce it on my end. You are using quite a lot of plugins and you are using a caching Plugin, so go into plugin’s settings and choose to switch off caching. Deactivate this and all other plugins. Afterwards clear browser cache and hard refresh a few times. Finally check if ALB is working fine again.
    If not then there might be some corrupted files, so please delete all theme files completely via FTP, before installing a fresh copy from your themeforest account: http://kriesi.at/documentation/enfold/install-enfold-over-ftp/

    Best regards,
    Andy

    #624570

    Hi,

    I understand better the problem:
    the fact is that wordpress avia editor works with:
    https://code.jquery.com/jquery-2.2.3.min.js
    But the front office don’t (avia animations)
    unless with special code in functions.php that reduce jquery version to 1.11.3

    So avia editor needs jquery 2.2.3.min.js and animations on front office need jquery 1.11.3.min.js to work

    So, Is it possible to modify the code in functions.php :
    ////Bug avia jquery
    function modify_jquery() {
    if (!is_admin()) {
    wp_deregister_script(‘jquery’);
    wp_register_script(‘jquery’, ‘https://code.jquery.com/jquery-1.11.3.min.js’);
    wp_enqueue_script(‘jquery’);
    }
    }
    add_action(‘init’, ‘modify_jquery’);
    ////

    By adding (and forcing jquery-2.2.3.min.js for avia editor) :
    wp_register_script(‘jquery’, ‘https://code.jquery.com/jquery-2.2.3.min.js’);

    But only for avia editor in wordpress back office, not for front

    Is it possible Moderator or someone else, or another better solution?

    PS: i’ve already done all possibilities (deleting and uploading all files by ftp, deactivating all plugins,etc…)

    Thanks

Viewing 30 posts - 1 through 30 (of 33 total)

You must be logged in to reply to this topic.