Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #417293

    Hi,

    I have just realized that since I’ve installed enfold, twelve days ago, I don’t have comments on pages.

    Is there a way to enable comments by default for all pages?

    #417371

    I am using Avia Layout Builder for my pages and I am aware that I can bring back comments with it, but that way I have to do it for every page again and again, and that requires too much time. Is it possible to simply enable comments and comment box for all pages? Thanks.

    #417957
    #456084
    This reply has been marked as private.
    #456096

    Hi!

    Please add Comments element under Content elements of Advanced Layout Builder to the bottom of your post that you have created using Advanced Layout Builder

    Best regards,
    Yigit

    #456314
    This reply has been marked as private.
    #456330
    This reply has been marked as private.
    #456485

    Hi!

    If the post is made with the ALB, yes. If made with the default editor, no.

    Best regards,
    Rikard

    #1041175

    I would like to reopen this discussion because it’s true, if you try to do it with the default editor it is not possible.

    This problem should be solved because it is not correct to be forced to use the ALB on each page just to be able to view the comments.

    does anyone know how to fix this bug?

    thanks

    #1043460

    Hi,

    The comments should display by default when you’re using the default editor. Can you give us a link to the site? Did you adjust the Settings > Discussion options?

    Best regards,
    Ismael

    #1043642

    First of all if I change from text to visual, I lose all the text content, and the comments section is no longer displayed !

    thanks

    #1045189

    Hi,

    Thanks for the update.

    I created a test post and the comment section is visible there. (see private field)
    Where can we see the issue? Please note that you have to manually insert the “Comments” element when you’re using the ALB (Advance Layout Builder).

    Best regards,
    Ismael

    #1045278

    Hi Ismael

    I wrote in the pages, the problem happens in the pages, please try check there.

    thank you

    #1046373

    Hi,

    Did you allow the comments for that particular page? Please edit the page then look for the “Discussions” panel. Tick the “Allow comments” option.

    // https://codex.wordpress.org/Comments_in_WordPress#Turning_on_Comments_for_a_Single_Post_or_Page

    Best regards,
    Ismael

    #1047120

    already done obviously, sorry but there is no one who wants to access the panel and check the problem in the pages?

    #1048149

    Hi,

    Thanks for the update. I see the issue now but I’m not sure what’s causing it. Please edit the includes > helper-assets.php file, look for this code on line 395:

    add_filter( 'comments_open', 'av_comments_on_builder_posts_required', 10, 2 );
    

    Comment it out or disable it temporarily:

    // add_filter( 'comments_open', 'av_comments_on_builder_posts_required', 10, 2 );
    

    Let us know if that changes anything.

    I did access the file server but I think it’s for a different site. To confirm it, I deleted the whole header.php file but it didn’t break the “assicurazioneviaggiothailandia” site.

    Best regards,
    Ismael

    #1048228

    I was experiencing the same issue with comments element not working in ALB and commenting out the code you suggested worked. Thank you!

    #1048659

    Hi imagestudios,

    Glad it worked for you :)

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #1071535

    Hi,

    I just had the same issue and could only solve it this way. I had General -> Discussions the comments allowed, per each post the discussion and comments allowed + I put the comment from the ALB editor on the bottom. Yet the only solution to fix the “comments are closed”-bug by removing this function. Since I use a child theme I put this in my child theme in order not to need to adjust it on every theme update:

    //Remove a function from the parent theme
    function remove_parent_filters() {
    	remove_filter('comments_open', 'av_comments_on_builder_posts_required');
    }
    add_action( 'after_setup_theme', 'remove_parent_filters' );

    But guys, this is a legitimite bug. Please look into this and fix it. Apart from that Enfold is clearly the best theme ever :)

    • This reply was modified 1 month, 3 weeks ago by  Jannis.
    #1072098

    Hi,

    @jannis: Thanks for the info. The problem is that we can’t reproduce the issue on our end, so there is something in your installations that is causing the comments to not display aside from that filter. We would like to test the issue further, but we’ll have to access your site’s dashboard and the file server. Please post the FTP and WP login details in the private field.

    Best regards,
    Ismael

Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.