Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #1198376

    I’d like visitors to my site be able to attach images to their comments on my blog. I added a plugin called DCO Comment Attachment, which adds this functionality. However, when I try using it to upload an attachment larger than about 49kb, the theme takes me to a 404 page regarding /wp-comments-post.php.

    I don’t know how to edit PHP or the theme itself in that way, but I was wondering if someone could help explain how to fix this problem. I’d like visitors to be able to upload files up to 10MB.

    My ultimate goal would also be that commenters could also have some basic editing tools like bold, italic, hyperlink, etc. Other plugin recommendations would be welcome too.

    Any help would be greatly appreciated. Thanks!

    #1199851

    Hi guys,

    Just following up on my post from last week. Not sure if you’re working through this craziness, but I’d love to hear from you. Hope you’re staying safe and healthy!

    Best, George

    #1201213

    Hi,

    Sorry for this long delay. Have you tried to increase the maximum upload size limit to at least 10MB? You can do it by editing the php.ini file or add the config in the .htaccess file located in the root directory of your installation.

    // https://www.cloudways.com/blog/increase-media-file-maximum-upload-size-in-wordpress/

    Best regards,
    Ismael

    #1201240

    Hi Ismael,

    Thanks for you response. Both of those locations show the max size as 1024M already. See the private content for the details.

    #1203237

    Hi,

    Sorry for the delay. Where did you add the form again? We tried to create a page and put the [user-submitted-posts] shortcode within the post editor, but we get an error whenever we try to publish or save the page as draft. Do you experience this issue on your end?

    Please contact the plugin author for additional help.

    Best regards,
    Ismael

    #1203288

    Hi Ismael,

    Sorry, the functionality I’m trying to add is having visitors be able to upload images in their comments. The plugin you reference (user-submitted-posts) is something I added in order for other employees to be able to add their own posts, nothing to do with comments.

    The plugin I was trying to use for adding images to comments is the one called DCO Comment Attachment (currently disable on my site until this gets figured out). If you turn it on, I’ll add a link to the post I was commenting on below. I’m not “married” to this particular plugin though, so if you know of a better way to allow visitors to add images to their comments, please let me know.

    Again, the plugin works, in that it turns on and allows the image upload functionality. It just doesn’t allow any image larger than 49 KB to be uploaded.

    Thanks, George

    #1203957

    Hi,

    We found a few plugins that have the same functionality but they are either deprecated or not available for download.

    Can you check the SFTP account? We can’t access the file server using that info. We would like to enable debugging in your installation — see if we can find anything useful in the logs.

    Best regards,
    Ismael

    #1204010

    Sorry. Try this. I was able to get on with these credentials.

    #1205290

    Hi,
    Sorry for the late reply, I tested the DCO Comment Attachment plugin and it seems to work in my install, I was able to upload large images that your site would not.
    Have you tried disabling your other plugins?

    Best regards,
    Mike

    #1205819

    Yes, I tried deactivating all other plugins. Trying to upload an image still takes you to a 404 error.

    #1206524

    Hi,
    Sorry, I’m not sure why you are getting this error, on a new install it seems to work correctly.
    Try to create the error again and then check your server error log for error messages that could help isolate the cause.

    Best regards,
    Mike

    #1206824

    I just created the error again and I don’t see anything in the error log.

    #1207261

    Hi,
    Try adding this to your wp-config.php via FTP to enable advanced debugging.

    define( 'WP_DEBUG_LOG', true );
    define( 'SCRIPT_DEBUG', true );
    define( 'SAVEQUERIES', true );

    This article explains each of these settings and what to expect from them. This should create a debug log at /wp-content/debug.log

    Best regards,
    Mike

    #1207868

    Below is the content of the debug.log. Can you make sense of it? I don’t know how to read one of those. Thanks.

    #1208147

    Hi,
    Thanks, it looks like you are getting a “Too many connections” warning from your database, it looks like it’s set to 1040 by the max_connections option in your database, if you think you are getting about that much traffic ask your webhost to increase it. This could also be from something else, perhaps the plugin?
    The debug log is only showing Notice & Warning but no errors, so I’m still unsure the cause of the 404, and why I’m not getting it on my install, unless it’s because I have no traffic on my localhost to give me the “Too many connections” warning? Earlier you wrote that you were not “married” to this plugin, did you find any similar plugins? Did you see this one?

    Best regards,
    Mike

    #1208204

    I’ll ask my host about the connections. I did see that plugin but it’s really old so I disregarded it.

    #1208944

    Hi,
    I’m surprised how few plugins there are for this, I would have thought there would be more. It seems many were taken down from WordPress due to security risks, perhaps adding this function adds a vulnerability to your site?

    Best regards,
    Mike

Viewing 17 posts - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.