Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #831590

    Since the last update of Enfold we have a problem with columns inside a row set to “equal height” (doesn’t matter if we vertical align them top or middle): The columns brake into rows but somehow shifted, like a stair case.

    The strange thing is, the problem appears only in the secondary language (English). So it might be a confict with WPML? Theme settings of Enfold are eaxctly the same in both languages.

    You can see the bug here in the light blue bar in the middle of the page: https://www.activemind.legal/en/ –> compared to the German version, where everything is perfect: https://www.activemind.legal/

    #832615

    Hey activemindneudenken,

    Please send us a temporary admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,
    Rikard

    #840839

    Hi Rikard,

    Is there a fix/solution available?
    I have the exact same issue, this also only appears on translated pages. Example: when I remove a random element on the translated page the equal height columns (1/3 1/3 1/3) are displayed vertical instead of horizontal: like 1/1 1/1 1/1 vertical.

    Already did some troubleshooting by saving page as template etc. It only happens with translated pages, and only with columns set equal height.

    #842130

    Hi Rikard,

    I would also like to add that this issue also occurs when removing full-width submenu and some other elements on the page.

    If you need more information please let me know!

    Kind regards,

    #842328

    Hi,


    @hotelsolutions
    : Have you tried moving the columns or set of elements inside their own color section?

    Related thread: https://kriesi.at/support/topic/column-with-equal-height-not-working-in-old-pages/#post-842325

    Best regards,
    Ismael

    #842380

    Hi Ismael,

    Thank you for your reply. I’ve replaced the line (765) in the config-templatebuilder > avia-shortcodes > columns.php file. It does affect the columns. However, the columns are still displayed below each other instead of next to each other (equal height, 1/3 1/3 13).

    Before and after screenshots (afer = after editing columns.php file): http://imgur.com/a/Mj6ou

    It also looks to be a issue with the <!–close column table wrapper. Autoclose: 1–> appearing after each 1/3 column (screenshot can also be found at http://imgur.com/a/Mj6ou )

    #842888

    Hi,

    Did you try our first suggestion? Please remove the modification then move the columns inside their own color section.

    Best regards,
    Ismael

    #842975

    Hi Ismael,

    Sorry, yes I tried. Nothing really happens, same issue is still active after moving columns inside their own color section. It definitely has something to do with the equal height setting. When the first 1/3 column is set to ‘individual height’ the 1/3 columns are displayed next to each other (horizontal). However, with equal height something goes wrong..

    Please let me know if you need any additional information in order to fix this issue.

    Kind regards,

    #843459

    Hi,

    Yes, it’s an issue with the “equal height” settings. The problem is we can’t reproduce it on our local installation. Do you mind posting the FTP details? We would like to do a few tests.

    Best regards,
    Ismael

    #843541

    Hi Ismael,

    Please find the details in the private content section.

    Kind regards,

    #843842

    Hi,

    I think we found the cause of the issue but we’re still formulating a fix for it. We’ll let you know once we found it. Do you mind re-creating the page from scratch? I added those columns alone in a test page and they turned out ok.

    // http://equalheightbug.wpengine.com/fr/test (hosted on WPengine)

    Best regards,
    Ismael

    #848027

    Hi,
    I have the same issue.
    Any solution found?
    Thanks in advance.

    #848923

    Hi,

    We think that the issue is cause by the code block element. Do you have that element in the page? Please remove it temporary, see if it fixes the issue.

    Best regards,
    Ismael

    #852215

    Hi,
    when I remove the code block element, all the columns with “equal height” brake into rows…

    As I can see making a search in google, several people have this isuue…

    have you found any fix?

    Thanks!

    • This reply was modified 6 years, 9 months ago by arreguisergio.
    #852461

    Hi,

    Yes, our developer found the issue with the shortcode tree or structure. We’ll include the patch in the latest version of the theme. For now, please disable the “Equal Height Column”.

    Best regards,
    Ismael

    #852470

    Hi!

    Thank you very much!!!
    Good news :)

    Best regards

    Sergio

    • This reply was modified 6 years, 9 months ago by arreguisergio.
    #852801

    Hi,

    We’ll close the thread for now. Please feel free to open a new one if you need anything else.

    Best regards,
    Ismael

Viewing 17 posts - 1 through 17 (of 17 total)
  • The topic ‘Columns equal height problem in secondary language’ is closed to new replies.