Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #1293302

    I use Color Sections to display custom background images. Different pages have different images. For some reason I can no longer edit or update the background images in these color sections. I use the Advanced Layout Editor in Enfold.

    I go into the Color Section => Styling => Background Image => Insert Image = Media Library => Select Image => Choose “Full Size” from available options => Click Insert => Click Save ……….. this just takes me back to the Avia Layout Builder but nothing has changed. Clicking Update doesn’t have any effect either.

    I have tried creating a new administrator account which did not help. I have tried creating new pages with new Color Sections which did not help either.

    I can get a single background image across the entire site by going to Enfold-Child => General Styling => Main Content => Background Image, but this is not what I want.
    The problem with this is it can’t be customized for individual pages.

    Please help me get these color sections working.



    Hey waltermorgan,

    Thanks for the login details. I’m getting blocked by a firewall though, please see private. Could you turn that off, or let us know from where, and how, we can access your site?

    Best regards,

    This reply has been marked as private.


    Thank you for the update.

    We are still getting denied by the Godaddy firewall. Please check the screenshot below.


    Make sure to temporarily disable the firewall.

    Did you add any content to the color section? If it does not have any content, try to set a minimum height so that it does not collapse.

    Best regards,

    This reply has been marked as private.


    Thank you for the info.

    This is odd. The background image gets automatically removed from the color section when we save the changes. Can we deactivate the security plugin temporarily? You may also have to ask the host if the server cache can be disabled.

    We have also found this error in the browser console, but we are not yet sure what is causing it or why the avia_framework_globals is undefined.

    post.php?post=74&action=edit:99 Uncaught SyntaxError: Invalid or unexpected token

    avia_dynamic_templates.js?ver=5.0:20 Uncaught ReferenceError: avia_framework_globals is not defined
    at avia_dynamic_templates.js?ver=5.0:20
    at avia_dynamic_templates.js?ver=5.0:415

    Best regards,


    I’ve disabled the security plugin. It did not seem to make a difference. All server caching has been disabled.

    You are correct in that the background image get auto-removed from the color section when the changes are saved. The same thing happens to background COLORS inside a color section. Basically the color section won’t save any styling at all.

    Please check the Enfold licensing. We redirected the DNS for this website after a client company name change. I wonder if the license could have an issue with the current domain name, which has changed. I have revalidated the Envato private token several times – it claims to be successful.

    The jQuery Migrate plugin you installed was causing a failure of the Avia editor so I deactivated it. Feel free to reactivate that if you need to.

    This is still a very pressing need for us to get this site ready for graphics.

    Thank you.



    There seems to be an issue with the core WP scripts when we edit a page using the ALB.

    Uncaught SyntaxError: Invalid or unexpected token
    load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.7.1:5 JQMIGRATE: Migrate is installed, version 3.3.2

    To properly debug it, please set these constants in the wp-config.php file.

    define("DEBUG", true);
    define("WP_DEBUG_DISPLAY", true);
    define("CONCATENATE_SCRIPTS", false);
    define("COMPRESS_SCRIPTS", false);
    define("COMPRESS_CSS", false);

    The background image is being saved properly, but it does not show in the front end because the URL is incorrect. (see private field)

    Do you have any idea why the URL is converted to that pattern? And what is the /tp1/ path?

    Best regards,


    I have set the constants you requested in the wp-config.php file.

    I have no idea why the URL is converted to that pattern. Looks like you’ve got two “https:” tags in the same URL. Odd.
    “TP1” is the name of the “test page” I setup for you to work on in WP. You are welcome to create another page, or work on the home page. We can’t use the site until this is resolved, so do whatever you need. Nothing on the site currently is critical or irreplaceable.



    Thank you for the info.

    We still see the same error in the browser console and the core scripts are still concatenated. Are you sure that CONCATENATE_SCRIPTS is set to false? Please post the FTP details in the private field so that we could edit the core files and check the issue further.

    Best regards,


    FTP Details attached in private. The variables were set near the top of the wp-config.php file, which was appropriately commented for reference.



    It seems like the issue is with the server configuration. For some reason a line break is created after the domain name, which breaks a lot of the specified URL. This issue is non-existent on other servers. Example:

    Uncaught SyntaxError: '' string literal contains an unescaped line break
     	avia_framework_globals.gmap_avia_api = '
  ['avia_builder_button'].image = '

    As you can see a line break is created right after the domain name. You may need transfer to a different host or a different server temporarily so that you can start with the site development. Or install a local server so that you can develop the site right in your machine and deploy it once it is ready.

    You should also contact GoDaddy and have them check the issue.

    Best regards,


    Ultimately we scrapped this site with GoDaddy and started with a new one, also on GoDaddy. We used the same URL but went thru the process of cancelling hosting and starting over with a new hosting setup, from scratch. This apparently reset whatever their issue was. Thank you for helping us troubleshoot. We’ve had more than a few issues with GoDaddy’s functionality, but since we have several other sites hosted with them, we wanted to keep everything consistent and use the same host. The new site is hosted with them, has all the same content, yet does not suffer from these issues with the color section.

    I should mention too that we used an outside marketing firm to get this website started. They made the mistake of purchasing the URL, knowing we intended to do all updates after the initial design was completed. Because of this we were not able to transfer ownership of the domain until 60 days after they bought the URL. Then we had to transfer over to our account from theirs. We didn’t wait 60 days to start development however. During that period there was a fair amount of domain forwarding and redirecting as the actual location of the content moved from server to server during transfer of ownership.

    Who knows exactly which step caused it, but it’s comforting to know it wasn’t a problem with Enfold, which we still use for all of our sites. Thanks again for the assistance.



    Great, I’m glad to hear that everything is working as it should now, and thanks for the update. Please let us know if you should need any further help on the topic or if we can close it.

    Best regards,

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.